Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10473 closed defect (fixed)

NPE when trying to simplify roads using modified nevada.sbp

Reported by: arosenberg3@… Owned by: *Martin*
Priority: normal Milestone:
Component: Plugin simplifyArea Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-28 22:35:35
Last Changed Author: Don-vip
Revision: 7347
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-29 00:32:15 +0200 (Tue, 29 Jul 2014)
Last Changed Rev: 7347

Identification: JOSM/1.5 (7347 en) Windows 7 64-Bit
Memory Usage: 303 MB / 989 MB (109 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xms128m, -Xmx1024m]
Dataset consistency test: No problems found

Plugin: FastDraw (30416)
Plugin: SimplifyArea (30416)
Plugin: dataimport (30416)
Plugin: geotools (30569)
Plugin: jts (30416)
Plugin: opendata (30508)
Plugin: pbf (30495)
Plugin: turnrestrictions (30454)
Plugin: utilsplugin2 (30460)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.coor.LatLon.greatCircleDistance(LatLon.java:273)
	at sk.zdila.josm.plugin.simplify.SimplifyAreaAction.averageNearbyNodes(SimplifyAreaAction.java:252)
	at sk.zdila.josm.plugin.simplify.SimplifyAreaAction.actionPerformed(SimplifyAreaAction.java:180)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Don-vip

Component: CorePlugin simplifyArea
Description: modified (diff)
Owner: changed from team to *Martin*
Summary: error when trying to simplify roads using modified nevada.sbpNPE when trying to simplify roads using modified nevada.sbp

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o30623:30625].

comment:3 Changed 5 years ago by Don-vip

Ticket #8210 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain *Martin*.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.