Modify

Opened 6 years ago

Closed 3 months ago

#10424 closed enhancement (fixed)

opening_hours validator fixes all warnings in one but only the selected disappears.

Reported by: ypid23 Owned by: team
Priority: minor Milestone: 20.03
Component: Core validator Version: latest
Keywords: opening_hours Cc:

Description

Steps to reproduce:

  1. Create node with opening_hours=monday, thu 12.00-14.00
  2. Run validation
  3. Expand warnings
  4. Select on one of the four warnings
  5. Click repair.

Result is that only one warning disappears but all of them are fixed in this step. I would expect that all warnings for this value would disappear (maybe after recheck of this opening_hours since a new warning could in very rare cases appear) since the used library https://github.com/ypid/opening_hours.js does not support fixing only specific warnings.

Tested with latest and testing.

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by simon04

Milestone: 20.03
Resolution: fixed
Status: newclosed

Fixed via #18140. For every value tested, org.openstreetmap.josm.data.validation.tests.OpeningHourTest#checkOpeningHourSyntax returns no or one error which may support autofix.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.