Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10422 closed defect (fixed)

Double-clicking .gpx file on Mac OS X doesn't open JOSM

Reported by: Stereo Owned by: team
Priority: normal Milestone: 14.08
Component: Installer MacOS Version:
Keywords: mac osx Cc: cquest

Description

Expected behaviour: JOSM should open the file as if it had been chosen through the file chooser dialog.

Actual behaviour: GPX file opens in another program that registers the .gpx filetype

Similarly, dragging a readable file to JOSM or typing 'open -a JOSM example.gpx' should open the file.

#10025 solved this for .osm files, so hopefully this shouldn't be too complicated :)

Attachments (0)

Change History (13)

comment:1 Changed 5 years ago by Don-vip

Component: CoreInstaller MacOS
Milestone: 14.08

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7441/josm:

fix #10422 - Double-clicking .gpx file on Mac OS X doesn't open JOSM

comment:3 Changed 5 years ago by Don-vip

Can you please check it's working when the mac osx package has been built here? http://donvip.fr/jenkins/job/JOSM/

Thanks.

comment:4 Changed 5 years ago by Don-vip

Does it work? I'd like to have feedback before we release next tested version if possible (end of this week-end if all goes well)

comment:5 Changed 5 years ago by Stereo

It doesn't :(.

I'll try to look into it before then!

comment:6 Changed 5 years ago by Don-vip

I am not sure how to define GPX type. It is not really a UTExportedTypeDeclarations as it is not a format specific to JOSM, but it is not an UTImportedTypeDeclarations neither as it is an exchange format and not something specific to a given software. Do you have any other software registered with GPX files? If yes, can you try to uninstall them to see if it changes something? If no, is there one (registering GPX type) you could install?

comment:7 Changed 5 years ago by Stereo

I have some software that does recognise gpx; my plan is to copy-paste their definition and see how that goes.

While looking at this, I notice that you seem to have defined the JOSM icon as an icon for .osm documents, but with the wrong path. Is that what you intended? Should I open a new ticket for that?

comment:8 in reply to:  7 Changed 5 years ago by Don-vip

Replying to Stereo:

you seem to have defined the JOSM icon as an icon for .osm documents, but with the wrong path. Is that what you intended? Should I open a new ticket for that?

Probably not. I'm totally blind on all Mac OSX issues as I cannot test. If you see mistakes, please attach patches to the relevant ticket (this one is OK, no need to create a new ticket)

comment:9 Changed 5 years ago by Don-vip

Resolution: fixed
Status: closedreopened

comment:10 Changed 5 years ago by Don-vip

Cc: cquest added

cquest could you help us too? :)

comment:11 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 7475/josm:

fix #10422 - Double-clicking .gpx file on Mac OS X doesn't open JOSM

comment:12 Changed 5 years ago by Don-vip

Useful for UTI debugging:
http://duti.sourceforge.net/duti.1.php

To get a list of UTIs on your system, you can use the following command line:

`locate lsregister` -dump | grep '[[:space:]]uti:' | awk '{ print $2 }' | sort | uniq

display all handlers for uti and exit:

duti -l com.topografix.gpx

comment:13 Changed 5 years ago by Stereo

duti -l com.topografix.gpx

com.berbie.trailrunner
org.openstreetmap.josm

duti -x gpx

Garmin BaseCamp.app
/Applications/Garmin BaseCamp.app
com.garmin.BaseCamp

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.