Modify

Opened 10 years ago

Closed 9 years ago

#10394 closed enhancement (duplicate)

MapCSS: select node on way by index

Reported by: Aun Johnsen <lists@…> Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: mapcss Cc:

Description (last modified by Don-vip)

I am trying to set an icon on the beginning and end of ways with a certain condition, i.e. speed limit set, I checked the wikipage for the implementation, and I can use >[index] to select the instance from the relation, and derived that the same could/should be possible for selecting a node on a way. The following snippet doesn't work:

way[highway][maxspeed] >[index=1] node {
icon-image: "my_maxspeed.png";
}

Though I can set a icon on every node, which will look messy:

way[highway][maxspeed] > node {
icon-image: "my_maxspeed.png";
}

[index=-1] should be the last entry as well (think that have been mentioned in another ticket)

Attachments (0)

Change History (2)

comment:1 by Don-vip, 10 years ago

Description: modified (diff)

comment:2 by Klumbumbus, 9 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10299.
Should work now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.