Modify

Opened 6 years ago

Closed 6 years ago

#10244 closed defect (fixed)

ArrayIndexOutOfBoundsException in MultipolygonTest

Reported by: naoliv Owned by: team
Priority: normal Milestone: 14.07
Component: Core validator Version:
Keywords: template_report Cc:

Description

While validating this file http://naoliv.iq.unesp.br/osm/10244.osm.bz2 (16M compressed; 249M uncompressed) I've got this:

ERRO: java.lang.ArrayIndexOutOfBoundsException: 0
java.lang.ArrayIndexOutOfBoundsException: 0
	at org.openstreetmap.josm.data.osm.Way.getNode(Way.java:134)
	at org.openstreetmap.josm.data.osm.visitor.paint.relations.Multipolygon.joinWays(Multipolygon.java:440)
	at org.openstreetmap.josm.data.validation.tests.MultipolygonTest.joinWays(MultipolygonTest.java:104)
	at org.openstreetmap.josm.data.validation.tests.MultipolygonTest.visit(MultipolygonTest.java:206)
	at org.openstreetmap.josm.data.osm.Relation.accept(Relation.java:166)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:200)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:150)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:744)
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-06 01:36:19
Last Changed Author: Don-vip
Revision: 7291
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-05 18:38:07 +0200 (Sat, 05 Jul 2014)
Last Changed Rev: 7291

Identification: JOSM/1.5 (7291 pt_BR) Linux Debian GNU/Linux testing (jessie)
Memory Usage: 2890 MB / 8158 MB (635 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-2
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on, -Xms1024M, -Xmx8g, -XX:+UseConcMarkSweepGC, -XX:+UseCompressedOops]

Dataset consistency test:
[DELETED REFERENCED] {Relation id=1891287 version=13 VT [caminho 139974581, caminho 139974583, caminho 139974582, caminho 139975028, caminho 139974813, caminho 139974736, caminho 139974587, caminho 139974647, caminho 139973697, caminho 139974596, caminho 139974559, caminho 139974589, caminho 139974913, caminho 139974584, caminho 139974576, caminho 139974574, caminho 139973150, caminho 30143466, caminho 30143289, caminho 287806345, caminho 30143611, caminho 203218454, caminho 141750015, caminho 249587582, caminho 249587583, caminho 249587585, caminho 287805772, caminho 287805771, caminho 141750024, caminho 203218452, caminho 139974575, caminho 141740381, caminho 139974557, caminho 139975047, caminho 141731627, caminho 141731640]} refers to deleted primitive {Way id=30143466 version=7 MVDT nodes=[]}
[DELETED REFERENCED] {Relation id=326266 version=38 MVT [caminho 186362725, caminho 30143466, caminho 30143289, caminho 287806345, caminho 30143611, caminho 203218454, caminho 141750015, caminho 249587582, caminho 249587583, caminho 249587585, caminho 287805772, caminho 287805771, caminho 30143578, caminho 30143308, caminho 30143371, caminho 49913936, caminho 30143292, caminho 30143441, caminho 30143299, caminho 251062348, caminho 251062350, caminho 251062400, caminho 251062387, caminho 30143345, caminho 30143502, caminho 249790469, caminho 251713113, caminho 251063475, caminho 249790458, caminho 44431985, caminho 44479611, caminho 44479608, caminho 44479606, caminho 44479538, caminho 44479589, caminho 44479594, caminho 44479593, caminho 44479553, caminho 44479597, caminho 44479595, caminho 44479600, caminho 44479603, caminho 44479602, caminho 44479599, caminho 44479596, caminho 44479546, caminho 44479554, caminho 261463726, caminho 30143590, caminho 41294238, caminho 30143413, caminho 30143272, caminho 30143400, caminho 30143572, caminho 141917233, caminho 186370067, caminho 186370075, caminho 186370065, caminho 186370079, caminho 186370083, caminho 186370084, caminho 261463732, caminho 186370082, caminho 186370066, caminho 186370069, caminho 186370076, caminho 186370078, caminho 186370081, caminho 186370074, caminho 186370080, caminho 186370068, caminho 186363482, caminho 262803221, caminho 30143261, caminho 186363497, caminho 186363518, caminho 186363502, caminho 186363555, caminho 186363507, caminho 186363492, caminho 186363528, caminho 287798887, caminho 186363512, caminho 186363523, caminho 186363567, caminho 186363550, caminho 186363562, caminho 186363572, caminho 262803222, caminho 186363545, caminho 186363576, caminho 186363556, caminho 186363538, caminho 186363541, caminho 186363533, caminho 186363488, caminho 186363586, caminho 141916934, caminho 186370087, caminho 186370086, caminho 186370085, caminho 186370090, caminho 287798888, caminho 186370088, caminho 186370089, caminho 287800865, caminho 141916920, caminho 287801318, caminho 186362696, caminho 186362698, caminho -1298837, caminho -1298838, caminho 186362721, caminho 186362699, caminho 186362708, caminho 186362705, caminho 186362704, caminho 186362722, caminho 141917070, caminho 186362718, caminho 186362714, caminho 186362700, caminho 186362702, caminho 186362701, caminho 186362703, caminho 186362707, caminho 287804682, caminho 186362706, caminho 186362724, caminho 186362711, caminho 186362723, caminho 186362715, caminho 186362712, caminho 186362709, caminho 69413929, nó 332175615, nó 539687471]} refers to deleted primitive {Way id=30143466 version=7 MVDT nodes=[]}
[DELETED REFERENCED] {Relation id=288247 version=261 MVT [relação 1994077, caminho 245358791, caminho 146458451, caminho 146458452, caminho 146459488, caminho 245345483, caminho 245345482, caminho 245345484, caminho 204091208, caminho 204091207, caminho 45823377, caminho 141452516, caminho 141322426, caminho 141322143, caminho 141452503, caminho 141322222, caminho 141452545, caminho 141452520, caminho 141454808, caminho 141461423, caminho 141322079, caminho 141716060, caminho 141604761, caminho 141604842, caminho 141725579, caminho 141722185, caminho 141722190, caminho 141726750, caminho 141726685, caminho 141726673, caminho 141726666, caminho 141727896, caminho 141727895, caminho 141722135, caminho 141724588, caminho 141731640, caminho 141731627, caminho 139975047, caminho 139974557, caminho 141740381, caminho 139974575, caminho 203218452, caminho 141750024, caminho 249587585, caminho 287805772, caminho 287805771, caminho 249587583, caminho 249587582, caminho 141750015, caminho 203218454, caminho 30143611, caminho 287806345, caminho 30143289, caminho 30143466, caminho 186362725, caminho 69413929, caminho 186362709, caminho 186362712, caminho 186362715, caminho 186362723, caminho 186362711, caminho 186362724, caminho 186362706, caminho 287804682, caminho 186362707, caminho 186362703, caminho 186362701, caminho 186362702, caminho 186362700, caminho 186362714, caminho 186362718, caminho 141917070, caminho 186362722, caminho 186362704, caminho 186362705, caminho 186362708, caminho 186362699, caminho 186362721, caminho -1298838, caminho -1298837, caminho 186362698, caminho 186362696, caminho 287801318, caminho 141916920, caminho 186370089, caminho 287800865, caminho 186370088, caminho 186370090, caminho 287798888, caminho 186370085, caminh...<snip>...

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by naoliv

To add some more information, trying to validate the same data again I am not seeing the problem.
Before having this issue I did an "Update modified", fixed some conflicts and then validated it (the file is in a state where I have already fixed the conflicts).

Could the problem be caused by the conflicts? (and/or the data inconsistencies from the log above)

comment:2 Changed 6 years ago by Don-vip

Summary: ArrayIndexOutOfBoundsExceptionArrayIndexOutOfBoundsException in MultipolygonTest

comment:3 Changed 6 years ago by Don-vip

How long does it take to check this file on your machine? I stopped it after a few minutes because I needed my CPU for something else :)

comment:4 Changed 6 years ago by naoliv

It's not the fastest machine here (an AMD Phenom X4), but it takes around 4 minutes (I also use -Xms1024M -Xmx8g -XX:+UseConcMarkSweepGC -XX:+UseCompressedOops; otherwise it gets really slow).
The longest test is "wrongly ordered ways".

comment:5 Changed 6 years ago by Don-vip

In 7295/josm:

see #10244 - ignore empty ways in Multipolygon.joinWays

comment:6 Changed 6 years ago by Don-vip

I have launched a new build, can you test, when it's available (new latest in 5-10 min) if it fixes the problem?

comment:7 Changed 6 years ago by naoliv

It works as expected (I can validate the data), but like I said in comment:1 I was able to validate it using the older version (after closing JOSM and reopening the same data).

Could somehow the validation or the conflicts have left JOSM in an inconsistent state? (and thus causing the exception)

comment:8 Changed 6 years ago by Don-vip

Milestone: 14.07
Resolution: fixed
Status: newclosed

OK. The conflict handling probably resulted in creating an empty way, thus the exception. It should be fixed by now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.