Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10224 closed enhancement (fixed)

New icon for amenity=charging_station

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone: 14.07
Component: Internal mappaint style Version:
Keywords: icon Cc: stoecker, akks, simon04

Description (last modified by Klumbumbus)

Current icon for charging_station: http://svn.openstreetmap.org/applications/share/map-icons/classic.small/accommodation/camping/hookup.png
That looks to me like a typical speed camera in germany (http://www.blitzer.de/system/pictures/files/2012/08/63047/normal_Blitzer_KL_7.jpg).

I made a new icon for amenity=charging_station: http://commons.wikimedia.org/wiki/File:Charging_station.png

Attachments (0)

Change History (12)

comment:1 Changed 5 years ago by Klumbumbus

Description: modified (diff)

comment:2 Changed 5 years ago by bastiK

In 7292/josm:

see #10224 - New icon for amenity=charging_station (by Klumbumbus)

comment:3 Changed 5 years ago by bastiK

In [o30515] - New icon for amenity=charging_station (license: CC0, author: Klumbumbus)

Thanks for the gentle reminder! ;)

comment:4 Changed 5 years ago by bastiK

Resolution: fixed
Status: newclosed

comment:5 Changed 5 years ago by Don-vip

What do we do with old XML style?

In my previous style update I also took care of updating it, should we continue to do so, or should we drop it now?

comment:6 in reply to:  5 Changed 5 years ago by Klumbumbus

Replying to Don-vip:

What do we do with old XML style?

In my previous style update I also took care of updating it, should we continue to do so, or should we drop it now?

I would like to know this as well. I plan to add some shop icons soon.

comment:7 Changed 5 years ago by bastiK

I suggest that we drop official maintenance of the old xml style and move it to a wiki page. There is no reason to ship them both, unless there are any problems with the mapcss variant.

comment:8 Changed 5 years ago by Don-vip

Cc: stoecker akks simon04 added

Fine for me, what do the others think? Should we also convert other existing XML styles and finally completely drop XML support?

Last edited 5 years ago by Don-vip (previous) (diff)

comment:9 Changed 5 years ago by bastiK

It's not really much to gain from dropping XML support right now: Both formats coexist nicely and you wouldn't save a lot in terms of download size. Converting the remaining XML styles is a good idea though, but I think some of them are external.

comment:10 Changed 5 years ago by stoecker

should we continue to do so, or should we drop it now

There is no reason to update the old style.

I suggest that we drop official maintenance of the old xml style and move it to a wiki page.

I think this is to early, but feel free to do so.

Should we also convert other existing XML styles

Possible.

drop XML support

No, there is no reason to do so and it will break external styles without any need.

comment:11 Changed 5 years ago by Don-vip

Milestone: 14.07

comment:12 Changed 5 years ago by Don-vip

Ticket #6962 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.