Modify

Opened 8 years ago

Closed 8 years ago

#10190 closed defect (invalid)

NumberFormatExc. ("width") bei Programmstart

Reported by: tobi@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-23 01:31:36
Last Changed Author: stoecker
Revision: 4158
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-22 11:47:21 +0200 (Wed, 22 Jun 2011)
Last Changed Rev: 4158

Identification: JOSM/1.5 (4158 de)
Memory Usage: 122 MB / 1820 MB (73 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X

java.lang.IllegalArgumentException: can't parse argument number: width

at java.text.MessageFormat.makeFormat(MessageFormat.java:1420)
at java.text.MessageFormat.applyPattern(MessageFormat.java:479)
at java.text.MessageFormat.<init>(MessageFormat.java:363)
at java.text.MessageFormat.format(MessageFormat.java:835)
at org.openstreetmap.josm.tools.I18n.tr(I18n.java:141)
at org.openstreetmap.josm.data.imagery.ImageryLayerInfo.loadDefaults(ImageryLayerInfo.java:77)
at org.openstreetmap.josm.gui.preferences.ImageryPreference.initialize(ImageryPreference.java:839)
at org.openstreetmap.josm.Main.<init>(Main.java:239)
at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:59)
at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:231)

Caused by: java.lang.NumberFormatException: For input string: "width"

at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Integer.parseInt(Integer.java:492)
at java.lang.Integer.parseInt(Integer.java:527)
at java.text.MessageFormat.makeFormat(MessageFormat.java:1418)
... 9 more

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by tobi@…

deleting the .josm-directory in HOME did not work.

comment:2 Changed 8 years ago by bastiK

Resolution: invalid
Status: newclosed

Your JOSM version is 3 years old, updating will fix the problem.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.