Modify

Opened 6 years ago

Closed 5 years ago

#10164 closed defect (fixed)

DataIntegrityProblemException: pseudo class :unconnected blocks adding tags

Reported by: Klumbumbus Owned by: team
Priority: major Milestone: 14.12
Component: Core Version:
Keywords: mapcss unconnected exception Cc:

Description (last modified by Don-vip)

How to reproduce:

  • Use a mapcss file with the following content node:unconnected{} (example file)
  • Select a node or way
  • Click add in the tags dialog or use Alt + A
  • An error occours and you can't add tags

Happens in tested 7182 and latest 7249.
See console output for more information about the error.

	org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-100 version=0 VT lat=0.0,lon=0.0}
	        at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:334)
	        at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:997)
	        at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:1018)
	        at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.appliesImpl(Condition.java:404)
	        at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.applies(Condition.java:380)
	        at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$AbstractSelector.matches(Selector.java:417)
	        at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.apply(MapCSSStyleSource.java:387)
	        at org.openstreetmap.josm.gui.mappaint.ElemStyles.generateStyles(ElemStyles.java:328)
	        at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.getNodeIcon(MapPaintStyles.java:144)
	        at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.suggestRecentlyAddedTags(TagEditHelper.java:687)
	        at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.<init>(TagEditHelper.java:607)
	        at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper.addTag(TagEditHelper.java:129)
	        at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$AddAction.actionPerformed(PropertiesDialog.java:1008)
	        at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	        at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	        at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	        at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)

Attachments (2)

unconnected test.mapcss (19 bytes) - added by Klumbumbus 6 years ago.
console output.txt (32.1 KB) - added by Klumbumbus 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Klumbumbus

Attachment: unconnected test.mapcss added

Changed 6 years ago by Klumbumbus

Attachment: console output.txt added

comment:1 Changed 5 years ago by Klumbumbus

Component: Core multipolyCore

Any plans on fixing this? The pseudoclass :unconnected is nearly unusable because of this.

comment:2 Changed 5 years ago by stoecker

Milestone: 14.12

comment:3 Changed 5 years ago by stoecker

Summary: pseudo class :unconnected blocks adding tagsRuntimeException: pseudo class :unconnected blocks adding tags

comment:4 Changed 5 years ago by Don-vip

Description: modified (diff)
Keywords: mapcss unconnected exception added
Summary: RuntimeException: pseudo class :unconnected blocks adding tagsDataIntegrityProblemException: pseudo class :unconnected blocks adding tags

comment:5 Changed 5 years ago by Don-vip

Priority: normalmajor

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7797/josm:

fix #10164 - handle dataset properly in mapcss icon fetching

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.