Modify

Opened 6 years ago

Closed 6 years ago

#10156 closed defect (fixed)

combine ways: conflicts not shown

Reported by: skyper Owned by: team
Priority: critical Milestone: 14.10
Component: Core Version: latest
Keywords: template_report combine ways conflict tag regression Cc: simon04, Klumbumbus

Description

What steps will reproduce the problem?

  1. select two ways with one common end node and no dual-value conflicts in tags
  2. combine ways

What is the expected result?

The "conflict when combining ways" window is created which lists all differences in tags and values including tags which do only exists on one/same ways. Plus all differences of memberships including roles.

What happens instead?

The ways are silently combine as long as there is no real dual-value conflict and all tags and memberships from all ways are preserved.

Please provide any additional information below. Attach a screenshot if possible.

This is really dangerous with relations but also with tags as the tag list can easily have more than 20 lines.

Right now the check box on the top right hand side of the above mentioned window does not make any sense.

Not sure how long ago this change was introduced maybe in relation with the better handling of semicolons.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-06-16 01:37:10
Last Changed Author: bastiK
Revision: 7249
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-06-14 20:26:29 +0200 (Sat, 14 Jun 2014)
Last Changed Rev: 7249

Identification: JOSM/1.5 (7249 en) Linux Debian GNU/Linux 7.5 (wheezy)
Memory Usage: 369 MB / 882 MB (55 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1~deb7u1
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: conflation (0.1.7)
Plugin: imagery-xml-bounds (30495)
Plugin: jts (30416)
Plugin: mirrored_download (30495)
Plugin: notes (v0.9.2)
Plugin: photoadjust (30428)
Plugin: reverter (30436)
Plugin: terracer (30416)
Plugin: todo (29154)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)
Plugin: wikipedia (30449)

Attachments (1)

test.osm (2.2 KB) - added by skyper 6 years ago.
test file

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by skyper

Priority: majorcritical

As even myself, an experienced user in handling relations, did break some relations on accident and now have to remind myself to always take a closer look before combinding ways, this is really dangerous.

comment:2 Changed 6 years ago by mdk

I think the conflict window should be shown always, except of two situations:

  1. all ways (except of one) have no tags and no relation memberships
  2. all ways have the same tags with the same values and the same relation memberships with the same roles.

In all other cases, the user should be involved, because any characteristics are assigned from one way to an other.

Combining a highway=residential with a barrier=fence creates a useless result. Is there any case, where combining ways with different tags ever make sense?

Combining ways in route, boundary or multipolygon relations will (nearly) always break the relation, if the ways where not members of the same relation before the operation!

Only in type=restriction relation the "from" and "to" roles may be combined with an other way if the ways are not combined at the "via" node/way.

comment:3 Changed 6 years ago by skyper

This is a real dangerous bug as it damages data and is not easy to spot in general nor easily revertible once changes are uploaded. Any chance in getting it fixed ?

comment:4 Changed 6 years ago by mkoniecz

I was not aware about this problem, it is likely that I damaged multiple ways as result. Please, fix this.

comment:5 in reply to:  description Changed 6 years ago by skyper

Cc: simon04 added

Replying to skyper:

Not sure how long ago this change was introduced maybe in relation with the better handling of semicolons.

Narrowed it down to r6802.

comment:6 Changed 6 years ago by stoecker

I don't think r6802 is the cause. This exists probably since the beginning of the dialog at all. We always tried to reduce the amount of displayed dialogs, as it is a conflict dialog and combining without conflicts did not trigger it.

comment:7 in reply to:  6 Changed 6 years ago by skyper

Replying to stoecker:

I don't think r6802 is the cause. This exists probably since the beginning of the dialog at all. We always tried to reduce the amount of displayed dialogs, as it is a conflict dialog and combining without conflicts did not trigger it.

Please, try it yourself.

  • I did try it from r6767 to r6922 in several steps and yes, the dialog first changes and later misses.
  • It is no conflict as you do not take unset as an value but the relation part is a real conflict and even different roles do not raise one
  • Last but not least, why do we have the two check boxes on top of the "conflict dialog" (if you manage to get it to open) ?
Last edited 6 years ago by skyper (previous) (diff)

comment:8 Changed 6 years ago by Don-vip

Can you please attach an example .osm file?

Changed 6 years ago by skyper

Attachment: test.osm added

test file

comment:9 in reply to:  8 Changed 6 years ago by skyper

Replying to Don-vip:

Can you please attach an example .osm file?

Well, it is pretty easy, simple find two ways which are split for reason.

Simply connect the two or three of the three connected ways in the example file.
The northern triple counts, the southern is just a reference with one common tag with value conflict.

comment:10 Changed 6 years ago by Don-vip

Milestone: 14.09

comment:11 Changed 6 years ago by Don-vip

Milestone: 14.0914.10

Didn't have the time to work on this, I'll look into it for next version.

comment:12 in reply to:  11 Changed 6 years ago by skyper

Replying to Don-vip:

Didn't have the time to work on this, I'll look into it for next version.

Would be a good idea to not introduce this bug into Debian freeze. On the other hand Debian release strategy does not work well together with JOSM releases and it would be better to have backport packages for stable.

comment:13 Changed 6 years ago by Don-vip

Sure. But honestly I don't know if I'll get enough time this week too.

comment:14 Changed 6 years ago by Klumbumbus

Cc: Klumbumbus added

comment:15 Changed 6 years ago by Don-vip

Keywords: regression added

comment:16 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7642/josm:

fix #10156 - combine ways: conflicts not shown when no conflicting values (regression from r6802)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.