Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10105 closed defect (invalid)

current josm won't start on ubuntu-linux

Reported by: akvds@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Hi there,

i just installed josm, but could launch it.
So here's the crash-log when i start josm from the command-line:
Using /usr/lib/jvm/java-6-openjdk/bin/java to execute josm.
Exception in thread "main" java.lang.UnsupportedClassVersionError: JOSM : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)

Could not find the main class: JOSM. Program will exit.
christian@christian-Laptop:~$ java -version
java version "1.6.0_31"
OpenJDK Runtime Environment (IcedTea6 1.13.3) (6b31-1.13.3-1ubuntu1~0.12.04.2)
OpenJDK Server VM (build 23.25-b01, mixed mode)

If you know any solution, please let me know, otherwise i'll wait for the next release.

Kind regards

Christian

Attachments (0)

Change History (3)

comment:1 by akks, 10 years ago

Sorry, newer JOSM will not work on Java 6. We migrated to Java 7. https://josm.openstreetmap.de/ticket/8465
It is a bug in repository if you get new version with openjdk-6.

Try sudo apt-get install openjdk-7-jre and the problems should vanish.

comment:2 by Don-vip, 10 years ago

Resolution: invalid
Status: newclosed

comment:3 by JamesZD, 10 years ago

If that did not fix it for you it might be because you have both Java 6 and Java 7 installed and it is defaulting to 6. http://askubuntu.com/questions/272187/setting-jdk-7-as-default explains how to fix this using

sudo update-alternatives --config java

and selecting the appropriate version. I hope that helps.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.