Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10070 closed defect (invalid)

Running qat_script plugin on download errors form servers....

Reported by: marcobra.ubutntu@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-25 01:35:27
Last Changed Author: bastiK
Revision: 7178
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-24 21:03:56 +0200 (Sat, 24 May 2014)
Last Changed Rev: 7178

Identification: JOSM/1.5 (7178 it) Linux Ubuntu 14.04 LTS
Memory Usage: 217 MB / 455 MB (120 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Server VM
VM arguments: [-Xmx512M]
Dataset consistency test: No problems found

Plugin: AddrInterpolation (30416)
Plugin: CommandLine (30436)
Plugin: FastDraw (30416)
Plugin: FixAddresses (30416)
Plugin: ImportImagePlugin (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: PicLayer (30436)
Plugin: SimplifyArea (30416)
Plugin: buildings_tools (30416)
Plugin: conflation (0.1.7)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1010)
Plugin: dataimport (30416)
Plugin: download_along (30416)
Plugin: geotools (30416)
Plugin: jts (30416)
Plugin: junctionchecking (30416)
Plugin: log4j (30416)
Plugin: mapdust (30416)
Plugin: merge-overlap (30416)
Plugin: mirrored_download (30436)
Plugin: namemanager (30416)
Plugin: notes (v0.9.2)
Plugin: opendata (30436)
Plugin: pbf (30416)
Plugin: poly (30416)
Plugin: print (30416)
Plugin: proj4j (30417)
Plugin: reltoolbox (30416)
Plugin: reverter (30436)
Plugin: scripting (30604)
Plugin: tageditor (30416)
Plugin: tagging-preset-tester (30416)
Plugin: terracer (30416)
Plugin: turnrestrictions (30454)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)
Plugin: walkingpapers (30416)
Plugin: waydownloader (30416)
Plugin: waypoint_search (30416)
Plugin: wikipedia (30449)

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

AttributeError: type object 'org.openstreetmap.josm.tools.Utils' has no attribute 'UTF_8'

at java.util.concurrent.FutureTask.report(FutureTask.java:122)
at java.util.concurrent.FutureTask.get(FutureTask.java:188)
at javax.swing.SwingWorker.get(SwingWorker.java:602)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)

java.util.concurrent.ExecutionException: java.util.concurrent.ExecutionException: Traceback (most recent call last):

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

AttributeError: type object 'org.openstreetmap.josm.tools.Utils' has no attribute 'UTF_8'

at org.python.core.Py.JavaError(Py.java:495)
at org.python.core.PyObject._jthrow(PyObject.java:3529)
at org.python.core.PyObject._jcall(PyObject.java:3536)
at org.python.proxies.download_and_parse$DownloadTask$8.done(Unknown Source)
at javax.swing.SwingWorker$5.run(SwingWorker.java:737)
at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(SwingWorker.java:832)
at sun.swing.AccumulativeRunnable.run(AccumulativeRunnable.java:112)
at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(SwingWorker.java:842)
at javax.swing.Timer.fireActionPerformed(Timer.java:312)
at javax.swing.Timer$DoPostEvent.run(Timer.java:244)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:694)
at java.awt.EventQueue$3.run(EventQueue.java:692)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Caused by: java.util.concurrent.ExecutionException: Traceback (most recent call last):

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

AttributeError: type object 'org.openstreetmap.josm.tools.Utils' has no attribute 'UTF_8'

at java.util.concurrent.FutureTask.report(FutureTask.java:122)
at java.util.concurrent.FutureTask.get(FutureTask.java:188)
at javax.swing.SwingWorker.get(SwingWorker.java:602)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.python.core.PyReflectedFunction.call(PyReflectedFunction.java:186)
at org.python.core.PyReflectedFunction.call(PyReflectedFunction.java:204)
at org.python.core.PyObject.call(PyObject.java:387)
at org.python.core.PyObject.call(PyObject.java:391)
at org.python.core.PyMethod.call(PyMethod.java:109)
at download_and_parse$py.done$4(/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py:127)
at download_and_parse$py.call_function(/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py)
at org.python.core.PyTableCode.call(PyTableCode.java:165)
at org.python.core.PyBaseCode.call(PyBaseCode.java:301)
at org.python.core.PyBaseCode.call(PyBaseCode.java:194)
at org.python.core.PyFunction.call(PyFunction.java:387)
at org.python.core.PyMethod.instancemethod_call(PyMethod.java:220)
at org.python.core.PyMethod.call(PyMethod.java:211)
at org.python.core.PyMethod.call(PyMethod.java:201)
at org.python.core.PyMethod.call(PyMethod.java:196)
at org.python.core.PyObject._jcallexc(PyObject.java:3502)
at org.python.core.PyObject._jcall(PyObject.java:3534)
... 21 more

Caused by: Traceback (most recent call last):

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

File "/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py", line 87, in doInBackground

inb = BufferedReader(InputStreamReader(ins, Utils.UTF_8))

AttributeError: type object 'org.openstreetmap.josm.tools.Utils' has no attribute 'UTF_8'

at org.python.core.Py.AttributeError(Py.java:173)
at org.python.core.PyType.noAttributeError(PyType.java:1715)
at org.python.core.PyObject.getattr(PyObject.java:925)
at download_and_parse$py.doInBackground$3(/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py:116)
at download_and_parse$py.call_function(/home/ubuntu/.josm/plugins/scripting/qat_script/download_and_parse.py)
at org.python.core.PyTableCode.call(PyTableCode.java:165)
at org.python.core.PyBaseCode.call(PyBaseCode.java:301)
at org.python.core.PyBaseCode.call(PyBaseCode.java:194)
at org.python.core.PyFunction.call(PyFunction.java:387)
at org.python.core.PyMethod.instancemethod_call(PyMethod.java:220)
at org.python.core.PyMethod.call(PyMethod.java:211)
at org.python.core.PyMethod.call(PyMethod.java:201)
at org.python.core.PyMethod.call(PyMethod.java:196)
at org.python.core.PyObject._jcallexc(PyObject.java:3502)
at org.python.proxies.download_and_parse$DownloadTask$8.doInBackground(Unknown Source)
at javax.swing.SwingWorker$1.call(SwingWorker.java:296)
at java.util.concurrent.FutureTask.run(FutureTask.java:262)
at javax.swing.SwingWorker.run(SwingWorker.java:335)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by anonymous

Seems caused by recent changes

https://josm.openstreetmap.de/changeset/7082/josm

ok please close...

comment:2 Changed 7 years ago by bastiK

Resolution: fixed
Status: newclosed

comment:3 Changed 7 years ago by Don-vip

Resolution: fixedinvalid

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.