Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10054 closed defect (fixed)

Multipolygons as members not highlighted when relation is selected.

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.09
Component: Core Version: latest
Keywords: relation highlight multipolygon Cc:

Description

What steps will reproduce the problem?

  1. add a multipolygon as member to a relation
  2. select the relation via relation list toggle dialog

What is the expected result?

All members are highlighted in pink

What happens instead?

Only ways and nodes with membership are highlighted but no relations.

Please provide any additional information below. Attach a screen shot if possible.

I did test it with a route and a associatedStreet relation. Please have a look at attached example file.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-20 01:35:44
Last Changed Author: simon04
Revision: 7146
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-19 18:17:18 +0200 (Mon, 19 May 2014)
Last Changed Rev: 7146

Identification: JOSM/1.5 (7146 en) Linux Debian GNU/Linux 7.5 (wheezy)
Memory Usage: 314 MB / 882 MB (186 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1~deb7u1
VM arguments: [-Djosm.home=/tmp/.josm]
Program arguments: [--language=en]
Dataset consistency test: No problems found

Attachments (1)

multipoly_relation.osm (5.4 KB) - added by skyper 5 years ago.
example file

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by skyper

Attachment: multipoly_relation.osm added

example file

comment:1 Changed 5 years ago by akks

Actulally, the relation itself can not be highlighted, only its members.

If needed, I can add recursive highlight as an option. Not sure if should be defalut (highlighted relation can not be distinguished from highlighted member ways).

comment:2 Changed 5 years ago by skyper

A multipolygon is always an area and it could be highlighted with or without its members (ways).

From a user's point of view a highlighting is needed. Otherwise you do not get any visual information and you need to take a look at every relation.

Last edited 5 years ago by skyper (previous) (diff)

comment:3 Changed 5 years ago by akks

So the area highlighting is needed (and not implemented), not the recusive-relation-highlighting.

comment:4 Changed 5 years ago by stoecker

I don't understand that. JOSM does not support multipolygons with relations as members at all and also I fear nobody else does so.

comment:5 in reply to:  4 Changed 5 years ago by skyper

Replying to stoecker:

I don't understand that. JOSM does not support multipolygons with relations as members at all and also I fear nobody else does so.

Are polygons in general supported ? Some areas are only mappable as multipolygons.

It might work for route relations as you can simply use an extra way, but for associatedStreet it is needed as there are buildings with holes and also areas mapped as multipolygon.

comment:6 Changed 5 years ago by stoecker

Hmms, somehow this is confusing.

  • JOSM supports relations as relation members when creating and managing relations.
  • JOSM does not support relations as relation members when using such relations (i.e. when displaying polygons, ...)

Also most other software does not support relations inside relations (maybe routes could be an exception).

So encouraging display of such constructs is not such a good idea - Users will assume it works, but nobody can use it.

comment:7 in reply to:  6 Changed 5 years ago by skyper

Replying to stoecker:

Hmms, somehow this is confusing.

  • JOSM supports relations as relation members when creating and managing relations.
  • JOSM does not support relations as relation members when using such relations (i.e. when displaying polygons, ...)

Also most other software does not support relations inside relations (maybe routes could be an exception).

It is needed for associatedStreet and Street relations as houses with inside holes cannot be drawn in a different way.

comment:8 Changed 5 years ago by Don-vip

Milestone: 14.09

comment:9 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7555/josm:

fix #10054 - Multipolygons as members not highlighted when relation is selected

comment:10 Changed 5 years ago by Don-vip

Ticket #6657 has been marked as a duplicate of this ticket.

comment:11 Changed 5 years ago by aceman

It is probably also used in administrative boundary relations where the "subarea" members are relations again.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.