Modify

Opened 5 years ago

Closed 5 years ago

#10030 closed defect (fixed)

WMS support broken

Reported by: skyper Owned by: Don-vip
Priority: major Milestone: 14.05
Component: Core imagery Version: latest
Keywords: wms Cc:

Description

What steps will reproduce the problem?

Activate Maps4BW layer

What is the expected result?

Images are downloaded

What happens instead?

Red error tiles.

Please provide any additional information below. Attach a screenshot if possible.

Using wget I have no problem to download the tiles.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-15 01:36:41
Last Changed Author: Don-vip
Revision: 7132
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-15 03:15:28 +0200 (Thu, 15 May 2014)
Last Changed Rev: 7132

Identification: JOSM/1.5 (7132 en) Linux Debian GNU/Linux 7.5 (wheezy)
Memory Usage: 338 MB / 882 MB (175 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-1~deb7u1
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: conflation (0.1.6)
Plugin: imagery-xml-bounds (30416)
Plugin: jts (30416)
Plugin: mirrored_download (30436)
Plugin: notes (v0.9.2)
Plugin: photoadjust (30428)
Plugin: reverter (30436)
Plugin: terracer (30416)
Plugin: todo (29154)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30419)
Plugin: wikipedia (30449)
ERROR: java.lang.Exception: Index: 0, Size: 0
Image couldn't be fetched: http://www.webatlasde.de/arcgis/services/Maps4BW/MapServer/WMSServer?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=Halbtonvariante&STYLES=&SRS=EPSG:3857&WIDTH=500&HEIGHT=500&BBOX=903250.2659236,6111864.0374223,903371.6052930,6111985.3767917. Cause: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
java.lang.Exception: Index: 0, Size: 0
Image couldn't be fetched: http://www.webatlasde.de/arcgis/services/Maps4BW/MapServer/WMSServer?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=Halbtonvariante&STYLES=&SRS=EPSG:3857&WIDTH=500&HEIGHT=500&BBOX=903250.2659236,6111864.0374223,903371.6052930,6111985.3767917
	at org.openstreetmap.josm.io.imagery.WMSGrabber.fetch(WMSGrabber.java:74)
	at org.openstreetmap.josm.io.imagery.Grabber.attempt(Grabber.java:66)
	at org.openstreetmap.josm.io.imagery.Grabber.run(Grabber.java:50)
	at java.lang.Thread.run(Thread.java:744)
Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
	at java.util.ArrayList.rangeCheck(ArrayList.java:635)
	at java.util.ArrayList.get(ArrayList.java:411)
	at javax.imageio.metadata.IIONodeList.item(IIOMetadataNode.java:127)
	at org.openstreetmap.josm.tools.ImageProvider.getTransparentColor(ImageProvider.java:1274)
	at org.openstreetmap.josm.tools.ImageProvider.read(ImageProvider.java:1237)
	at org.openstreetmap.josm.tools.ImageProvider.read(ImageProvider.java:1132)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.grab(WMSGrabber.java:181)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.fetch(WMSGrabber.java:70)
	... 3 more

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Milestone: 14.05
Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 7134/josm:

fix #10030 - wms support broken in r7132

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.