Modify

Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#10007 closed enhancement (fixed)

change "public" into "yes" in access presets and in validator

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 16.04
Component: Internal preset Version:
Keywords: Cc:

Description (last modified by mkoniecz)

There is a "public" value in access presets. AFAIK it is synonymous to "yes" in the access context, is way less used (13:388) and is undocumented on wiki. It is not appearing in iD editor.

I suggest removal of "public" from all access presets and adding rule in validator to change <access_key>=public to <access_key>=yes (via fix button).

See

https://lists.openstreetmap.org/pipermail/tagging/2014-May/017501.html
https://lists.openstreetmap.org/pipermail/tagging/2014-May/017509.html
https://lists.openstreetmap.org/pipermail/tagging/2014-May/017510.html

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-11 01:36:45
Last Changed Author: bastiK
Revision: 7105
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-11 01:48:28 +0200 (Sun, 11 May 2014)
Last Changed Rev: 7105

Identification: JOSM/1.5 (7105 en) Windows 7 32-Bit
Memory Usage: 42 MB / 247 MB (10 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Client VM

Plugin: OpeningHoursEditor (30416)
Plugin: RoadSigns (30438)
Plugin: buildings_tools (30416)
Plugin: continuosDownload (28565)
Plugin: lakewalker (30416)
Plugin: measurement (30416)
Plugin: notes (v0.9.2)
Plugin: wikipedia (30416)

Attachments (0)

Change History (16)

comment:1 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:2 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:3 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:4 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:5 Changed 5 years ago by Don-vip

Component: CoreInternal preset

comment:6 Changed 5 years ago by skyper

I do not like access=yes. Better use explicit keys, but well, some like to explicitly tag that access is allowed.

Thought by default access=yes applies to all ways.
I do not know what people intended to describe when they did use designated,official or public, but the wiki page really invites to tag this way.

comment:7 Changed 5 years ago by mkoniecz

I am not a great fan of access=yes but it is certainly better than access=public that appears only in JOSM presets.

comment:8 Changed 5 years ago by goldfndr

FYI, it is documented on the wiki at amenity=toilets (and also at amenity=grit_bin). Changing defaultpresets.xml line 4058 to remove public, will get it off of the default list. (Try yourself by saving/extracting it then change line 4058 then change Internal Preset to point to the local file instead of "resource://data/defaultpresets.xml".)

comment:9 Changed 5 years ago by mkoniecz

Still, it clearly should be reported by validator and not suggested for things that are not toilets or grit_bin.

I encountered it on highways, playgrounds etc.

comment:10 in reply to:  9 Changed 5 years ago by skyper

Replying to mkoniecz:

Replying to goldfndr:

Replying to skyper:

I do not like access=yes. Better use explicit keys, but well, some like to explicitly tag that access is allowed.

Thought by default access=yes applies to all ways.
I do not know what people intended to describe when they did use designated,official or public, but the wiki page really invites to tag this way.

FYI, it is documented on the wiki at amenity=toilets (and also at amenity=grit_bin).

Thanks, that explains the usage of public as counter-part to private. If you want to state that an amenity/leisure is for the public it might be useful.

Still, it clearly should be reported by validator and not suggested for things that are not toilets or grit_bin.

I encountered it on highways, playgrounds etc.

I prefer public over yes for playgrounds but both values are useless on highways. How about excluding leisure and amenity but check all the rest.

comment:11 Changed 5 years ago by mkoniecz

I prefer public over yes for playgrounds

Why it is better? IMHO it makes parsing data more complicated for no gain (I processed OSM data on occasion and discovering yet another pointless variation of tagging is IMHO one of the most irritating things).

comment:12 Changed 5 years ago by mkoniecz

this bug was present also in iD - see https://github.com/openstreetmap/iD/issues/2280

comment:13 Changed 4 years ago by mkoniecz

This bug is still present and it continues to promote undocumented duplicate of existing tag.

comment:14 Changed 3 years ago by Klumbumbus

Milestone: 16.03

The toilet wiki page was changed one year ago (public->yes) and I just changed the grit bin page.
In my opinion it is better to use yes instead of public everywhere. So I'm gonna change the preset now. Since there is no real agreement for the deprecation and the usage numbers for public are higher than for yes (for toilets and grit bins) I will not add a validator warning at this point.

comment:15 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 10094/josm:

fix #10007 - change access=public to access=yes in presets for toilets, shower and sanitary dump station.

comment:16 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.