Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1000 closed defect (worksforme)

Upload of deletions gives server return code 504

Reported by: anonymous Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: proxy deletion Cc:

Description

When I want to upload changes that contain deletions of nodes or ways, the server gives return code 504. In the Java console I get

upload to: http://www.openstreetmap.org/api/0.5/node/274951903...connected
got return: 504 with id 274951903
backing off for 10 seconds...
...
...
<<<

In Potlatch I can delete those objects without error. Seems there is an API usage flaw in JOSM (used most current from today, 2008-06-30).

Node 274951903 was created only for this purpose. I have deleted it in Potlatch to keep the map clean.

Walldorfer

Attachments (0)

Change History (4)

comment:1 Changed 14 years ago by anonymous

This only happens when I am behind a proxy (JOSM started with -Dhttp.proxy[Host|Port]). When I take the same JAR and move it to a computer that is directly connected to the Internet, the deletions work fine. For clarity: All other ops (create nodes, move, change atts) work fine also behind the proxy.

My exact version where I reproduced this is 669 (2008-06-28 01:12:34).

comment:2 Changed 14 years ago by anonymous

Does this still happen? Can't reproduce.

comment:3 Changed 14 years ago by Hasienda

Resolution: worksforme
Status: newclosed

Checked this here

  • on Debian GNU/Linux system with
  • JOSM revision 1073 (downloaded at 11/12/2008, latest to date is 1075 now)
  • run with command line options -Dhttp.proxyHost=myhost -Dhttp.proxyPort=3128

built node 311862396; uploaded to OSM; deleted node; uploaded again -> no error, no warning at the console, from where JOSM was started in foreground = zero problems here

@reporter: verify on your own, re-open with more details about (network layout, proxy configuration, exact JOSM revision #, etc.), if still unsolved for you, please

comment:4 Changed 14 years ago by Hasienda

Keywords: proxy deletion added

just added some keywords

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.