Changeset 18167 in josm


Ignore:
Timestamp:
2021-08-23T01:22:24+02:00 (18 months ago)
Author:
Don-vip
Message:

see #17858 - deprecate native javafx plugins, no longer needed, would rather cause harm as loading JavaFX through classpath is no longer supported anayway

https://github.com/openjdk/jfx/blob/master/doc-files/release-notes-16.md#javafx-runtime-logs-a-warning-if-javafx-modules-are-loaded-from-the-classpath

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/org/openstreetmap/josm/plugins/PluginHandler.java

    r17678 r18167  
    164164            new DeprecatedPlugin("MovementAlert", inCore),
    165165            new DeprecatedPlugin("OpenStreetCam", tr(replacedByPlugin, "KartaView")),
    166             new DeprecatedPlugin("scoutsigns", tr(replacedByPlugin, "KartaView"))
     166            new DeprecatedPlugin("scoutsigns", tr(replacedByPlugin, "KartaView")),
     167            new DeprecatedPlugin("javafx-osx", inCore),
     168            new DeprecatedPlugin("javafx-unixoid", inCore),
     169            new DeprecatedPlugin("javafx-windows", inCore)
    167170        );
    168171        Collections.sort(DEPRECATED_PLUGINS);
Note: See TracChangeset for help on using the changeset viewer.