Modify

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#7904 closed defect (wontfix)

Webstart blocked by OS X Mountain Lion

Reported by: patrick@… Owned by: team
Priority: major Milestone:
Component: Core Webstart Version: latest
Keywords: Webstart, OS X, Mountain Lion Cc: stoecker

Description (last modified by bastiK)

On Apple OS X 10.8 aka Mountain Lion, JOSM cannot be started via webstart due to a missing or invalid signature. There is no manual override option.

Details (German):

Seit gestern gibt es das neue Betriebssystem für stationärne Macs, Mac OS X 10.8 'Mountain Lion'.
Josm läuft nicht.
Beim Starten wird das Zertifikat abgelehnt. Ein Löschen und erneutes Laden von Josm änderte nichts.
Fehlermeldung: 'Die digitale Signatur ist nicht vertrauenswürdig. Java erlaubt keinen Zugriff auf dieses Programm.'
Manuelles Zulassen wird nicht erlaubt

Attachments (0)

Change History (14)

comment:1 Changed 5 years ago by Cobra

This might be related to the new "Gatekeeper" checking signatures before allowing applications to run. There seems to exist a similar problem with java applets: http://stackoverflow.com/questions/11665386/os-x-10-8-gatekeeper-and-java-applets

comment:2 Changed 5 years ago by Cobra

Component: Coreunspecified
Description: modified (diff)
Keywords: Webstart X added; OSX Apple removed
Summary: läuft nicht unter MacOS X Mountain LionWebstart blocked by OS X Mountain Lion

comment:3 Changed 5 years ago by Cobra

It seems like the webstart gets blocked by Apple's Gatekeeper because it isn't signed by a certificate issued by Apple to someone with an Apple Developer ID (which costs 99$ per year).

(german) forum thread: http://forum.openstreetmap.org/viewtopic.php?id=17601

Last edited 5 years ago by Cobra (previous) (diff)

comment:4 Changed 5 years ago by bastiK

Doc on the Apple web site.

In my humble opinion, the minimum requirement for JOSM to comply:

  • certificate free of charge or one-time fee
  • no contracts that puts a hobby programmer in a disadvantageous position (liabilities, etc.)
  • signing-tools, that run on Linux, so it can be part of the automated build process

comment:6 Changed 5 years ago by Don-vip

Cc: stoecker added

Are we OK to say we won't do anything on this subject and thereby close this ticket as wontfix ?

comment:7 Changed 5 years ago by stoecker

Resolution: wontfix
Status: newclosed

comment:8 Changed 5 years ago by drnoble

This also appears to apply to the OS X package version.

Temporarily disabling Gatekeeper, opening JOSM.app, then re-enabling Gatekeeper also appears to work for me.

comment:9 Changed 5 years ago by anonymous

Ticket #8034 has been marked as a duplicate of this ticket.

comment:10 Changed 4 years ago by bastiK

Component: unspecifiedWebstart
Description: modified (diff)

comment:11 Changed 4 years ago by bastiK

Ticket #8524 has been marked as a duplicate of this ticket.

comment:12 Changed 3 years ago by Don-vip

Ticket #9313 has been marked as a duplicate of this ticket.

comment:13 Changed 3 years ago by John Firebaugh

I opened an issue on the Apple Bug Reporter regarding this issue. It was closed as a 3rd Party Issue, with the following comment:

You are using an obsolete JavaApplicationStub which is stuck launching Java SE 6 and is deprecated. You need to rebundle the app with Java 7 (or 8), and resign the app using that.

I understand the reluctance to pay for a Developer ID, but could you investigate whether rebundling the app with Java 7 or 8 would at least result in a better error message for the unsigned app?

comment:14 in reply to:  13 Changed 3 years ago by Don-vip

Replying to John Firebaugh:

could you investigate whether rebundling the app with Java 7 or 8 would at least result in a better error message for the unsigned app?

See #8654 :D

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.