[Patch] Refactor Command.getDescription
|Reported by:||simon04||Owned by:||team|
As discussed in the course of #7327, the Command.getDescription method should be refactored:
Currently each Command must provide a JLabel getDescription() method. I'd consider it better to request String getDescriptionText() and ImageIcon getDescriptionIcon() instead as this allows to use the data in other places as well without doing quirks.
See the attached patch for the refactoring. Especially, take a look at the changes in PseudoCommand, which allow a smooth transition (as plugins also need to be updated).