Modify

Opened 10 years ago

Last modified 3 years ago

#724 new enhancement

Josm Extrude for multiple elements

Reported by: dieterdreist Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by skyper)

The Extrude option at the moment just can extrude one way at the same time. It would be quite nice, if it would be possible to extrude more than one the same time, like its possible for moving, deleting, ...

The extrusion should be according to the local vector (or otherwise be possible only to parallel ways). This way it would be possible to create more complicated buildings using the following sequence:

  1. draw line
  2. extrude line
  3. add more points to the now rectangle
  4. extrude several segments (between newly created points on rectangle) the same time, by this assuring that they all have the same (extrusion) length (and will therefore render much nicer)

it also will save lots of time when manipulating large areas of same shaped house (like single-houses in suburban areas)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by Gubaer

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by Gubaer

Resolution: duplicate
Status: closedreopened

Ops, didn't mean to close this one.

comment:4 Changed 6 years ago by skyper

Description: modified (diff)
Owner: changed from framm to team
Status: reopenednew

comment:5 Changed 3 years ago by skyper

Ticket #9457 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to dieterdreist
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from team to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.