Modify

Opened 7 years ago

Closed 7 years ago

#5373 closed defect (fixed)

JOSM can't delete old and replace by new plugins

Reported by: willis@… Owned by: team
Priority: blocker Milestone:
Component: Core Version:
Keywords: Cc: Emvee

Description

After updating plugins and restarting JOSM I get the appended output on the console. After exiting JOSM I can manually delete the old x.jar and rename the new x.jar.new to x.jar. After this JOSM starts and uses the new version without problems.

In the German forum the same problem has been reported http://forum.openstreetmap.org/viewtopic.php?pid=98763#p98763.

Console output (for wmsplugin):

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-08-25 01:31:39
Last Changed Author: ulfl
Revision: 3465
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-08-25 00:43:34 +0200 (Wed, 25 Aug 2010)
Last Changed Rev: 3465

Warnung: Das Entfernen des veralteten Plugins "C:\Dokumente und Einstellungen\Willi\Anwendungsdaten\JOSM\plugins\wmsplugin.jar" ist fehlgeschlagen.
Warnung: die Installation des heruntergeladenen Plugins 'wmsplugin' ist fehlgeschlagen. JOSM wird weiterhin die alte Version des Plugins nutzen.
lade Plugin 'remotecontrol' (Version 22734)
RemoteControl::Accepting connections on port 8111
lade Plugin 'wmsplugin' (Version 22761)
wmsplugin: initializing remote control
RemoteControl: adding command "wms" (handled by WMSRemoteHandler)
lade Plugin 'PicLayer' (Version 22549)
lade Plugin 'validator' (Version 22688)
lade Plugin 'livegps' (Version 21706)
lade Plugin 'measurement' (Version 22547)

Information from status overview:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-08-25 01:31:39
Last Changed Author: ulfl
Revision: 3465
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-08-25 00:43:34 +0200 (Wed, 25 Aug 2010)
Last Changed Rev: 3465

Identification: JOSM/1.5 (3465 de)
Memory Usage: 21 MB / 989 MB (0 MB allocated, but free)
Java version: 1.6.0_21, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Plugin: PicLayer (22549)
Plugin: livegps (21706)
Plugin: measurement (22547)
Plugin: remotecontrol (22734)
Plugin: validator (22688)
Plugin: wmsplugin (22761)

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by anonymous

I have the same problem on Win XP. (Under Ubuntu, I've never got this problem, till now.)

comment:2 Changed 7 years ago by stoecker

Ticket #5350 has been marked as a duplicate of this ticket.

comment:3 Changed 7 years ago by Emvee

Cc: Emvee added

comment:4 Changed 7 years ago by bastiK

Priority: normalblocker

comment:5 Changed 7 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3512]) fixed #5373 - JOSM can't delete old and replace by new plugins (JOSM loaded icons from plugin jar file, but did not release file handles.)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.