Modify

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3012 closed defect (fixed)

External Plugins not up-to-date

Reported by: phobie Owned by: team
Priority: blocker Milestone:
Component: Core validator Version:
Keywords: Cc: rharrison, chris.bainbridge@…, Gubaer

Description (last modified by stoecker)

A very silly bug in 1815!
After adding and editing some nodes I tried to upload them but this exception prevents me from doing so.

Klicking "Upload" results in the "Disable plugin" window.
If I click "Cancel" I get the "Unexprected Exception" window.
If I click on "Do nothing" the window closes, but uploads nothing.
If I click on "Report bug" the exception window is shown, but nothing has been uploaded.

If I click on "Disable plugin" I get "The plugin could not be removed.Please tell the people you got JOSM from about the problem"

Now I will redo all my changes on a new josm instance...

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1815
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1815
Last Changed Date: 2009-07-19 21:35:34 +0200 (Sun, 19 Jul 2009)


Memory Usage: 46 MB / 986 MB (17 MB allocated, but free)
Java version: 1.6.0_14

Plugins: measurementopenstreetbugsosmarenderplastic_lafremotecontrolroutingslippymaptageditortagging-preset-testerusertoolsutilspluginvalidatorwaydownloaderwmsplugin
Plugin plastic_laf Version: 14016
Plugin measurement Version: 16317
Plugin openstreetbugs Version: 16564
Plugin osmarender Version: 16239
Plugin remotecontrol Version: 16290
Plugin routing Version: 16409
Plugin slippymap Version: 16294
Plugin tageditor Version: 16575
Plugin tagging-preset-tester Version: 14015
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16290
Plugin validator Version: 16439
Plugin waydownloader Version: 16290
Plugin wmsplugin Version: 16442


java.lang.NoSuchFieldError: ds
	at org.openstreetmap.josm.plugins.validator.tests.UntaggedNode.visit(UntaggedNode.java:56)
	at org.openstreetmap.josm.plugins.validator.ValidateUploadHook.checkUpload(ValidateUploadHook.java:60)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:212)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (16)

comment:1 Changed 9 years ago by phobie

Component: CoreCore validator

Restarting did not help.
A "rm -rf ~/.josm/plugins/validator*" was needed.
Reinstalling the plugin does not help...

comment:2 Changed 9 years ago by stoecker

Description: modified (diff)
Summary: NoSuchFieldError UntaggedNode validator.ValidateUploadHookExternal Plugins not up-to-date

comment:3 Changed 9 years ago by stoecker

Ticket #3013 has been marked as a duplicate of this ticket.

comment:4 Changed 9 years ago by stoecker

Ticket #3017 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by stoecker

Ticket #3007 has been marked as a duplicate of this ticket.

comment:6 Changed 9 years ago by rharrison

Cc: rharrison added

comment:7 Changed 9 years ago by Chris Bainbridge <chris.bainbridge@…>

Cc: chris.bainbridge@… added

comment:8 Changed 9 years ago by Gubaer

Cc: Gubaer added

Caution!

r1814 (and probably r1811, too) are not compatible with a couple of existing plugins! This has been announced on dev.

comment:9 Changed 9 years ago by Gubaer

Ticket #3019 has been marked as a duplicate of this ticket.

comment:10 Changed 9 years ago by stoecker

Ticket #3021 has been marked as a duplicate of this ticket.

comment:11 Changed 9 years ago by stoecker

Ticket #3025 has been marked as a duplicate of this ticket.

comment:12 Changed 9 years ago by jttt

Resolution: fixed
Status: newclosed

All plugins in OSM svn repository should now work with new JOSM. If there are still broken plugins then they should get they own ticket so there is better change their authors will fix them.

comment:13 Changed 9 years ago by stoecker

Ticket #3031 has been marked as a duplicate of this ticket.

comment:14 Changed 9 years ago by stoecker

Ticket #3057 has been marked as a duplicate of this ticket.

comment:15 Changed 8 years ago by stoecker

Ticket #3086 has been marked as a duplicate of this ticket.

comment:16 Changed 8 years ago by stoecker

Ticket #3082 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.