Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2277 closed defect (duplicate)

Exception/crash with cadastre-fr plugin in JOSM snapshot 1479

Reported by: GuillaumeAudirac Owned by: team
Priority: blocker Milestone:
Component: Plugin Version: tested
Keywords: cadastre-fr Cc:

Description

Hello,

I am facing an issue with the latest JOSM snapshot 1479 (Windows XP). I have not crosschecked with Linux yet.
The selected Projection Method is Lambert Zone (France) as recommended for the cadastre-fr plugin.
I first download some JOSM data around the village Villy-Bocage in France (postcode 14310). Then I do a Cadastre/Change Location in searching for "Villy Bocage". Then happens the exception/crash: "An unexpected exception occured. This is always a coding error. Etc..."
It is 100% reproducible.

Thanks for your help.
Guillaume

* Below is the crash dump *

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1479
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1479
Last Changed Date: 2009-03-08 23:04:16 +0100 (Sun, 08 Mar 2009)

Java version: 1.6.0_12
Plugins: AgPifoJ;DirectUpload;cadastre-fr;utilsplugin;validator;wmsplugin
Plugin AgPifoJ Version: 14018
Plugin DirectUpload Version: 14015
Plugin utilsplugin Version: 13776
Plugin validator Version: 14015
Plugin wmsplugin Version: 13927
Plugin cadastre-fr Version: 13785

java.lang.NoSuchFieldError: worker

at cadastre_fr.DownloadWMSTask.download(DownloadWMSTask.java:68)
at cadastre_fr.MenuActionNewLocation.actionPerformed(MenuActionNewLocation.java:32)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by anonymous

Closed as duplicate of #2267.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.