Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#15186 closed defect (fixed)

NPE at JsonQueryUtil.queryAsync (Main.worker)

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin geochat Version:
Keywords: template_report regression Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. crash on launch

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-08-25 10:18:53 +0200 (Fri, 25 Aug 2017)
Build-Date:2017-08-25 08:21:06
Revision:12643
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12643 be) Linux Ubuntu 17.04
Memory Usage: 964 MB / 964 MB (743 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 2560x1440
Maximum Screen Size: 2560x1440
VM arguments: [-Djava.net.preferIPv4Stack=true]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (33160)
+ FastDraw (33182)
+ HouseNumberTaggingTool (33160)
+ Mapillary (v1.5.5)
+ PicLayer (33385)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ ejml (32680)
+ geochat (33088)
+ geojson (52)
+ geotools (33380)
+ imagery_offset_db (33316)
+ jts (32699)
+ reltoolbox (33311)
+ reverter (33088)
+ terracer (33088)

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Thread-14 (132)
java.lang.NullPointerException
	at geochat.JsonQueryUtil.queryAsync(JsonQueryUtil.java:72)
	at geochat.ChatServerConnection.autoLogin(ChatServerConnection.java:94)
	at geochat.ChatServerConnection$2.run(ChatServerConnection.java:126)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (9)

comment:1 Changed 3 months ago by Don-vip

Component: CorePlugin geochat
Owner: changed from team to Zverikk

comment:2 Changed 3 months ago by Don-vip

Description: modified (diff)
Summary: JOSM crashes on loadNPE at JsonQueryUtil.queryAsync

comment:3 Changed 3 months ago by bastiK

Ticket #15189 has been marked as a duplicate of this ticket.

comment:4 Changed 3 months ago by Don-vip

Ticket #15191 has been marked as a duplicate of this ticket.

comment:5 Changed 3 months ago by Don-vip

Ticket #15190 has been marked as a duplicate of this ticket.

comment:6 Changed 3 months ago by Don-vip

Keywords: regression added
Owner: changed from Zverikk to Don-vip
Status: newassigned
Summary: NPE at JsonQueryUtil.queryAsyncNPE at JsonQueryUtil.queryAsync (Main.worker)

regression caused by #15182

comment:7 Changed 3 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 12665/josm:

see #15182 - fix #15186 - fix #15192 - fix initialization of Main.worker (regression)

comment:8 Changed 3 months ago by Zverikk

Thanks for fixing this. I upgraded all deprecated API calls in plugin version 33546.

comment:9 Changed 3 months ago by Don-vip

Thank you! I'm sorry for the noise, I try very hard to avoid plugin breakage but I missed this one.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.