Changes between Version 2 and Version 4 of Ticket #16682


Ignore:
Timestamp:
2018-08-24T13:33:46+02:00 (3 years ago)
Author:
Don-vip
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #16682 – Description

    v2 v4  
    88Problems to resolve:
    99- JavaFX is based on native libraries, the plugin must install only those for the current platform. If I remember correctly the JOGL plugin does already something like this.
    10 - the plugin classes will have to be made available to JOSM core classloader for MP3 support => a new plugin property must be added for this (`Core-Export`?)
     10- ~~the plugin classes will have to be made available to JOSM core classloader for MP3 support => a new plugin property must be added for this (`Core-Export`?)~~ => The package `org.openstreetmap.josm.io.audio.fx` will have to move to this new plugin
    1111- the plugin will include OpenJFX 11. As we still need to support Java 8, the plugin must not be loaded on Java <= 10, for compatibility reasons => a new plugin property must be added for this (`Minimum-Java-Version`?)