Changeset 18165 in josm


Ignore:
Timestamp:
2021-08-22T23:17:02+02:00 (9 months ago)
Author:
Don-vip
Message:

see #17083 - drop old NSIS/Launch4J Windows installer

Location:
trunk/native/windows
Files:
7 deleted
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/native/windows/README.txt

    r7934 r18165  
    1 This is the Win32 installer generator for JOSM, to create a Windows
    2 like installer. This should ease installation and provides a reasonable set of
    3 default preferences for Windows users.
     1This is the Win32 installer generator for JOSM, to create a Windows installer.
     2This should ease installation for Windows users.
    43
    5 Currently only josm and a small assortment of josm plugins is included in the
    6 installer.
    7 
    8 As other osm related applications like osmarender and mapnik have a lot more
    9 UNIX related dependencies that will make them complicated to install, only JOSM
    10 is currently installed "the easy way".
     4Currently josm, the Java runtime and JavaFX are included in the installer.
    115
    126
     
    2317------------------------
    2418The installer will currently add:
    25 - josm into "C:\Program Files\JOSM" (or the corresponding international dir)
    26 - josm icons to the desktop and quick launch bar
    27 - josm file associations to .osm and .gpx files
    28 - some assorted plugins (more to follow?)
    29 - default preferences to the current user profile (if not already existing)
     19- josm and java/javafx runtime into "%CSIDL_LOCAL_APPDATA%\JOSM" (or the directory chosen by user)
     20- josm icons to the desktop
     21- josm file associations
    3022
    31 When the installed josm.exe is executed, it should ask the user to download
    32 Java runtime if it's not already installed.
    3323
    3424build the installer
    3525-------------------
    36 1.) You will need to download and install the following on your machine:
    37 - cygwin bash and wget
    38 - launch4j - http://launch4j.sourceforge.net/ (currently 3.6, older 2.x will NOT work!)
    39 - NSIS - http://nsis.sourceforge.net/ (any recent version should do)
     261.) You will need to download JavaFX modules from:
     27- https://gluonhq.com/products/javafx/
    4028
    41 2.) Edit the two absolute paths in the file josm-setup-unix.sh (in the calls
    42 to launch4jc and makensis)
     292.) Extract the modules to %JAVA_HOME%/jmods
    4330
    44 3.) Start a cygwin shell and call ./josm-setup-unix.sh
     313.) Start a cygwin shell and call ./native/windows/win-jpackage.sh
    4532
    46 how the installer is build
     334.) The JOSM.exe and JOSM.msi files can then be found in ./app/
     34
     35how the installer is built
    4736--------------------------
    48 First, wget will download the required files (e.g. the josm plugins) into the
    49 downloads subdir. Then jaunch4j wraps the josm.jar into a josm.exe, which
    50 makes registration of file extensions a lot easier. Then NSIS is called to
    51 create the actual josm-setup-latest.exe.
     37See jpackage documentation to understand what it does and how it works:
     38- https://docs.oracle.com/en/java/javase/16/jpackage/preface.html
    5239
    5340known issues
    5441------------
    55 - absolute paths in josm-setup-unix.sh
    56 - josm should support "global settings" instead of only the personal profile
    57 - install all josm plugins by default and only enable them according to user wishes?
     42- no translation
    5843
    5944build the installer under Linux / Debian
    6045----------------------------------------
    61 It's possible to build the installer under Linux. Beside the things mentioned above,
    62 the NSIS Debian package currently has an incomplete System.dll (in the plugins directory).
    63 This dll needs to be replaced by the System.dll included in the NSIS zip package, e.g. from
    64 http://nsis.sourceforge.net/Development_Files.
    65 More details can be found in the following NSIS forum thread:
    66 http://forums.winamp.com/showthread.php?s=bb7fa5bf8173e31c05e083340ca2c242&postid=2211132
     46It's likely not possible to build the installer under Linux because of the WiX transitive dependency.
Note: See TracChangeset for help on using the changeset viewer.