source: osm/applications/editors/josm/debian/rules@ 12474

Last change on this file since 12474 was 12474, checked in by joerg, 16 years ago

Compile each plugin and only insert the ones compiling, use new target to compile josm; add more commets to build script; add color to build output; add logfiles for compilation and reduce compile output

  • Property svn:executable set to *
File size: 1.4 KB
Line 
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6export DH_VERBOSE=1
7
8# This is the debhelper compatability version to use.
9#export DH_COMPAT=5
10export destdir = $(CURDIR)/debian/openstreetmap-josm
11
12
13build: build-stamp
14build-stamp:
15 dh_testdir
16
17 # Add here commands to compile the package.
18 # $(MAKE)
19
20 touch build-stamp
21
22clean:
23 dh_testdir
24 dh_testroot
25 rm -f build-stamp
26 rm -f dist/*.jar
27
28 # Add here commands to clean up after the build process.
29 -$(MAKE) distclean
30
31 dh_clean
32
33install: build
34 dh_testdir
35 dh_testroot
36 dh_clean -k
37 dh_installdirs
38
39# ./debian/update_svn_revision.sh
40 ./debian/make_install_files.sh --dest-path=${destdir} || exit -1
41
42
43# Build architecture-independent files here.
44binary-indep: build install
45 dh_testdir
46 dh_testroot
47 dh_installchangelogs
48 dh_installdebconf
49# dh_installdocs
50# dh_installexamples
51 dh_installmenu
52# dh_installlogrotate
53# dh_installemacsen
54# dh_installpam
55# dh_installmime
56# dh_python
57# dh_installinit
58# dh_installcron
59# dh_installinfo
60# dh_installman
61# dh_link
62 dh_strip
63 dh_compress
64 dh_fixperms
65# dh_perl
66 dh_installdeb
67 dh_gencontrol
68 dh_md5sums
69 dh_builddeb
70
71# Build architecture-dependent files here.
72binary-arch: build install
73# We have nothing to do by default.
74
75binary: binary-arch binary-indep
76.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch
Note: See TracBrowser for help on using the repository browser.