[[TranslatedPages(revision=69)]] [[PageOutline(2-4,Table des Matières)]] = Fenêtre d'Édition dans JOSM (Map View) = C'est la vue principale dans JOSM (également appelée [https://en.wikipedia.org/wiki/Viewport Fenêtre de travail]), dans laquelle les opérations d'édition est faite par le contributeur, et dans laquelle Bing/Mapbox et d'autres sources peuvent être affichées. [[Image(MapView2.png,500,link=)]] == Que voyez-vous ici et quand ? == Il y a plusieurs mécanismes dans JOSM qui affectent ce que l'utilisateur voit dans la Fenêtre d’Édition. === Que voyez-vous ? === * Les données peuvent être ''filtrées'' par l'utilisation des [wikitr:/Help/Dialog/Filter Filtres] * Les [wikitr:/Help/Dialog/LayerList Calques (données, imageries)] * peuvent être [wikitr:/Help/Dialog/LayerList#LayerButtons cachés] ou leur niveau [wikitr:/Help/Dialog/LayerList#VisibilityLayer d'opacité] peut être réglé * peuvent être masqués par d'autres calques de données (les [wikitr:/Help/Dialog/LayerList#PanelButtons boutons vers le haut/vers le bas] sont utilisés pour organiser les calques) * Les Styles de coloriage des cartes peuvent cacher les objets OSM par niveau de zoom === Apparence === * Le **remplissage partiel des objets** est activé par défaut, il **dépend de la surface de l'objet**. Les zones seront entièrement remplies si ''le remplissage partiel couvre plus de 50 % de la surface'' afin d'éviter les petits vides non remplis au milieu d'une zone. * Les modèles de Coloriage activés (dans les [wikitr:/Help/Preferences/Map#MapPaintStyles préférences]) et activés (dans la [wikitr:/Help/Dialog/MapPaint Fenêtre de Coloriage] ou dans les préférences) affectent ce que vous voyez à l'écran) * Les styles peuvent être affichés différemment en fonction du facteur de zoom == Paramètres d'affichage de la Fenêtre d'Édition == === Déplacement de la carte === La zone d'affichage peut être déplacée en **maintenant enfoncé** le `bouton droit de la souris`, et en **faisant glisser** la souris. Pour améliorer les performances du glissement, les étiquettes sont cachées pendant le déplacement de la carte : [[Image(Help/MapView:labels_hiding.gif,500,link=)]] Cela peut être désactivé dans les [wikitr:/Help/Preferences/Display#OSMData paramètres d'affichage des données OSM]. === Zoom === * Utilisation de la roue de défilement * les touches `+` et `-` * des actions et des outils de déplacement et de zoom plus spécialisés comme : * plusieurs éléments du [wikitr:/Help/Menu/View menu Affichage] * [wikitr:/Help/Action/JumpToPosition Aller à la Position] * [wikitr:/Help/Action/Zoom Outil de zoom] * [wikitr:/Help/Dialog/Minimap Mini carte] == Zone de téléchargement ==#Downloadedarea {{{#!comment la cible #Downloadedarea est appelée depuis la page Help/ExpertMode }}} La zone qui ''n'a pas'' été téléchargée est indiquée par une hachure jaune. Les chemins qui ont été téléchargés peuvent cependant être partiellement dans la zone hachurée. Veillez à modifier, des objets, uniquement dans la zone hachurée, car des modifications, dans la zone hachurée, pourraient entraîner des [wikitr:/Help/Concepts/Conflict conflits] ou des doublons après l'envoie des données. Notez que si vous téléchargez des données filtrées (par exemple, uniquement les bâtiments via l'[wikitr:/Help/Action/Download API Overpass]) il n'y aura pas de zone hachurée du tout car il s'agit d'un ensemble de données incomplet. Dès que vous téléchargerez une zone supplémentaire (contenant toutes les données de cette zone) dans ce calque, les hachures apparaîtront. Dans des scénarios de modification spéciaux, il peut être utile de désactiver les hachures. Cela peut être fait via le [wikitr:/Help/Menu/View menu Affichage] (uniquement en [wikitr:/Help/ExpertMode Mode Avancé]) ou dans les [wikitr:/Help/Preferences/Display#OSMData paramètres d'affichage des données d'OSM]. À utiliser avec prudence. Ne désactivez les hachures que si vous savez ce que vous faites. == Grille ==#Grid [[Image(Help/MapView:Grid.png,500,link=)]] Une grille configurable peut être affichée sur la Fenêtre d'Édition, par-dessus tous les calques, à titre d'aide visuelle : par exemple pour voir d'un seul coup d'œil quelles parties d'une grande zone ont déjà été modifiées, ou pour tracer un réseau de rues régulier. La grille est purement visuelle. Il n'y a **pas d'alignement automatique** sur les lignes de la grille ; le dessin et l'édition se déroulent exactement comme en l'absence de grille. Afficher et masquer:: [wikitr:/Help/Menu/View Affichage] > **Grille** > **Afficher**. Cette action peut également être ajoutée à la [wikitr:/Help/Preferences/Toolbar barre d'outils]. Paramètres:: Le menu [wikitr:/Help/Menu/View Affichage] > **Grille** > **Préférences de la grille…** ouvre directement la fenêtre [wikitr:/Help/Preferences/Grid Préférences > Grille] : Type de grille (Coordonnées projetées en mètres, ou Latitude/longitude en degrés), Espacement est et nord, Rotation, Origine, Épaisseur des lignes, Distance minimale entre les lignes à l'écran et Mode de fusion. Les couleurs des lignes se définissent dans [wikitr:/Help/Preferences/ColorPreference Préférences > Couleurs] ("lignes est de la grille", "lignes nord de la grille"). Par défaut, une grille de 1 000 m × 1 000 m en coordonnées projetées est affichée en jaune avec le mode de fusion « Lumière vive » afin qu’elle reste visible sur les éléments clairs et sombres de la carte. Les espacements d'une grille projetée correspondent à des distances réelles en mètres, identiques à celles mesurées par le [wikitr:/Help/Action/Parallel Mode Parallèle] et la barre d'état. Lors d'un zoom arrière, l'espacement est automatiquement multiplié par 10 (100, 1 000, …) dès que les lignes se rapprochent à moins d'un nombre de pixels configurable, afin que la grille reste lisible tout en restant alignée sur celle configurée. **Grille de latitude/longitude et limites mondiales :** lorsque l'on effectue un zoom arrière suffisant pour que le bord de la zone utilisable de la projection (par exemple, ±85° de latitude pour la projection de Mercator par défaut) devienne visible, les méridiens s'arrêtent à ce bord au lieu de se prolonger jusqu'au pôle. Ce comportement est normal : il s'agit de la même limite à laquelle sont soumis la projection elle-même, les données téléchargées et les images d'arrière-plan ; ce n'est pas un défaut de la grille. === Positionnement de la grille à partir de la sélection actuelle === Les deux options du menu [wikitr:/Help/Menu/View Affichage] > **Grille** permettent de positionner la grille à partir de la sélection actuelle dans le calque de données, sans avoir à saisir de coordonnées : Définir l'origine sur la sélection:: Déplace la grille de manière à ce qu’une ligne nord-sud et une ligne est-ouest se croisent au point sélectionné, puis active la grille. Sélectionnez un seul nœud (par exemple, un carrefour) pour utiliser sa position exacte ; pour toute autre sélection (plusieurs nœuds, un ou plusieurs chemins, une relation), l’origine correspond au centre de gravité — c’est-à-dire la position moyenne arithmétique de tous les nœuds accessibles à partir de la sélection. Pour une grille projetée, l’origine correspond également au point où l’espacement métrique est exact ; choisissez donc un point situé à l’intérieur de la zone sur laquelle vous travaillez. Le champ est désactivé tant que la sélection ne contient aucun nœud dont les coordonnées sont connues. Aligner la rotation sur la sélection:: Fait pivoter la grille de manière à ce que ses lignes soient parallèles à la sélection actuelle : soit dans un seul sens (de son premier nœud à son dernier), soit entre exactement deux nœuds. Sélectionnez d'abord un long tronçon rectiligne de l'une des rues. La grille passe alors en coordonnées projetées (une grille de latitude/longitude ne pouvant pas être pivotée) et est activée. Le champ de saisie est désactivé tant que la sélection ne définit pas de direction. Ces deux options suivent la sélection en temps réel ; elles s'activent et se désactivent donc automatiquement lorsque vous sélectionnez ou désélectionnez des objets ; il n'est pas nécessaire de rouvrir le menu. Déroulement type pour un réseau routier régulier existant : sélectionnez une rue principale rectiligne, puis choisissez Affichage > Grille > **Aligner la rotation sur la sélection** ; sélectionnez ensuite le nœud situé à une intersection, puis choisissez « Affichage > Grille > **Définir l'origine sur la sélection** ; enfin, définissez la taille du bloc comme espacement via Affichage > Grille > **Préférences de la grille... **. === Bordures de tuiles des calques d'imagerie === Indépendamment de la grille, les calques d'imagerie peuvent afficher une fine bordure autour de chacune de leurs tuiles : cliquez avec le bouton droit sur la carte (ou sur le calque dans la [wikitr:/Help/Dialog/LayerList liste des calques]) et cochez **Afficher les bordures des tuiles**. Cela permet de savoir quelle tuile est actuellement affichée, par exemple en combinaison avec l'option **Afficher les informations sur les tuiles**. Ce paramètre s'applique à ce calque et est enregistré avec celui-ci dans les [wikitr:/Help/Action/SessionSaveAs sessions]; son activation ou sa désactivation sont également mémorisées, de sorte que les calques ouverts ultérieurement et après un redémarrage de JOSM respectent le dernier choix. Sa couleur est "Bordure de tuile d'imagerie" dans [wikitr:/Help/Preferences/ColorPreference Préférences > Couleurs]. == Résolution des problèmes == Sur Mac avec une souris à un seul bouton, simulez le clic droit en maintenant la touche `Ctrl` enfoncée tout en cliquant sur le bouton. == Voir également == * **[wikitr:/Help/Action/Select Action Sélectionner]** - aide à la sélection, au déplacement et à la rotation des objets dans la fenêtre d'édition * **[wikitr:/Help/EditToolbar Modes]** - aperçu des modes (outils fréquemment utilisés) dans JOSM * [wikitr:/Help/StatusBar Barre de status] * [wikitr:/Help/Menu/ImageryContextMenu Menu Contextuel des Calques d'Imagerie] * La version originale de cette page en [wiki:/Help/MapView anglais] ---- Retour au [wikitr:/Help Menu d'aide]