wiki:De:HowTo

HowTo

Diese Seite wird Ihnen hoffentlich ein paar wertvolle Tipps geben können, wie man die Standardarbeiten in JOSM durchführt.

Wie man einzelne Linien auswählt

Man wird oft in die Situation kommen, dass sich zwei oder sogar mehrere Linien, einen einzelnen Punkt (node) teilen. Benutzen Sie in so einem Fall das Auswahlwerkzeug (en) um einen einzelne Linie auszuwählen.
Alternativ können Sie auch die Taste [S] drücken, um das Auswahlwerkzeug auszuwählen.

Wenn Sie mit der Maus auf den betroffenen Punkt zeigen und die mittleren Maustaste [MMT] drücken, wird Ihnen eine Liste mit der durch diesen Punkt führenden Linien angezeigt. Durch erneutes drücken der mittleren Maustaste [MMT], schalten Sie jeden einzelne Linie der Liste durch.
Schneller geht es jedoch, wenn Sie nach dem ersten drücken der [MMT] zusätzlich die Strg-Taste gedrückt halten. Solange Sie [Strg] gedrückt halten, bleibt die Liste geöffnet und Sie können mit der linken Maustaste [LMT] die gewünschte Linie in der Liste anklicken.

für Mac Benutzer

Auf dem Mac OSX gibt es, anders als bei einem Unix-System, keine Taste die als mittlere Maustaste arbeitet. Sie können die mittlere Maustaste mit einer Mighty Mouse benutzen. Verbinden Sie dazu die Mighty Mouse und öffnen Sie die Systemsteuerung. Klicken Sie auf 'Tastatur und Maus' und konfigurieren Sie die Ball-Taste als 'Taste 3'. Dann könnten Sie es als mittlere Maustaste benutzen.

Bitte beachten Sie:
Mit einem Apple-Treiber können Sie keine andere Taste als 'Taste 3' programmieren. Eventuell können Sie einen geeigneten Treiber für diese Zwecke finden.

Wie man eine Linie verlängert

Benutzen Sie zu nächste das Auswahlwerkzeug (en) [S] und wählen Sie den letzten Punkt der zu erweiternden Linie aus. Wechseln Sie danach zum Bearbeitungswerkzeug (en) [A], um neue Punkte zu erstellen. Die ausgewählte Linie wird jetzt automatisch mit jedem neuen Punkt verlängert und alle Eigenschaften der bisher bestehenden Linie werden übernommen.

Wie man einen Punkt zu einer Linie hinzufügt

Benutzen Sie das Bearbeitungswerkzeug (en) [A] und zeigen Sie mit dem Bearbeitungskreuz (Mauszeiger) auf die gewünschte Stelle der Linie. Das Bearbeitungskreuz ändert sich nun leicht und zeigt zusätzlich einen Pfeil zwischen zwei Punkten einer Linie. Dies bedeutet, Sie können an dieser Stelle einen neuen Punkt setzten.

Um zu der bestehenden Linie einen neuen Punkt hinzuzufügen, klicken Sie einfach mit der linken Maustaste [LMT] auf die gewünschte Stelle. Automatisch wird der neue Punkt gesetzt und das Programm erwartet nun, dass Sie weitere Punkte setzten um die Linie zu erweitern.

Wollen Sie die Linie nicht erweitern oder haben Sie die neue Linie fertiggestellt, so können Sie die Bearbeitung mit [ESC] beenden.

Wie man eine Kreuzung in einen Kreisverkehr ändert

Sollte es notwendig sein, eine Kreuzung in einen Kreisverkehr ändern zu müssen, kann man bei standardisierten Kreisverkehren das passende Attribut englisch "tag" heraussuchen und eintragen.

Sollte der Kreisverkehr jedoch größer sein oder eine andere Form als die Standardisierten haben, so muss man folgende Schritte durchführen...

Neuen Kreisverkehr erstellen
In diesem Abschnitt wird beschrieben, wie man einen Kreis für einen Kreisverkehr erstellt.

  • Zeichnen Sie mit dem Bearbeitungswerkzeug (en) Taste [A] eine Linie, die in der Länge dem Querschnitt des zu erstellenden Kreisverkehrs entspricht.

  • Wählen Sie die gezeichnete Linie mit dem Auswahlwerkzeug (en) [S] aus und klicken Sie in der Menüleiste auf Werkzeuge -> Kreis erstellen. Tastenkombination: [Umschalt]+[O]

  • Sollte der Kreis nicht rund genug sein, müssen Sie mit dem Bearbeitungswerkzeug [A] weitere Punkte zu dem Kreis hinzufügen und diesen wieder mit dem Auswahlwerkzeug [S] auswählen. Klicken Sie in der Menüleiste auf Werkzeuge -> Punkte im Kreis anordnen. Taste [O]
  • Wählen Sie den erstellten Kreis aus und verschieben Sie ihn, mit gedrückter linker Maustaste [LMT], mittig über die zu ersetzende Kreuzung.

  • Sie können die Ausrichtung des Kreises mit der Maus anpassen, indem Sie den Kreis auswählen und die Tasten [Strg]+[Umschalt] sowie die [LMT] gedrückt halten. Nun können Sie durch das einfache Bewegen der Maus, den Kreis ausrichten.

Kreuzung verlegen
In diesem Abschnitt wird beschrieben, wie man die Kreuzung auflöst und die bestehenden Wege mit dem neuen Kreisverkehr verbindet.

  • Um die Kreuzung aufzulösen muss man den Punkt der Kreuzung mit dem Auswahlwerkzeug [S] auswählen und in der Menüleiste auf Werkzeuge -> Linien trennen klicken. Taste: [G]
  • Zum Verschieben der einzelnen Punkte, der Linie, müssen Sie zunächst mit dem Auswahlwerkzeug [S] in einen leeren Bereich des Bearbeitunsfensters klicken. So deselektieren Sie den Punkt der Kreuzung wieder. Nun können Sie jede einzelne Linie vom Kreuzungspunkt wegziehen, indem Sie mit dem Auswahlwerkzeug den Kreuzungspunkt mit gedrückter linker Maustaste [LMT] auswählen und den Punkt durch eine Mausbewegung ziehen.

  • Um die Linie weiter aufzutrennen, wählen Sie den Punkt der Linie aus, an dem die Linie getrennt werden soll. Klicken Sie nun in der Menüleiste auf Werkzeuge -> Linie aufspalten. Taste: [P]. Und wählen Sie den Punkt erneut mit einem Linksklick aus. Jetzt müssen Sie nochmals auf Werkzeuge -> Linien trennen klicken. Taste: [G]. Die Verbindung der Linie wurde jetzt an dieser Stelle komplett aufgelöst. Indem Sie die linke Maustaste auf dem gerade getrennten Punkt gedrückt halten, können Sie die Endpunkte der Linienteile beliebig verschieben.

  • Wiederholen Sie die letzten beiden Schritte bei jeder Linie der ehemaligen Kreuzung.
  • Sie sollten nun zu jeder Linie einen Endpunkt haben, welchen Sie mit dem neu erstellten Kreisverkehr verbinden können.

Kreisverkehr verbinden
Hier werden zwei Möglichkeiten beschrieben, wie man den Kreisverkehr an die bestehenden Straßen anbindet.

Möglichkeit 1

  • Wählen Sie mit dem Auswahlwerkzeug [S] einen Endpunkt einer Linie aus und wechseln Sie zum Bearbeitungswerkzeug [A]. Automatisch wird eine Linie zum gewählten Punkt erstellt und Sie können mit einem Linksklick einen bestehenden Punkt des Kreisverkehrs anwählen um die Linie mit dem Kreisverkehr zu verbinden.
  • Dadurch ist ein zusätzlicher Punkt auf der bestehenden Linie entstanden den Sie z.B. zur Definition einer leichten Kurve nutzen können.
  • Überflüssige Punkte können Sie durch einen Klick auf Bearbeiten -> Entfernen oder Taste: [Entf] löschen.

Möglichkeit 2

  • Wählen Sie mit dem Auswahlwerkzeug [S] einen Endpunkt einer Linie aus und halten Sie [Strg] gedrückt um einen bestehenden Punkt des Kreisverkehrs auszuwählen. Die beiden ausgewählten Punkte können Sie durch klicken auf Werkzeuge -> Punkte vereinigen oder Taste: [M] verbinden.
  • Durch diese Methode wird kein zusätzlicher Punkt auf der bestehenden Linie erstellt. Meistens ist ein zusätzlicher Punkt, zur Definition einer Kurve oder ähnlichem, gar nicht notwendig.

Beachten Sie:

  • dass die Fahrtrichtung für den Kreisverkehr korrekt angegeben ist. Gegebenenfalls können Sie diese ändern, indem Sie den Kreis mit dem Auswahlwerkzeug [S] auswählen und via Bearbeiten -> Linienrichtung umkehren oder Taste: [R] umkehren.
  • gegebene Relationen der vorhandenen Linien nicht zerstört, unterbrochen oder gelöscht werden. Eventuell müssen diese auch durch den Kreisverkehr weitergeleitet werden.

Wie man Sprachnotizen und bestehende Audioaufnahmen verwendet

Nuten Sie dazu die Anleitung zum Audio Mapping (en).

Wie man die Programm-Einstellungen zurücksetzt

Beachten Sie die Hinweise Einstellungen zurücksetzen (en)

Benutzung von JOSM unter Linux

Eine der Möglichkeiten zum Ausführen wählen:

  • auf Application>Education>JOSM klicken (Ubuntu/Gnome, oder äquivalent)
  • josm (Kommande (Zeile im Terminal-Fenster oder anderswo))
  • java -jar ./josm-tested.jar (idem)

Die englische Anleitung dazu finden Sie hier JOSM Linux (en).

Wie man die Kartenprüfung nutzt

Sehen Sie hier Kartenprüfung (en).


Zurück zur Hilfe-Startseite

Last modified 2 months ago Last modified on 2018-02-20T13:44:30+01:00