wiki:Cs:VersionHistory

Starší novinky v JOSM

  • 2017-11-26 (stabilní verze 13170)
    • Text poznámek lze nyní označit a kopírovat; na odkazy lze kliknout
    • Možnost nahrávat data na pozadí
    • Neoznačí všechny znaky textového pole při přepínání mezi JOSM a další aplikací
  • 2017-10-29 (stabilní verze 13053)
    • Stažené oblasti mapy jsou zobrazeny v okně stahování a minimapě, výběr vrstev byl vylepšen
    • Nové tlačítko v editoru relací pro výběr upravované relace
  • 2017-10-06 (poslední verze 12926)
    • JOSM nyní používá nový certifikát pro podepisování kódu sponzorovaný FOSSGIS e.V. (potřeba pro WebStart)
  • 2017-10-03 (stabilní verze 12921)
    • Přidány odkazy na externí prohlížeče změn do oken historie a správy sad změn
    • Přidána možnost požádat o posouzení změn v okně nahrávání dat
    • Funkce vytváření kruhů automaticky použije nezbytný počet bodů v závislosti na průměru
    • Nové parametry příkazové řádky určené ke spouštění některých úloh bez grafického rozhraní:
      • Rendering osm dat dle stylopisu MapCSS
      • Konverze souřadnic z jednoho systému do jiného
  • 2017-09-02 (stabilní verze 12712)
  • 2017-07-30 (stabilní verze 12542)
    • Vyhledávání dle předvolby v okně hledání.
    • Nová „domovská lokalita“ v záložkách (pokud ji má uživatel nastavenu na svém OSM účtu) a záložky posledních 15 sad změn.
  • 2017-07-02 (stabilní verze 12450)
  • 2017-05-29 (stabilní verze 12275)
  • 2017-05-02 (stabilní verze 12039)
    • Změna projekce (ohýbání) podkladových vrstev: umožňuje kombinovat vrstvy různých systémů projekce.
  • 2017-04-02 (stabilní verze 11826)
    • Pomocí "upload=never" v osm souboru lze zabránit uploadu této vrstvy.
    • V expertním režimu lze vypnout automatický zoom na stažená data.
  • 2017-02-27 (stabilní verze 11639)
    • GPS heat-mapa má teď nějaká nastavení pro úpravu svého vzhledu.
    • Mirror servery mapových podkladů teď lze vybrat v Nastavení mapových podkladů.
  • 2017-02-02 (stabilní verze 11526)
    • GPS trasy je možné zobrazit v režimu heat-mapy.

2016

  • 2016-12-31 (stabilní verze 11427)
    • Interní databáze hranic všech zemí. Pravidla validátoru nebo styly zobrazení je možné omezit na konkrétní stát.
    • Přetahování URL odkazů pro jednoduché stahování dat nyní podporuje všechny typy URL z okna Otevřít z URL.
    • Textová pole pro vkládání klíčů a jejich hodnot jsou předvyplněna další hodnotou ze seznamu, pokud je předchozí již použita.
  • 2016-11-06 (stabilní verze 11223)
  • 2016-09-05 (stabilní verze 10966)
  • 2016-08-12 (stabilní verze 10786)
    • Přechod na Java 8 s přepracováním jádra JOSM
    • Nová funkce "Vložit na zdrojovou pozici" v menu Upravit (Ctrl+Alt+V, pouze v expertním režimu)
    • Podpora geo odkazů
  • 2016-07-12 (stabilní verze 10526)
    • Zásadní přepracování jádra JOSM
  • 2016-04-28 (stabilní verze 10161)
  • 2016-03-13 (stabilní verze 9979)
    • OAuth je nyní výchozí metodou autorizace.
    • Podpora Drag & Drop v editoru relací (více informací)
    • Nové tlačítko v editoru relací pro aktualizaci relace (např. po rozdělení cesty)
    • Dialog historie zobrazuje původní a nové koordináty přesunutých bodů na mapě
    • Automatický zoom přizpůsobující se výchozímu rozlišení podkladu
    • Rozšířená podpora různých typů projekcí

2015

  • 2015-12-31 (stabilní verze 9229)
  • 2015-11-23 (stabilní verze 9060)
    • Podpora bokmål formy norštiny
  • 2015-10-30 (stabilní verze 8969)
    • Rozdělování cest: recykluje id/historii pro nejdelší zbývající úsek (v expertní režimu si lze vybrat jiný, vypne se to splitway.segment-selection-dialog=false)
    • Zobrazení ikon bodů z mapview i v seznamech (např. v dialogu výběru, editoru relací nebo dialogu nahrávání)
  • 2015-09-28 (stabilní verze 8800)
    • Integrace stahování dat z Overpass a průvodce Overpass Turbo (Pouze v režimu pro experty)
    • Přidána minimapa
    • Přidán odkaz na taginfo
    • Nastavitelná Gamma pro podkladové mapy
  • 2015-08-22 (stabilní verze 8677)
  • 2015-06-17 (stabilní verze 8491)
    • Podpora běloruštiny
    • Podpora vietnamštiny
  • 2015-04-18 (8227)
    • Podpora valencijštiny
  • 2015-03-31 (8160)
    • Podpora litevštiny
  • 2015-03-02 (8109)
    • Podpora více fontů a jazyků ve Windows
    • Některé pluginy lze nyní instalovat a používat bez restartu JOSM.
    • Nové pole vyhledávání v hlavním menu (vpravo nahoře)
    • Integrované poznámky jsou nyní ve výchozím stavu zapnuty (plugin je označen jako zastaralý).
  • 2015-02-18
    • Web Launchpadu používaný pro překlad JOSM by měl být opět funkční bez opakovaných timeoutů.

2014

  • 2014-12-29 (7906)
    • Dvě nové lokalizace: asturština a khmerština.
    • Na systémech OS X a Windows přepracovány adresáře konfigurace, uživatelských dat a cache.
  • 2014-12-10 (7777)
  • 2014-10-21 (7643)
    • Opraveny zásadní chyby v klávesových zkratkách a ošetření konfliktů při slučování cest.
  • 2014-09-30 (7588)
    • Lepší integrace do OS X (detaily v #10455).
    • Zobrazení OSM tagů v rozhraní předvoleb.
  • 2014-09-20 (7569)
    • JOSM nyní varuje u multipolygonů vytvořených starším způsobem s tagy nad vnější cestou místo nad relací, které je třeba převést.
  • 2014-08-31 (7480)
    • Vylepšení základního mapového stylu:
      • Symboly bodů a ikony jsou při menším přiblížení skrývány (konfigurovatelné v nastavení stylu).
      • Lepší umisťování názvů uvnitř ploch
      • Názvy silnic a ulic jsou zobrazovány podél cest
    • Offline režim s novým argumentem příkazové řádky --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Do 30. září pořádáme soutěž o nové logo! Podrobnosti na wiki.
  • 2014-07-04 (7287)
  • 2014-05-18 (7139)
    • Výchozí mapový styl JOSM konvertován z XML do MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Migrace na Javu verze 7, mnoho čistění kódu
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Přístup k OSM API pomocí HTTPS
  • 2014-01-29 (6767)
    • Kontrola tagů na základě MapCSS, rozšiřitelná o vlastní pravidla
    • Přidání akce "Najít objekt v předvolbách" Shift-F3
    • Vylepšení předvoleb, MapCSS a validátoru

2013

  • 2013-12-20 (6502)
    • Dotaz na zdroj (source) dat v dialogu odesílání na OSM server
    • Dialog historie: načíst a zobrazit komentář datové sady
    • source:trunk/images/mapmode/improvewayaccuracy.png Zpřesnit cestu zpřístupněno ve standardním režimu
    • Mnoho dalších vylepšení a oprav chyb viz (změny)
  • 2013-11-17 (6388)
    • Aktualizace překladů
  • 2013-11-12 (6383)
    • Nový příkaz na odpojení nodu od cesty
    • Upozornění na nové zprávy na webu OSM
    • Mnoho drobných vylepšení předvoleb, stylů, validátoru a dalších částí
  • 2013-09-20 (6238)
    • Nové neobtěžující notifikace
    • Položka "sezení" v menu soubor, viditelná v expertním režimu
    • Kompletní podpora GPX tras
    • Mnoho drobných vylepšení předvoleb, restartu, stylů a validátoru, včetně výkonosti
  • 2013-08-07 (6115)
    • Požadavek na oprávnění OAuth kvůli plné podpoře nového pluginu notes
    • Přepracování menu pluginů pro lepší podporu seskupování a interakce
    • Preference potomka (posledního) vybraného objektu v případě výběru duplicitních nodů
    • Mnoho dalších vylepšení a oprav chyb viz (změny)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • možnost nastavit klávesové zkratky na předvolby a další tlačítka nástrojové lišty a nové kontextové menu "Upravit zkratku" pro jejich definici
    • automatické přibližování ve WMS vrstvách
    • nová akce "Skrýt panely" na klávese TAB pro ukrytí/zobrazení postranního panelu
  • 2013-05-08 (5939)
    • integrován plugin restart
    • pro všechny textové komponenty doplněno menu na pravý klik "zpět, vyjmout, kopírovat, vložit, smazat, vybrat vše"
    • zlepšení výkonu příkazu vyčistit
  • 2013-04-08 (5836)
    • zásadní přepracování kontextových menu
    • přidáno tlačítko "vyčistit buffer" určené o odstranění nevalidního obsahu pro akci "vložit tag z textu"
    • odstraněna podpora pro (zastaralý) ofsetový server podkladů
  • 2013-03-07 (5759)
    • Ctrl-Shift-V umí nyní vložit tagy z textového bufferu, např., a=2,c=3 a a 2 c 3
    • spousty vylepšení renederování MapCSS
    • možnost přetahování nodů v režimu tažení
    • kontextové menu v dialogu Přidat/Upravit hodnotu, možnost opravit rozvržení kláves
    • základní filtrování podle data pro GPS záznamy
    • vzdálené ovládání: možnost mazání tagů a vytváření objektů s tagy
    • mnoho drobných úprav a oprav
  • 2013-02-06 (5697)
    • v editoru relací a při vytváření relací jsou nabízeny odpovídající role
    • možnost filtrovat v seznamu relací
    • několik vylepšení dialogu "Přidat hodnotu" včetně tlačítka nápovědy, zapamatování pozice a možnost přidat několik tagů za sebou bez zavření dialogu (mrkněte na nápovědu)
    • nová položka podkladů wms_endpoint a přepracování dialogu WMS/TMS
    • nový test validátoru pro adresy, odkazy na Wikipedii a vylepšení výkonu při vykreslování a opravě chyb
    • mnoho drobných vylepšení

2012

  • 2012-12-08 (5608)
    • nový operátornth: a nth% umožňující hledat pozici v cestě
    • drobné úpravy externího ovládání a interních předvoleb
  • 2012-11-10 (5576)
    • podpora "námořní míle" (NM) jako systému jednotek
  • 2012-10-08 (5531)
    • přepracováno testovaní budov validátorem
    • při nahrávání na server jsou automaticky odstraňovány některé tagy (TIGER, odbl, yh)
    • odstraněn kód týkající se změny licence
  • 2012-08-29 (5482, 5485)
    • poskytovatelé podkladových vrstev se nabízejí v závislosti na stahované oblasti dat
    • při přidávání tagů prvkům mapy se zobrazuje pět naposledy přidaných, které lze vybrat
    • nástroj filtrování dostal lepší podporu multipolygonů
    • Nadále již není možné otevřít adresář z menu 'Soubor > Otevřít...'- a načíst automaticky všechny obsažené obrázky. Můžete soubory vybrat přímo (pomocí Ctrl-A nebo Shift+klik). Nástroj 'Import obrázků' z kontextového menu GPX vrstvy funguje stále stejně, takže můžete rekurzivně načíst fotky obsažené ve všech podadresářích.
  • 2012-07-23 (5353, 5356)
    • opravy chyb při zpracování dat změněných botem kvůli změně licence
    • drobné opravy a vylepšení mapových stylů a testů validátoru, včetně vykreslování neaktivních vrstev a zobrazování názvů ve výstupu validátoru
  • 2012-07-03 (5315)
    • opravy validátoru, dialog konfliktu při slučování vrstev
    • drobná vylepšení dialogu konfliktu včetně možnosti výběru (dvojklik) a zvětšení (kontextové menu)
    • drobná vylepšení testů validátoru
  • 2012-06-04 (5267)
    • nové jazyky: Portugalština (evropská) (pt), Katalánština (ca)
    • podpora uživatelských projekcí
    • při vytvoření multipolygonu jsou tagy přesunuty na relaci
  • 2012-05-02 (5210)
    • Různá drobná vylepšení
      • alternativní dialog vyhledávání nastaven jako výchozí
      • parametr příkazové řádky --load-preferences= pro načtení konfigurace JOSM při startu
      • MapCSS umožňuje různé stylování levé a pravé strany
  • 2012-04-14 (5181)
    • Úvodní stránka josm.openstreetmap.de byla reorganizována a zjednodušena
    • Otestovaná verze (5181) byla vydána s mnoha změnami a vylepšeními, zahrnujícími
      • source:trunk/images/mapmode/rope.png režim výběru lasem (v expertním režimu)
      • informační dialogy pro začátečníky: varování před nesprávně zaměřeným podkladem, kombinacemi cest s konfliktními tagy nebo jejich umísťování do relací
      • nová funkce při editaci relací: "Přidat výběr do relace" (pravým kliknutím na relaci), "Vybrat předchozí/další mezeru" (v editoru relací)
      • vylepšení uživatelského rozhraní v menu Zobrazit: "Styly kreslení mapy", možnost skrýt editační nástrojovou lištu
      • několik vylepšení rychlosti startu
  • 2012-02-07 (4905)
    • Přidány klávesové zkratky pro editor relací: Alt-Up, Alt-Down (posun vybraného člena nahoru/dolu), Alt-Del (odstranění člena) a Alt-Home (stažení nekompletních členů)
    • Dostupná sumarizovaná historie obsahující změny mezi stabilními verzemi.
  • 2012-02-02 (4897 ...)
    • Opraveny konflikty klávesových zkratek mezi JOSM a pluginy. Spousta funcí kolem klávesových zkratek byla přepracována!
  • 2012-01-22 (4846)
    • Plugin ImproveWayAccuracy byl integrován do jádra. Vyberte cestu, klikněte na source:trunk/images/mapmode/improvewayaccuracy.png, a zlepšete její přesnost. Detailní informace o použití najdete na stránce nápovědy.
  • 2012-01-21 (4791, 4796, 4833)
    • Různá rozšíření funkcionality vzdáleného ovládání: nový příkaz '/load_object' pro stahování objektu dle id; příkaz '/add_way' pro vytvoření nové cesty se zadanými koordináty; parametr 'new_layer' pro příkaz '/load_and_zoom' způsobující načtení dat do nové vrstvy.
  • 2012-01-12 (4789)
    • Nový parametr příkazové řádky pro nastavení libovolné předvolby při startu. (např. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Zvýrazňování bodů a cest pod kurzorem myši může být vypnuto: 'Konfigurace' > 'Nastavení zobrazení' > 'OSM Data' (pouze v expertním režimu)
    • V režimu kreslení source:trunk/images/mapmode/node/autonode.png je možné použít modifikátor režimu na klávese tab a docílit tak přilepování čar do celočíselných úhlů (např. 30/45°).
  • 2012-01-04 (4765)
    • Automatické skrývání tlačítek dialogů po pravé straně může být deaktivováno pro každé okno zvlášť. (Symbol oka v pravém horním rohu)

2011

  • 2011-12-29 (4745)
    • Nový příkaz pro přednačítání a cachování WMS podkladů podél gpx trasy. (V kontextovém menu GPX vrstvy)
  • 2011-12-20 (4673)
    • Pro Francii dostupná Lambertova 93 projekce (EPSG:2154).
  • 2011-12-20 (4670)
    • Z důvodu nedostatečné podpory odstraněny lokalizace do Arabštiny, Islandštiny a Hebrejštiny.
  • 2011-12-05 (4621-4636)
    • Zlepšen výkon při práci s rozsáhlými multipolygony.
  • 2011-11-26 (4609, 4611)
    • Tlačítka editační nástrojové lišty (vlevo nahoře) mohou být skryta.
    • Backspace vrátí zpět poslední krok při kreslení cest.
  • 2011-11-20 (4601)
    • Historie verzí nyní zobrazuje stav akceptace nové licence u každého editora objektu.
  • 2011-11-15 (4595)
    • Podpora vícefázových klávesových zkratek. Např. Ctrl+Alt+S, 1 přepne viditelnost první vrstvy.
  • 2011-11-14 (4593)
    • Menu na malých obrazovkách není již oříznuté a lze jím scrolovat.
  • 2011-11-07 (4587)
    • Nová možnost v dialogu vyhledávání přidání tlačítka do nástrojové lišty. Tlačítko lze následně odstranit pravým kliknutím na něj. (Pouze v expertním režimu.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Interní formát pro ukládání uživatelské konfigurace byl změněn na XML.
  • 2011-10-29 (4546)
    • Text zobrazovaný nad body, cestami a relacemi může být upraven pomocí jmenných šablon.
  • 2011-10-20 (4530)
  • 2011-10-10 (4512)
    • Implementován expertní režim aby se zlepšila přívětivost aplikace pro nové uživatele. Z důvodu zachování kompatibility zůstanou všechny stávající instalace v tomto režimu.
  • 2011-10-07 (4497, 4498, 4500)
    • Další možnosti v menu 'Soubor > Stáhnout objekt...'.
    • Dialog historie: Lepší zobrazení přidaných / odstraněných bodů cest (a členů relací).
    • Nové klávesové zkratky v dialogu vlastností prvku: Alt+A, Alt+S, Alt+D pro Přidat, Upravit a Smazat.
  • 2011-09-23 (4454)
    • Kopírování klíče a jeho hodnoty do schránky pravím kliknutím v dialogu vlastností prvku.
  • 2011-09-12 (4416, 4423)
    • Hranice podkladové mapy jsou zobrazeny na náhledové mapce v konfiguraci.
  • 2011-09-08 (4408)
    • Položka menu 'Prozkoumat' byla přesunuta z konextového menu výběru do 'Zobrazit > Rozšířené informace'.
  • 2011-09-07 (4405)
    • Seznam v konfiguraci podkladových obrázků je řazen podle kódu státu.
  • 2011-08-29 (4380)
    • Nová možnost 'Upravit > Kopírovat souřadnice'.
  • 2011-08-28 (4371)
    • Seznam naposledy otevřených souborů zobrazuje ne jen otevřené, ale i uložené soubory.
  • 2011-08-27 (4355)
    • Dynamické zobrazování řádku s tlačítky vpravo (volitelné, rozšířené volby 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Klávesové zkratky pro viditelnost vrstev (Alt-1 až Alt-9)
  • 2011-08-21 (4332)
    • Výběr zobrazovaných záznamů pro každou GPX vrstvu (kontextové menu v seznamu vrstev)
  • 2011-08-21 (4327)
    • Režimy výběru a mazaní jsou nyní lépe vizuálně indikovány včetně zobrazení změny, kterou akce způsobí (zvýraznění, změna kurzoru).
  • 2011-07-18 (4256)
    • Podpora vektorového obrázkového formátu SVG.
  • 2011-07-14 (4241)
    • Bere v potaz informace o orientaci JPEG obrázků z EXIF hlavičky.
  • 2011-07-07 (4207)
    • GPS trasy mohou být obarveny v závislosti na směru.
  • 2011-06-18 (4142)
  • 2011-06-11 (4126, 4129, 4134)
    • Optimalizace využití paměti a rychlejší vykreslování GPX tras
    • Nový režim kreslení: Přidej paralelní cestu vedle existující. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • Nová funkce Sledování linie pro zjednodušení kreslení spolu hraničících oblastí. (podobné klávesové zkratce "F" Potlatchu 2)
    • Hledání (a Filtrování) nyní umožňuje práci s uzavřenými plochami, je možné hledat minimální a maximální ohraničenou plochu. (Klíčová slova: closed; areasize:MIN-MAX nebo areasize:MAX, v m²)
    • Stáhnout objekt... akceptuje seznam identifikátorů.
  • 2011-04-18 (4032)
    • Do panelu nástrojů přidány upravitelné texty pro vyhledávání a možnost vlastních ikon pro vrstvy na pozadí.
    • Upraveno zobrazení stavu licencování (zelené zatržítko - odsouhlaseno, šedé - odsouhlaseno automaticky, červené - zamítnuto)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Nová funkce Následování bodu - přesune pohled tak, aby naposledy umístěný bod byl vycentrován. (Hlavní menu > Zobrazit; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Pluginy imagery,wmsplugin,slippymap a remotecontrol jsou integrovány do jádra JOSM.
  • 2010-12-07 (3705)
    • Vrstvy mohou být zobrazeny průhledné. (nové tlačítko v dialogu nad seznamem vrstev)
  • 2010-12-07 (3702)
    • Podpora změny měřítka objektů. (Ctrl+Alt v režimu výběru)
    • info K rotaci objektu použijte Ctrl+Shift.
  • 2010-11-25 (3669)
    • Plugin Validator byl integrován do základu.
  • 2010-09-23 (3557, #5427)
    • Změna režimu “vytváření ploch” (X): Při opakovaném tažení v jednom směru nevznikají nadbytečné body. (Pomocí klávesy shift lze docílit původního chování.)
  • 2010-09-14 (3529)
    • U tagů uvedených v předvolbách, můžete v prohlížeči přímo otevřít odpovídající wiki stránku.
  • 2010-09-03 (o22964)
    • WMS plugin nyní podporuje zjišťování schopností serveru (GetCapabilities).
  • 2010-08-13 (3431)
    • Nový příkaz Purge může vyčistit datové vrstvy.
  • 2010-07-27 (3388)
    • Nový dialog hledání předvoleb.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Hledání podporuje vyhledávání podle rolí v relacích.
    • Dialog vlastností prvku zobrazuje pozici v relacích, jihž je členem.
  • 2010-06-01 (3291)
    • Od této verze jsou používány role definované v předvolbách. To může způsobovat varovná hlášení validátoru u relací, které JOSM nezná.
    • Členové vybrané relace jsou znázorňováni jinou barvou než přímo vybrané prvky mapy.
  • 2010-04-16 (3189)
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • Nový dialog stažení objetku dle id a volitelně všech cest a relací jihž je součástí.
  • 2010-01-28 (2901)
    • Novinka: Duplikování vybrané datové vrstvy bez vazby na soubor.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Poznámka pro uživatele AgPifoJ: Nyní můžete otevírat obrázky z hlavního menu (Soubor > Otevřít...) nebo z kontextového menu odpovídající GPX vrstvy.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • Nový Dialog sad změn zobrazující informace o jednotlivých sadách, jejich stažení, uzavření a zobrazení.
  • 2009-12-05 (2575)
    • Pluginy utilsplugin a AgPifoJ byly integrovány do jádra JOSM.
  • 2009-11-24 (2513)
    • Projekce podporují parametry a jejich kódy a hranice se zobrazují uživateli.
  • 2009-10-25 (2313)
    • Zobrazení stavu propojení v editoru relací je nyní v grafické a srozumitelnější podobě.
    • Názvy oblastí jsou zobrazovány (světle šedou) pokud se vejdou do oblasti.
  • 2009-09-16 (2147)
    • Záložka pluginů v konfiguraci obsahuje nyní možnost vyhledat plugin dle názvu, popisky a verze, které je možno uvést v libovolném pořadí, a oddělit mezerami.
  • 2009-09-14 (2133)
    • Do nástrojové lišty byly přidány odkazy na položky předvoleb.
  • 2009-09-13 (2124)
    • JOSM nyní umožňuje použítí několika otevřených sad změn zároveň. Pokud potřebujete provést nesouvisející změnu, můžete ji nyní správně otagovat.
  • 2009-09-13 (2118)
    • Menu předvoleb je nyní rozčleněno do několika kategorií místo předchozího dlouhého seznamu. To by mělo usnadnit práci na menších obrazovkách a hledání správných položek.
  • 2009-09-12 (2109)
    • Nová obsluha kliknutí prostředním tlačítkem umožňuje měnit vybraný prvek pod kurzorem. To umožňuje snadnější výběr překrývajících se prvků.
  • 2009-09-02 (2026)
    • V režimu mazání se mění ikona ukazatele myši v závislosti na typu objektu na který ukazuje.
  • 2009-07-15 (1790)
    • Kompletní přestavba editoru relací.
  • 2009-07-11 (1767)
    • JOSM pluginy nyní podporují různé verze (minimálně u pluginů spravovaných pomocí SVN). Aktualizace pluginů by již neměly způsobovat jejich nefunkčnost.
  • 2009-07-07 (1743)
    • JOSM nyní podporuje snadno použitelná přednastavení a zobrazovací styly. Podívejte se na stránky Presets a Styles.
  • 2009-06-28 (1709)
    • Podpora zobrazování editační historie elementů v JOSM.
  • 2009-06-07 (1652)
    • Nový dialog při řešení konfliktů (pokud je objekt změněn během vaší editace).
  • 2009-05-30 (1628)
    • Konfigurace je nyní ukládána v UTF-8. Uživatelé nepoužívající latinku budou muset upravit své texty nebo resetovat nastavení.
  • 2009-05-19 (1605)
    • Standardní souřadnicový system byl změněn z EPSG:4326 na Mercator.
  • 2009-05-19 (1603)
    • Nové operátory parent a child umožňují hledat potomky a rodiče objektů splňujících kritérium hledání.
  • 2009-02-14 (1405)
    • Spousta novinek v režimu kreslení (dvojklik ukončuje kreslení). Je také možné přepnou konfiguraci do stylu Potlachu Vše-V-Jednom.
  • 2009-01-31 (1358)
    • V mapě jsou zobrazovány restrikce směru, hvězdička u relace znamená problém
    • První krůčky k implementaci přednastavení pro relace
  • 2009-01-10 (1231)
    • Soubory se mohou otevírat přetažením do okna s JOSM (Táhni a Pusť)
  • 2009-01-08 (1213)
    • Vyhledávání nyní podporuje regulární výrazy.
  • 2009-01-03 (1208)
    • Bylo vylepšeno zobrazování názvů bodů na mapě. Pokud není k dispozicí název, bude použito ref, operator nebo brand. Taktéž jsou zobrazovány názvy neznámých tagů (bez ikon).
  • 2009-01-02 (1203)
    • Od této verze je podporováno vykreslování relací multipolygonu. Konfigurační volbu "mappaint.multipolygon=true" si musíte nastavit ručně (později bude výchozí). Pokud je před názvem relace * pak JOSM nahlásí chybu. K zobrazení těchto chyb použijte plugin validátor.

2008

  • 2008-12-25 (1180)
    • Tato revize odstraňuje z JOSM spoustu nepoužívaného kódu. Staré pluginy nebudou s nejvyšší pravděpodobností funkční. Aktualizujte vše.
  • 2008-11-28 (1078)
    • Pokud máte v konfiguraci povoleno "zobrazení hranic stažených dat" (a doteď jste videli žlutý obdélník pro každou staženou oblast), tak nyní bude nestažená oblast šrafována a stažená oblast čistá. To poněkud ulehčí editace, protože nebude upravovaná oblast pomalována sem tam žlutými čarami.
  • 2008-11-14 (1076)
    • Funkce "uspořádat body do odélníku" byla nahrazena obecnější fukcí která umožňuje upravit do pravých úhlů libovolný útvar nebo linii, která je "téměř" pravoúhlá.
  • 2008-10-29 (1058)
    • Překlad JOSM byl restrukturalizován. Jazykové pluginy již nejsou třeba a překlady jsou součástí JOSM. Jazyk je detekován na základě systémového nastavení - locale - nebo parametrem --language.
  • 2008-10-05 (1023)
    • VAROVÁNÍ: JOSM nyní podporuje uživatelskou konfiguraci klávesových zkratek. Došlo ale k nějakým změnám standardního nastavení. Konfiguraci používejte opatrně, předejdete tím ztrátám vaší práce při omylech.
  • 2008-08-24 (858)
    • Akce rozpojení byla integrována. Není nadále třeba používat plugin.
  • 2008-08-19 (805)
    • Verze obsahuje nový režim kreslení. Při použití nástroje výběru jsou uprostřed cest zobrazovány malé kříže. Pokud dojde ke kliknutí na takový kříž, stane se z něj standardní bod. Toto hodně ulehčí práci. Pokud takové chování nechcete, vypněte používání virtuálních bodů v konfiguraci.
  • 2008-05-20 (643)
    • V této verzi došlo k malé modifikaci kreslícího režimu: SHIFT+CLICK nyní vybírá bod a nahrazuje jím stávající výběr(před změnou bylo možné vybrat pouze v případě, že nebylo nic vybráno). Toto je konzistentnější chování a není třeba se tak často přepínat do výběrového režimu.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Pomocník kreslení zobrazuje spojnici mezi posledním nakresleným bodem a potenciálním novým bodem. Pokud chcete tuto funkci vypnout, použijte "draw.helper-line" a nastavte na "false".
  • 2008-05-08 (608)
    • Stavový řádek nyní obsahuje informaci o pozici, úhlu a délce přidané linie.
  • 2008-05-08 (547)
    • Nyní obsahuje integrovanou podporu pro Audio mapování za pomoci kontinuálně zaznamenávaných zvukových záznamů

Last modified 5 years ago Last modified on 2013-06-25T23:16:45+02:00