Modify

Opened 6 years ago

Closed 6 years ago

#8570 closed defect (fixed)

JOSM does not clean up temporary jar_cache files

Reported by: maarten Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description (last modified by Don-vip)

I am using JOSM webstart, currently version 5759 on Windows XP. I have observed the same when using a downloaded JOSM

JOSM creates files called jar_cache*.tmp in the users temporary directory ("%USERPROFILE%\Local Settings\temp") and does not clean them up after exiting.
Some files are sometimes empty, some files contain tiles from the download dialog (rename the file to .png and open them in an image viewer).

It would be nice if JOSM would delete these files after exiting.

Attachments (0)

Change History (9)

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 6 years ago by Don-vip

Confirmed. I have myself:

  • 75 PNG tiles, all of them clearly being partially downloaded (the bottom is black)
  • 11 HTML files, all of them being the JOSM Startup page, but partially downloaded (file ends at a random location)
Version 0, edited 6 years ago by Don-vip (next)

comment:3 Changed 6 years ago by Don-vip

Looks like a Java bug to me, JOSM does not seem to create these files by itself, at least for the StartupPage.
What is your Java version ?

comment:4 Changed 6 years ago by maarten

Currently Java version 7 update 15 (build 1.7.0_15-b03) but I have seen this behaviour a long time, so it is not something new.

comment:5 Changed 6 years ago by Don-vip

I rather hoped for a Java 6 bug. Too bad.

comment:6 Changed 6 years ago by Don-vip

In 5834/josm:

see #8570 - close stream after reading page from wiki

comment:7 Changed 6 years ago by Don-vip

In 5839/josm:

see #8570 - close more streams

comment:8 Changed 6 years ago by Don-vip

In 5874/josm:

see #8570, #7406 - I/O refactorization:

  • Move different file copy functions to Utils.copyFile (to be replaced later by Files.copy when switching to Java 7)
  • Replace all Utils.close(XXX) by Utils.close(Closeable) -> impacted plugins: commandline, mirrored_download, opendata, piclayer
  • Add new Utils.close(ZipFile)
  • Use of Utils.close almost everywhere
  • Javadoc fixes

comment:9 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

Should be fixed in [o29528].
Please reopen if new temp files are still created with tomorrow's latest.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.