Modify

Opened 9 years ago

Closed 9 years ago

#8569 closed defect (duplicate)

Impossible to validate or upload new data => WARN - ZERO NODES

Reported by: neopolis Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: Cc:

Description

JOSM produce an error (WARN - ZERO NODES)during validation process resp. upload new data to OSM server. Also delete the whole street and rebulid them again. But it doesn't fix the problem.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-03-07 02:31:35
Last Changed Author: Don-vip
Revision: 5759
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-03-06 22:41:42 +0100 (Wed, 06 Mar 2013)
Last Changed Rev: 5759

Identification: JOSM/1.5 (5759 en)
Memory Usage: 66 MB / 494 MB (19 MB allocated, but free)
Java version: 1.7.0_17, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows XP

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=176877006 version=3 MVT nodes=[]} has zero nodes


Plugin: buildings_tools (29210)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.validation.tests.WayConnectedToArea.visit(WayConnectedToArea.java:29)
	at org.openstreetmap.josm.data.osm.Way.visit(Way.java:198)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:144)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:170)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.

Attachments (1)

melchingen.zip (302.2 KB) - added by neopolis 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Don-vip

Owner: changed from team to neopolis
Status: newneedinfo

Could you please attach your .osm file ? Thanks.

comment:2 Changed 9 years ago by neopolis

Sorry it's impossible because attachment limit was 2MB and the .osm is 2,7MB large :-/

comment:3 in reply to:  2 ; Changed 9 years ago by rickmastfan67

Replying to neopolis:

Sorry it's impossible because attachment limit was 2MB and the .osm is 2,7MB large :-/

Compress the file with 7-Zip and then upload it. You should be able to get it within the 2MB limit then. ;)

Changed 9 years ago by neopolis

Attachment: melchingen.zip added

comment:4 in reply to:  3 Changed 9 years ago by anonymous

Replying to rickmastfan67:

Compress the file with 7-Zip and then upload it. You should be able to get it within the 2MB limit then. ;)

Your right :-) Sorry I'm not myself today...

comment:5 Changed 9 years ago by Don-vip

Owner: changed from neopolis to team
Status: needinfonew
Version 0, edited 9 years ago by Don-vip (next)

comment:6 Changed 9 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7465.
Could you tell us how did you produce a zero-node way ? (in #7465 comments please).
Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.