Modify

Opened 7 years ago

Closed 7 years ago

#8007 closed defect (fixed)

Conflict between plugins ColumbusCVS and opendata (see also ticket 7920)

Reported by: meppen7 Owned by: OliverW
Priority: normal Milestone:
Component: Plugin columbuscsv Version: latest
Keywords: Pluginplugin, columbuscvs, opendata Cc: OliverW, Frankl2009

Description (last modified by Don-vip)

When both plugins - columbuscvs and opendata are loaded - the problem described with ticket #7920 appears. In addition a window named -Projection method - pops up, where you can select different projections. Deactivating the plugin opendata solves the problem.

Attachments (0)

Change History (16)

comment:1 Changed 7 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 7 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 7 years ago by Don-vip

This is because both plugins register the .csv file extension, and JOSM is not currently able to deal with this situation.
Two possible solutions:

  1. JOSM core asks the user which handler to use in this case
  2. Both plugins implement a more subtle file recognition (colombus plugin only accepts colombus CSV files, and opendata ignores these files)

If 2 is possible, it is better for users.

comment:4 in reply to:  3 Changed 7 years ago by Don-vip

opendata plugin will now ignore Colombus CSV files (done in [o29008]).

comment:5 Changed 7 years ago by Don-vip

Cc: OliverW added

Oliver, are you ok to implement the same safeguard mechanism in colombusCSV plugin ?

comment:6 Changed 7 years ago by OliverW

Yes, sure.

comment:7 Changed 7 years ago by Don-vip

Component: PluginPlugin columbuscsv
Owner: changed from Don-vip to OliverW
Status: assignednew

great :)

comment:8 Changed 7 years ago by OliverW

Fixed in 29179.

Version 0, edited 7 years ago by OliverW (next)

comment:9 Changed 7 years ago by OliverW

Resolution: fixed
Status: newclosed

comment:10 Changed 7 years ago by Don-vip

Thanks !

comment:11 in reply to:  8 Changed 7 years ago by skyper

Cc: Frankl2009 added

Replying to oliverw:

Fixed in [o29179].

Did not fix it and version is only manually installable as version in manifest is wrong. See comment:9:ticket:7920.

comment:12 Changed 7 years ago by skyper

Resolution: fixed
Status: closedreopened

comment:13 Changed 7 years ago by OliverW

Launched JOSM on a different computer and it updated to 29178 without problems. So I cannot reproduce your update problem, sorry.

Regarding the opendata conflict - could you provide a test file, please?

comment:14 in reply to:  13 ; Changed 7 years ago by skyper

Replying to OliverW:

Launched JOSM on a different computer and it updated to 29178 without problems. So I cannot reproduce your update problem, sorry.

Regarding the opendata conflict - could you provide a test file, please?

Sorry, I did not test it and was irritated by the version and the duplicate. Why is it 29178 and not 29179 ? What was the purpose of [o29179] ?

comment:15 in reply to:  14 ; Changed 7 years ago by stoecker

Replying to skyper:

Why is it 29178 and not 29179 ? What was the purpose of [o29179] ?

The jar version and the checkin always differ by at least 1. It is not possible to distribute the jar file with the same checkin as used for the build.

comment:16 in reply to:  15 Changed 7 years ago by skyper

Resolution: fixed
Status: reopenedclosed

Replying to stoecker:

Replying to skyper:

Why is it 29178 and not 29179 ? What was the purpose of [o29179] ?

The jar version and the checkin always differ by at least 1. It is not possible to distribute the jar file with the same checkin as used for the build.

Sorry, for the confusion. Still do not understand the version in manifest of [o29179].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.