Modify

Opened 9 years ago

Closed 9 years ago

#7200 closed defect (fixed)

Empty Plugin-Icon in manifest line

Reported by: stoecker Owned by: skyper
Priority: normal Milestone:
Component: Plugin curves Version:
Keywords: Cc: skyper

Description

The manifest line of this plugin contains an empty Plugin-Icon line. This is wrong and produces error messages when trying to load the icon. Please removeit.

Attachments (0)

Change History (17)

comment:1 Changed 9 years ago by stoecker

Ticket #7224 has been marked as a duplicate of this ticket.

comment:2 Changed 9 years ago by stoecker

Is this plugin still maintained? Any reason why it is not in SVN?

comment:3 in reply to:  2 Changed 9 years ago by skyper

Replying to stoecker:

Is this plugin still maintained? Any reason why it is not in SVN?

I have written another email,
and found: https://wiki.openstreetmap.org/wiki/Talk:JOSM/Plugins/Curves

comment:4 Changed 9 years ago by olejorgenb

Hi, sorry for late response time.

I've recently started working and suddenly spare time has been hard to find :)

I'll try to get to the manifest this afternoon, but other progress on the plugin is likely to slow. :(

If you want to move it to svn I'm ok with that, but since it's currently kinda dying and doesn't contain alot functionality it might not be worth it

comment:5 Changed 9 years ago by akks

If you want, your Arc action can be included to Utilsplugin2, so people can notice it and help you maintain it.

Last edited 9 years ago by akks (previous) (diff)

comment:6 in reply to:  4 Changed 9 years ago by bastiK

Replying to olejorgenb:

Hi, sorry for late response time.

I've recently started working and suddenly spare time has been hard to find :)

I'll try to get to the manifest this afternoon, but other progress on the plugin is likely to slow. :(

If you want to move it to svn I'm ok with that, but since it's currently kinda dying and doesn't contain alot functionality it might not be worth it

Are you OK to release it under GPL 2+?

comment:7 Changed 9 years ago by olejorgenb

Yeah, including it in utils2 is probably better. I'm ok with GPL 2+. I'll try making a patch this weekend.

comment:8 Changed 9 years ago by akks

Integration is simple, so I have done it to save your time - see [o27818]

Your should check it, add some additional remarks to code maybe.

I did not commit the binary, so you still can rework code completely.

It would be good to add some message boxes to help user. Patches are always welcome!

Version 1, edited 9 years ago by akks (previous) (next) (diff)

comment:9 Changed 9 years ago by stoecker

Core should be updated to see curves plugin as obsolete, as soon as this is released.

comment:10 in reply to:  9 ; Changed 9 years ago by akks

Replying to stoecker:

Core should be updated to see curves plugin as obsolete, as soon as this is released.

Please can you update the core before releasing tested version? I do not know how to do it correctly and what to do in SVN.

comment:11 in reply to:  10 Changed 9 years ago by simon04

Replying to akks:

Please can you update the core before releasing tested version?

Just see PluginHandler lines 80–110.

comment:12 Changed 9 years ago by akks

In [4877/josm]:

see #7200 - mark Curves plugin as obsolete (Arc moved to Utilsplugin2)

comment:13 Changed 9 years ago by akks

I have marked Curves plugin as obsolete (since it is in Utilsplugin2, untouched), but I do not know how to remove icon error.

comment:14 Changed 9 years ago by stoecker

but I do not know how to remove icon error.

Simply: I removed Curves plugin from plugin list.

One thing remaining: Again, docs should be copied from http://wiki.openstreetmap.org/wiki/JOSM/Plugins/Curves to Help/Action/CreateCircleArc.

comment:15 Changed 9 years ago by skyper

Cc: skyper added

comment:16 Changed 9 years ago by skyper

Owner: changed from olejorgenb to skyper

comment:17 in reply to:  14 Changed 9 years ago by skyper

Resolution: fixed
Status: newclosed

Replying to stoecker:

but I do not know how to remove icon error.

Simply: I removed Curves plugin from plugin list.

One thing remaining: Again, docs should be copied from http://wiki.openstreetmap.org/wiki/JOSM/Plugins/Curves to Help/Action/CreateCircleArc.

Done !

@stoecker:
Please have a look at the attachments at Help/Action/CreateCircleArc. There was a server time out and the 3. screenshot did not upload. Finally it did but a ".4" was added to the filename. I deleted the attachment and did upload again but without a different result.

Last edited 9 years ago by skyper (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain skyper.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.