Modify

Opened 11 years ago

Closed 10 years ago

#5727 closed defect (needinfo)

Stripes in wireframe view

Reported by: Fabi2 Owned by: Fabi2
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I'am using JOSM 3709 with openjdk on Linux x86_64.

  1. Install the imagery plugin, select sharpen=soft and correct set the maximum possible zoom level.
  2. Download some data in a bing covered area.
  3. Activate the bing layer.
  4. Swith to wireframe view.
  5. Zoom in a little bit more over the real imagery resolution to get some stripes on the bing imagery.

Attachments (1)

josm-wireframe-stripes.png (1.2 MB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by anonymous

Attachment: josm-wireframe-stripes.png added

comment:1 Changed 11 years ago by Fabi2

Component: Core imageryCore
Owner: changed from Upliner to team
Summary: Bing with stripes in wireframe view with sharpen=soft using the imagery pluginStripes in wireframe view

After som further checking, this bug is not the imagery plugin, but seems to bee the old openjdk display bug (see #3313), which in wireframe mode is still there. I thought it was already reported to the openjdk developers. When I switch back to normal view, everything is fine. If I switch again to wireframe, after some zooming, the stripes apeer again.

$ java -version
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.3) (ArchLinux-6.b20_1.9.3-1-x86_64)
OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)

comment:2 in reply to:  1 ; Changed 11 years ago by bastiK

Replying to Fabi2:

After som further checking, this bug is not the imagery plugin, but seems to bee the old openjdk display bug (see #3313), which in wireframe mode is still there.
I thought it was already reported to the openjdk developers.

This doesn't work that fast...

When I switch back to normal view, everything is fine. If I switch again to wireframe, after some zooming, the stripes apeer again.

Looking at the colour of the stripes, they come from relation rendering. It seem we have overlooked this part.

comment:3 in reply to:  2 Changed 11 years ago by Fabi2

Replying to bastiK:

Replying to Fabi2:

When I switch back to normal view, everything is fine. If I switch again to wireframe, after some zooming, the stripes apeer again.

Looking at the colour of the stripes, they come from relation rendering. It seem we have overlooked this part.

If it depends also on the colour, then this bug maybe in the gps trace display code too. Sometimes when zooming in, the whole map screen also turns to violett, when using gps traces in pedastrian-mode.

comment:4 Changed 10 years ago by skyper

Owner: changed from team to Fabi2
Status: newneedinfo

Is this still an issue ?

Version 0, edited 10 years ago by skyper (next)

comment:5 Changed 10 years ago by stoecker

Resolution: needinfo
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Fabi2.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.