Modify

Opened 3 months ago

Closed 4 weeks ago

#20432 closed enhancement (fixed)

Additional panel context menu item: Download complete relation

Reported by: skyper Owned by: GerdP
Priority: normal Milestone: 21.03
Component: Core Version:
Keywords: template_report download full relation Cc: Klumbumbus

Description

What steps will reproduce the problem?

  1. Have a relation without any members downloaded
  2. Try to quickly download all members

What is the expected result?

An panel context menu item as shortcut to download the relation with its members

What happens instead?

No context menu item and no shortcut.

Please provide any additional information below. Attach a screenshot if possible.

This evolved in #20416. For a reason that this is no replacement for "download members" but an addition option, see #20091.

With a slow internet connection or with high traffic on the OSM server this would save quite some resources.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2021-01-25 07:58:30 +0100 (Mon, 25 Jan 2021)
Revision:17476
Build-Date:2021-01-26 02:30:53
URL:https://josm.openstreetmap.de/svn/trunk

Last errors/warnings:
- 03355.024 W: java.net.SocketTimeoutException: connect timed out
- 03355.027 W: java.net.SocketTimeoutException: connect timed out
- 08549.966 W: java.net.SocketTimeoutException: Read timed out
- 08549.967 E: java.net.SocketTimeoutException: Read timed out
- 08549.968 E: java.util.concurrent.ExecutionException: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- 08550.005 E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- 08550.015 E: IO Exception - <html>Failed to upload data to or download data from<br>'https://api.openstreetmap.org/api/0.6/nodes?nodes=1241347839,1038660331,38364492,38364482,3065545130,2109323947,38364509,266563828,2774907517,38364498,38364503,1268544642,652431811,38364520,3065545115,3065545116,2109323932,291599942,3065545104,3065545105,1241347796,3065545106,38364515,7966862832,3065545096,277847998,38364536,277847997,38364539,3065545099,3065545100,2926565722,1240276698,3065545089,1242129715,38364531,3065545091,3065545094,3065545095,1591105940,564152038,564152041,38364419,564152044,1268544721,38364423,564152049,38364443,564152052,2109303534,38364435,291593786,564152060,564152062,38364457,1240350351,1241403037,2109323997,6451388396,38364460,38364449,2727458303,2727458302,291601936,38364475,2109323983,564152024,38364466,564152028,38364471,366521255,4153272591,1240350316,4153272590,38364365,2477583400,1303894579,2477583396,564150057,2477583397,266563690,2477583398,266563689,2577807149,2477583399,1268243484,2577807146,38364357,2577807147,2577807145,1268243736,2277280045,2109295144,2277280046,2277280047,38364381,652431479,1239549558,294022931,4821102792,4088712225,2277280042,2485699262,38364639,2485699263,652431476,2277280037,38364368,2109303586,1241402981,564150076,4153272592,1303894570,652431485,2109295143,38364374,2109295129,1193523586,564152065,2096997212,564149762,2277280031,2477583375,1239549505,2109295133,564149766,564152071,2477583371,38364385,2109295120,4088712221,564149769,1303894558,564152075,564152076,38364390,323296759,2479568254,38364415,5734456187,38364401,2440503245,2109324037,38364406,2926565551,2926565549,2926565548,38364302,1038660388,1240276771,2786126017,1268544842,38364319,52690430,264755482,38364308,726640046,38364328,2727124072,2318474453,2479568175,4882935279,38364335,38364322,38364346,726640059,52690388,38364350,1390558235,1390558238'<br>due to a problem with transferring data.<br>Details (untranslated): Read timed out</html>
- 09571.535 W: java.net.SocketTimeoutException: Read timed out
- 09571.535 E: java.net.SocketTimeoutException: Read timed out
- 09571.536 E: java.util.concurrent.ExecutionException: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out

Attachments (1)

20432-alpha.patch (2.9 KB) - added by GerdP 3 months ago.
work in progress

Download all attachments as: .zip

Change History (18)

Changed 3 months ago by GerdP

Attachment: 20432-alpha.patch added

work in progress

comment:1 Changed 3 months ago by GerdP

Cc: Klumbumbus added
Milestone: 21.02
Owner: changed from team to GerdP
Status: newassigned

I don't like the wording "complete relation", unless you really want the action to recurse down all child relations (this is known to cause trouble with some boundary relations)
In #20416 you suggested "Download with members", I think that's better.
My understanding is that "Download with members" should do what "Download members" did before r17341 -> Quite confusing!
I wonder if we really need three different actions to download members?
TODO:

  • new icon
  • new help texts

comment:2 Changed 3 months ago by skyper

Ok, "Download with members" is closer as I only want to download the direct members and no parent relations nor child relations.

Maybe, "Download members" should have been renamed to "Download with members" before r17341. Now, "Download members" and "Download incomplete members" would be only expert actions as they are only important for revert/undelete or after duplicating an incomplete relation if "Download with members" is available.

Right now, it is cumbersome to download some incomplete relations with all members at once as I have to manually copy each object id by its own to "Download object".As the "Object Info" and the "Download object" dialog both block, I need to use a text editor to prepare my string.

comment:3 Changed 3 months ago by GerdP

You can select the relations, press Ctrl+C (Copy) and then Shift+Crtl+C to download objects. That fills the dialog with the selected objects.

comment:4 in reply to:  3 Changed 3 months ago by skyper

Replying to GerdP:

You can select the relations, press Ctrl+C (Copy) and then Shift+Crtl+C to download objects. That fills the dialog with the selected objects.

Ctrl+Shift+O for download objects, thanks, that works for me and I do not need the additional button.

Version 0, edited 3 months ago by skyper (next)

comment:5 Changed 3 months ago by skyper

Resolution: worksforme
Status: assignedclosed

comment:6 Changed 3 months ago by skyper

Damn, sorry, Gerd. If you still want to work on it, please, reopen.

comment:7 Changed 3 months ago by Klumbumbus

Milestone: 21.02

comment:8 Changed 3 months ago by GerdP

@Klumbumbus: Do you have an idea reg. the icon? I think this method is the best for most users and for sure reduces workload on the OSM server.

comment:9 Changed 3 months ago by Klumbumbus

(I removed the milestone as there was no commit and the ticket closed.)

Regarding icon, I don't yet understand what the new feature would be (or the difference to the existing "Download members"), but you could implement it first without icon and then I can think about an icon.

comment:10 Changed 2 months ago by GerdP

Resolution: worksforme
Status: closedreopened

comment:11 Changed 2 months ago by GerdP

In 17485/josm:

see #20432: Additional panel context menu item: Download complete relation

  • unlile "download members" this will download the relation using the API call with /full This is typically much faster, while "download members" really downloads (only) the current members with possibly many multiget calls

Difference to "download members": The data for the relation is also updated, esp. also the member list

TODO: Create new icon for either of the actions.

comment:12 Changed 2 months ago by GerdP

Milestone: 21.02

comment:13 Changed 2 months ago by stoecker

Milestone: 21.0221.03

Milestone renamed

comment:14 Changed 2 months ago by skyper

Thanks for this shortcut, I use it, quite, often.

comment:15 Changed 5 weeks ago by GerdP

Should I close this ticket? The new icon isn't of big importance and we already had different actions using the same icon.

comment:16 Changed 4 weeks ago by skyper

I'd close this ticket and open a new enhancement ticket for the icon.

comment:17 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.