Modify

Opened 3 months ago

Closed 3 weeks ago

Last modified 5 days ago

#20148 closed defect (duplicate)

MacOS release

Reported by: stoecker Owned by: Stereo
Priority: normal Milestone: 21.02
Component: Installer MacOS Version:
Keywords: macos Cc: Don-vip

Description

Could we please finally get that release stuff for MacOS done instead changing each Wiki page in josm wiki to point to an undefined external service.

I reverted these changes.

"/download/macosx/josm-macosx.zip" is still the current and this URL will stay valid.

As already said before the linking to the external resource will be done via the JOSM server. But I'm still waiting for the information what and how the external link should look like.

As far as I remember our discussions the package should be built in the JOSM GitHub project. The link was not in the JOSM GitHub repository.

I added a redirect for the URL now, but this is only a workaround. I need a solution which does not require manual work to get at done and also one pointing to the correct repository.

Attachments (0)

Change History (14)

comment:1 Changed 3 months ago by stoecker

P.S. Please next time ASK before doing such a change!

comment:2 Changed 3 months ago by Don-vip

Component: CoreInstaller MacOS
Milestone: 20.12

comment:3 Changed 3 months ago by Don-vip

I missed #20146. Will take a look tomorrow to see if we can trigger GitHub API from JOSM server, so that we can drive GitHub from a change to TestedVersion like all the other release stuff.

comment:4 Changed 3 months ago by Stereo

Damn it, sorry about that. The release took me by surprise, and didn't do the things I thought it would do, so I had to quickly fix the build process on my github fork.

I tried to reach Don-vip but he was busy, so I wanted to fix things, and updated the wiki, (and removed a few outdated Mac error sections in the process.)

Ideally, /download/macosx/josm-macosx.zip would be a redirect that would, for this month, point to https://github.com/grischard/josm/releases/download/17329-tested/JOSM-macOS-java15.zip. That way, we won't need to update the wiki when we have release builds in the josm repo or, for example, we switch to java 17 for macOS builds one day.

Version 1, edited 3 months ago by Stereo (previous) (next) (diff)

comment:5 Changed 3 months ago by Stereo

Keywords: macos added

comment:6 in reply to:  4 Changed 3 months ago by stoecker

Replying to Stereo:

Ideally, /download/macosx/josm-macosx.zip would be a redirect that would, for this month, point to https://github.com/grischard/josm/releases/download/17329-tested/JOSM-macOS-java15.zip.

That's what it is now, but that's a workaround, no solution.

comment:7 Changed 3 months ago by simon04

$ curl --head https://josm.openstreetmap.de/download/macosx/josm-macosx.zip
HTTP/1.1 301 Moved Permanently
Date: Wed, 25 Nov 2020 19:58:05 GMT
Server: Apache/2.4.29 (Ubuntu)
X-Clacks-Overhead: GNU Terry Pratchett
Strict-Transport-Security: max-age=16070400; includeSubDomains
Location: https://github.com/grischard/josm/releases/download/17329-tested/JOSM-macOS-java15.zip
Content-Type: text/html; charset=iso-8859-1

Maybe the HTTP status code should be 302 (or 307)?

comment:8 Changed 3 months ago by Stereo

Definitely 302, not 301.

comment:9 in reply to:  8 Changed 3 months ago by stoecker

Replying to Stereo:

Definitely 302, not 301.

Done.

comment:10 Changed 2 months ago by stoecker

Milestone: 20.1221.01

comment:11 Changed 4 weeks ago by Don-vip

Milestone: 21.0121.02

comment:12 Changed 3 weeks ago by Stereo

Resolution: duplicate
Status: assignedclosed

Closed as duplicate of #20046.

comment:13 Changed 2 weeks ago by stoecker

Milestone: 21.0221.03

Milestone renamed

comment:14 Changed 5 days ago by Don-vip

Milestone: 21.0321.02

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Stereo.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.