Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#19975 closed defect (invalid)

Error could not read file Data Layer 1_20201020_120535525. Line1 column 1: content is not allowed in prolog.

Reported by: sharcrash Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by sharcrash)

Not a bug, I need help on restoring a session with many edits that got lost when computer crashed. I get the error:
Could not read file Data Layer 1_20201020_120535525. Line1 column 1: content is not allowed in prolog.

I tried to open the osm file but it seems having only zeros. There is also a .pid file with the same file-name.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 808 MB / 1820 MB (493 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1280x1024 (scaling 1.0x1.0), \Display1 1280x1024 (scaling 1.0x1.0)
Maximum Screen Size: 1280x1024
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Plugins:
+ ImageWayPoint (35248)
+ SimplifyArea (35405)
+ alignways (35474)
+ apache-commons (35524)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ buildings_tools (35563)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geochat (35405)
+ imagery_offset_db (35405)
+ log4j (35092)
+ photo_geotagging (35499)
+ photoadjust (35405)
+ reltoolbox (35529)
+ reverter (35556)
+ turnrestrictions (35515)
+ undelete (35521)
+ utilsplugin2 (35487)
+ wikipedia (1.1.4)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
+ https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- 00037,180 W: Region [TMS_BLOCK_v2] : Problem verifying disk.
- 00054,400 E: org.openstreetmap.josm.io.IllegalDataException: Line 1 column 1: Content is not allowed in prolog.. Cause: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,1]
- 00054,476 E: Error - <html>Could not read file 'Data Layer 1_20201020_120535525.osm'.<br>Error is:<br>Line 1 column 1: Content is not allowed in prolog.</html>

Attachments (2)

Data Layer 1_20201020_120535525.osm (7.2 MB) - added by sharcrash 4 months ago.
Data Layer 1_20201020_120535525.pid (17 bytes) - added by sharcrash 4 months ago.

Change History (6)

Changed 4 months ago by sharcrash

Changed 4 months ago by sharcrash

comment:1 Changed 4 months ago by sharcrash

Description: modified (diff)

comment:2 Changed 4 months ago by skyper

Can reproduce.

This file will not help much, as it is completely corrupt. Do not know what happened, but I fear you have to dig deeper. Maybe, looking for deleted/modified files on the file system level using journal information might help.

Working on a large scale, it is always useful, to upload or, at least, save your work from time to time. Once a layer is saved, there are more option.

comment:3 Changed 4 months ago by Don-vip

Resolution: invalid
Status: newclosed

The file is completely corrupted, nothing we can do, sorry. My only advice would be to check that you run latest security patches, check your hardware, etc. to avoid future crashes of your computer.

comment:4 Changed 4 months ago by sharcrash

Thanks all! It got it back, solved it yesterday! :)

I realise i should save after smaller chunks of edits but i got carried away since there was a lot to correct on the area.

Thanks!

Version 0, edited 4 months ago by sharcrash (next)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.