Modify

Opened 13 months ago

Closed 13 months ago

Last modified 12 months ago

#19000 closed defect (fixed)

reverter doesn't revert

Reported by: Klumbumbus Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. try to revert https://overpass-api.de/achavi/?changeset=82779396

What is the expected result?

2 nodes move north east

What happens instead?

nothing

Please provide any additional information below. Attach a screenshot if possible.

console:

2020-03-29 15:41:59.248 INFORMATION: Reverting 1 changeset(s): [82779396]
2020-03-29 15:41:59.249 INFORMATION: Reverting changeset 82779396
2020-03-29 15:41:59.253 INFORMATION: GET https://api.openstreetmap.org/api/0.6/changeset/82779396 -> HTTP/1.1 200 (4 ms; 641 B)
2020-03-29 15:41:59.256 INFORMATION: GET https://api.openstreetmap.org/api/0.6/changeset/82779396/download -> HTTP/1.1 200 (1 ms; 1,27 kB)
2020-03-29 15:41:59.264 INFORMATION: GET https://api.openstreetmap.org/api/0.6/nodes?nodes=6183253379v4,1697804637v6 -> HTTP/1.1 200 (5 ms; 1,19 kB)
2020-03-29 15:41:59.266 WARNUNG: No revert commands found for changeset 82779396
2020-03-29 15:41:59.266 INFORMATION: Reverted changeset 82779396
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-27 15:39:19 +0100 (Fri, 27 Mar 2020)
Build-Date:2020-03-28 02:30:56
Revision:16205
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16205 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1909 (18363)
Memory Usage: 1286 MB / 1820 MB (497 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files (x86)\josm-latest.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=58140, -Djnlpx.jvm=<java.home>\bin\javaw.exe]
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (35248)
+ HouseNumberTaggingTool (35248)
+ Mapillary (1.5.20)
+ OpeningHoursEditor (35250)
+ PicLayer (35313)
+ RoadSigns (35313)
+ SimplifyArea (35313)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35364)
+ editgpx (35248)
+ ejml (35122)
+ imagery-xml-bounds (35313)
+ imagery_offset_db (35248)
+ jaxb (35092)
+ jna (35092)
+ jogl (1.2.3)
+ log4j (35092)
+ measurement (35369)
+ osm-obj-info (56)
+ photo_geotagging (35313)
+ photoadjust (35313)
+ reltoolbox (35313)
+ reverter (35400)
+ rex (53)
+ tageditor (35258)
+ tagging-preset-tester (35267)
+ terracer (35327)
+ turnlanes-tagging (283)
+ turnrestrictions (35313)
+ undelete (35396)
+ utilsplugin2 (35384)
+ wikipedia (1.1.3)
+ wms-turbo-challenge2 (35248)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/StolpersteineLight&zip=1
+ %UserProfile%\Documents\OSM\TestNew\newpresets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ %UserProfile%\Documents\OSM\josm\core\resources\data\defaultpresets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Allergy&zip=1

Map paint styles:
+ %UserProfile%\Documents\OSM\josm\core\resources\styles\standard\elemstyles.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
- %UserProfile%\Documents\OSM\TestNew\newicons.mapcss
- %UserProfile%\Downloads\Road_Extended_JOSM_style.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/sac_scale&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ShowID&zip=1
- %UserProfile%\Documents\OSM\eigene styles\PriorityRoad\PriorityRoad_1.0.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&style&zip=1
- https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- %UserProfile%\Documents\OSM\eigene styles\Tourenplanung.mapcss
- %UserProfile%\Documents\OSM\eigene styles\SpecificBuildingValues\SpecificBuildingValues.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Incline&zip=1
- %UserProfile%\Documents\OSM\eigene styles\area-symbol.zip
- http://www.freietonne.de/ft_icons/josm/FreieTonne_rules_presets_zip.php
- http://www.openrailwaymap.org/styles/standard.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/DestinationSignRelation&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/hazmat&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Postcode&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/RecyclingMaterials&zip=1
- %UserProfile%\Documents\OSM\eigene styles\maxspeed\maxspeed_2.9_01 basierend auf 2.7_02 Zahlen.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Bench&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ColourTag&zip=1
- %UserProfile%\Downloads\coloured_kerbs_style.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Admin_Boundaries&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- %UserProfile%\Documents\OSM\eigene styles\yes-no-unset\YesNoUnset_1.0.mapcss
- <josm.pref>\styles\sit.mapcss
- <josm.pref>\styles\sit.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/IconTester&zip=1

Validator rules:
+ https://raw.githubusercontent.com/<user.name>n-a-bauer/josm-validators/master/mtb.validator.mapcss
+ %UserProfile%\Documents\OSM\TestNew\new.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1
+ %UserProfile%\Documents\OSM\TestNew\newttt.validator.mapcss

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'https://code-de.org/sites/all/themes/cde/favicon.ico'
- E: Fehler beim Laden des Bildes 'https://code-de.org/sites/all/themes/cde/favicon.ico'
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: Unable to use English input method
- W: No revert commands found for changeset 82766012
- W: No revert commands found for changeset 82779396
- E: Fehler beim Laden des Bildes 'https://code-de.org/sites/all/themes/cde/favicon.ico'
- E: Fehler beim Laden des Bildes 'https://code-de.org/sites/all/themes/cde/favicon.ico'

Attachments (0)

Change History (23)

comment:1 Changed 13 months ago by GerdP

Seems you already changed the data, so I cannot reproduce the problem.

comment:2 Changed 13 months ago by GerdP

No, forget that. I can reproduce.

comment:3 Changed 13 months ago by GerdP

Resolution: fixed
Status: newclosed

comment:4 Changed 13 months ago by GerdP

Ouch, that was a really stupid error. I did not notice that classes Node, Way, and Relation overwrite OsmPrimitive.hasEqualSemanticAttributes() :(

comment:5 Changed 13 months ago by Klumbumbus

I think there went something wrong with the jar file. I download the new version 35402 and restart JOSM but then it says the local version is still 35400 and it loads the new version again (and the bug is also not fixed in that new downloaded version). I tried several times including deleting the jar file manually.
There is the same problem with the undelete plugin.

comment:6 Changed 13 months ago by GerdP

Did you update the plugin list?

comment:7 Changed 13 months ago by Klumbumbus

Yes.

comment:8 Changed 13 months ago by GerdP

I just tried and my JOSM shows that reverter version is 35402.

comment:9 Changed 13 months ago by GerdP

Without manual update of the list it did not update to 35402 and kept 35400.

comment:10 Changed 13 months ago by Klumbumbus

I don't know why, but JOSM always downloads 35400 (while it sais that it is 35402). So no way to update the plugin with JOSM tools. Now I replaced the jar file in my pref folder with the one from my svn. That worked.

comment:11 Changed 13 months ago by GerdP

What method do you use to find out what the version of the jar is?

comment:12 Changed 13 months ago by Klumbumbus

File size. The old had 72 KB the new 71 KB. (I know thats not a safe evidence.)

comment:13 Changed 13 months ago by Klumbumbus

...and after restart JOSM says again that it is version 35400 and also the reverter didn't revert.

comment:14 Changed 13 months ago by GerdP

The jar is a zip archive. You can open it and look at the content of file META-INF\MANIFEST.MF
Jar file size should be 72.205 bytes. On my machine it downloads the file which is stored in josm/dist svn repo

comment:15 Changed 13 months ago by GerdP

1) Update the plugin list
2) Update the plugins
3) Restart JOSM

comment:16 in reply to:  15 Changed 13 months ago by Klumbumbus

Replying to GerdP:

1) Update the plugin list
2) Update the plugins
3) Restart JOSM

Yes, thats the normal workflow, but thats an infinite loop for me. I can't reproduce with the reverter plugin anymore as I fixed it manually. However with the undelete plugin the behavior is the same: After the plugin update and before the restart there are two files in C:\Users\stefa\AppData\Roaming\JOSM\plugins undelete.jar and undelete.jar.new
Both jars include the same (old) manifest file:

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.9.7
Created-By: 1.8.0_201-b09 (Oracle Corporation)
Plugin-Mainversion: 14763
Plugin-Version: 35396
Plugin-Class: org.openstreetmap.josm.plugins.undelete.Undelete
Plugin-Description: Allows undeleting object from OSM database
Plugin-Date: 2020-03-26T07:24:51.828567Z
Author: Nakor
Plugin-Link: https://wiki.openstreetmap.org/wiki/JOSM/Plugins/Undelete
Plugin-Icon: images/undelete.png


comment:17 Changed 13 months ago by GerdP

Strange. What do you get with a clean JOSM directory?

comment:18 Changed 13 months ago by GerdP

My laptop downloads a file site-josm.openstreetmap.de-_pluginicons.txt which contains the version 35402 for reverter and it also downloads this version.

comment:19 Changed 13 months ago by Klumbumbus

It is indeed very strange. First JOSM correctly downloads the new file:

2020-03-29 21:08:26.477 INFORMATION: GET https://josm.openstreetmap.de/pluginicons?plugins=DirectUpload,HouseNumberTaggingTool,Mapillary,OpeningHoursEditor,PicLayer,RoadSigns,SimplifyArea,apache-commons,apache-http,buildings_tools,editgpx,ejml,imagery-xml-bounds,imagery_offset_db,jaxb,jna,jogl,log4j,measurement,osm-obj-info,photo_geotagging,photoadjust,reltoolbox,reverter,rex,tageditor,tagging-preset-tester,terracer,turnlanes-tagging,turnrestrictions,undelete,utilsplugin2,wikipedia,wms-turbo-challenge2 -> HTTP/1.1 200 (76 ms)
2020-03-29 21:08:27.482 INFORMATION: Erweiterung undelete wird heruntergeladen...
2020-03-29 21:08:27.485 INFORMATION: GET https://svn.openstreetmap.org/applications/editors/josm/dist/undelete.jar -> HTTP/1.1 200 (2 ms; 34,5 kB)
2020-03-29 21:08:27.531 INFORMATION: Erweiterungen aktualisieren - <html>Die folgende Erweiterung wurde <strong>erfolgreich</strong> heruntergeladen:<ul><li>undelete (35398)</li></ul>Bitte starten Sie JOSM neu, um die heruntergeladenen Erweiterungen zu aktivieren.</html>

But directly after this the undelete.jar.new file is the same like the old undelete.jar. I think somehow JOSM manages to override the new file with the old one.
I'll try with a clean profile tomorrow.

comment:20 Changed 13 months ago by GerdP

Maybe a reboot helps. The idea: A zombie thread of JOSM still keeps the old files open/locked.

comment:21 in reply to:  20 Changed 13 months ago by Klumbumbus

Replying to GerdP:

Maybe a reboot helps.

No, I aldready tried that before :)

Version 0, edited 13 months ago by Klumbumbus (next)

comment:22 Changed 13 months ago by skyper

Had similar problems, see #19006.

comment:23 Changed 12 months ago by Klumbumbus

It seems plugin update is back to normal for me.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.