Modify

Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#17482 closed enhancement (fixed)

remove building:ruian:type tag where it duplicates building tag

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 19.04
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. create object with building=garage and building:ruian:type=18
  2. run validator

What is the expected result?

Validator offers to remove useless and cryptic duplicate of building tag

What happens instead?

Presets do not contain property key - Key 'building:ruian:type' not in presets. (1)

Please provide any additional information below. Attach a screenshot if possible.

See https://wiki.openstreetmap.org/wiki/Key:building:ruian:type?uselang=en documenting widespread duplication of nearly all building:ruian:type tags.

http://overpass-turbo.eu/s/H7I alone has more matches than displayable in a browser

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-03-10 20:57:11 +0100 (Sun, 10 Mar 2019)
Build-Date:2019-03-11 02:30:51
Revision:14877
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14877 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 479 MB / 869 MB (117 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34867)
+ buildings_tools (34904)
+ continuosDownload (82)
+ imagery_offset_db (34867)
+ measurement (34867)
+ reverter (34867)
+ todo (30306)

Validator rules:
+ ${HOME}/Desktop/tmp/unnecessary.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (0)

Change History (30)

comment:1 Changed 8 months ago by mkoniecz

Description: modified (diff)

comment:2 Changed 8 months ago by Don-vip

Milestone: 19.03

Some values add more information than the osm building tag and should not be removed automatically. But for following values there is no added value, so the tag can be removed without any loss of information:

/* #17482 */
*[building:ruian:type=2][building=farm_auxiliary],
*[building:ruian:type=7][building=house],
*[building:ruian:type=11][building=hotel],
*[building:ruian:type=12][building=warehouse],
*[building:ruian:type=13][building=barn],
*[building:ruian:type=18][building=garage],
*[building:ruian:type=21][building=greenhouse] {
  throwWarning: tr("{0} is unnecessary for {1}", "{0.tag}", "{1.tag}");
  group: tr("unnecessary tag");
  fixRemove: "{0.key}";
}

comment:3 Changed 8 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14901/josm:

fix #17482 - suggest to remove building:ruian:type when there is no added value

comment:4 Changed 8 months ago by mkoniecz

What about:

1 ( průmyslový objekt industrial object building=industrial)
10 (stavba pro obchod commercial building building=commercial)
17 ( stavba pro dopravu building for transportation building=transportation)
26 ( jez weir waterway=weir)

I think this codes also add no useful information over standard OSM tag if it is present.

Version 0, edited 8 months ago by mkoniecz (next)

comment:5 Changed 8 months ago by mkoniecz

What would be preferred to get feedback on what I posted in the previous comment? Reopen this issue? Open new one?

comment:6 Changed 8 months ago by Don-vip

New one. This issue is fixed.

EDIT: no, sorry, read too fast.

Last edited 8 months ago by Don-vip (previous) (diff)

comment:7 Changed 8 months ago by Don-vip

I didn't add these values on purpose because if we remove the ruian:type we cannot retrieve the original value from the OSM tag, as there are several possibilities (for example we cannot distinguish 1 from 16, 10 from 14 and so on).

comment:8 Changed 8 months ago by mkoniecz

"we cannot retrieve the original value from the OSM tag" - is there any reason at all to care about original value in the external database? Also, if one really cares about original value it is possible to process history.

In addition it anyway impossible to distinguish with current replacements building=garage that in past had building:ruian:type tag and one that never had it.

Last edited 8 months ago by mkoniecz (previous) (diff)

comment:9 Changed 8 months ago by Mkyral

Resolution: fixed
Status: closedreopened

Hi,
this tag is a part of RUIAN manual import that is done via Tracer-Testing plugin. https://wiki.openstreetmap.org/wiki/Cs:R%C3%9AIAN#Stavebn.C3.AD_objekty_.28SO.29

Please do not remove it. Just put it to ignore list instead.
If you want discuss it more, please contact us on @talk-cz.

Thanks,
Marián

(Tracer-Testing plugin maintainer and member of Czech community)

comment:10 Changed 8 months ago by mkoniecz

this tag is a part of RUIAN manual import

Is there any reason why the same information is presented both as standard OSM building tag and again with building:ruian:type? What kind of information is added by having both building:ruian:type=18 and building=garage?

please contact us on @talk-cz

Is it OK to use English there?

comment:11 Changed 8 months ago by mkoniecz

Just put it to ignore list instead.

Note that key on "ignore list" (discardable tags) are not only not displayed but also silently removed. So it is not something that you want.

Last edited 8 months ago by mkoniecz (previous) (diff)

comment:12 in reply to:  10 Changed 8 months ago by Mkyral

Replying to mkoniecz:

this tag is a part of RUIAN manual import

Is there any reason why the same information is presented both as standard OSM building tag and again with building:ruian:type? What kind of information is added by having both building:ruian:type=18 and building=garage?

1) Consistency - all buildings added from RUIAN have this tag.
2) Mapping is not always 1:1 - Some general tags, like "civic" can be changed by mapper to more specific like school, church, station...
3) This tag can be used to check changes made by users and review them or do an analyze of data.
4) If some mapping change in future (a new mappig will be agreed), it can be used to identify objects that needs to be changed.

please contact us on @talk-cz

Is it OK to use English there?

Yes.

BTW: why are you interested in this tag?

comment:13 in reply to:  11 Changed 8 months ago by Mkyral

Replying to mkoniecz:

Just put it to ignore list instead.

Note that key on "ignore list" (discardable tags) are not only not displayed but also silently removed. So it is not something that you want.

OK. So just ignore it in JOSM at all ;-)

comment:14 Changed 8 months ago by mkoniecz

Consistency - all buildings added from RUIAN have this tag.

For tagging source we have tags in changesets, or source tag on objects if someone really wants it

Some general tags, like "civic" can be changed by mapper to more specific like school, church, station...

Note that only 100% duplicates are suggested for removal by JOSM - see https://josm.openstreetmap.de/ticket/17482#comment:2

This tag can be used to check changes made by users and review them or do an analyze of data.

Why not use ref:ruian:building for comparing ruian and OSM databases?

If some mapping change in future (a new mappig will be agreed), it can be used to identify objects that needs to be changed.

Again, only obvious duplicates are removed, not less specific ones.

BTW: why are you interested in this tag?

During fixing unrelated broken data I spotted this tag duplicating standard OSM tags (it is fairly common mistake made during imports). But it is not something unique - see https://josm.openstreetmap.de/query?status=closed&resolution=fixed&component=Core+validator&reporter=~mkoniecz&max=1000&col=id&col=summary&col=status&col=component&col=type&col=priority&col=milestone&col=time&report=2&order=id for my other JOSM validator proposals.

Last edited 8 months ago by mkoniecz (previous) (diff)

comment:15 Changed 8 months ago by mkoniecz

Is it OK to use English there?

Yes.

I subscribed and will post explanation once new post will be made in "[talk-cz] Varování JOSM -- kombinace building:ruian:type a building" thread (to avoid starting a separated thread).

In general:

Tags duplicating standard tags are generally pointless, especially tags added during imports. For example import of villages adding both place=village and OBJECT_CLASS:PREFIX=Populated place is undesirable, adding just place=village would be better.

https://wiki.openstreetmap.org/wiki/Key:building:ruian:type?uselang=en documents that for example building:ruian:type=18 is not providing any information over standard OSM tag building=garage

The same applies to some additional codes listed in https://josm.openstreetmap.de/ticket/17482#comment:2

Validators may be mistaken and in such cases it is good to report problems. But in this case this warning was deliberate and as far as I can see it is not reporting any false positives.

Note that for example removal of code 29 for building tagged as building=yes ("stavba odkaliště") would not be desirable and JOSM is not proposing to do that.

Last edited 8 months ago by mkoniecz (previous) (diff)

comment:16 in reply to:  14 Changed 8 months ago by Mkyral

Replying to mkoniecz:

Consistency - all buildings added from RUIAN have this tag.

For tagging source we have tags in changesets, or source tag on objects if someone really wants it

It is not about identify the ruian building itself (we are using ref:ruian:* for it), but about a fact, that all ruain building have the same minimal set of tags.

Some general tags, like "civic" can be changed by mapper to more specific like school, church, station...

Note that only 100% duplicates are suggested for removal by JOSM - see https://josm.openstreetmap.de/ticket/17482#comment:2

Having this tag only on some buildings is useless for us.

This tag can be used to check changes made by users and review them or do an analyze of data.

Why not use ref:ruian:building for comparing ruian and OSM databases?

This is a snapshot. As we are doing a semi-manual import, the value in the source database could change in meantime and comparison wil be not correct.

comment:17 Changed 8 months ago by mkoniecz

Having this tag only on some buildings is useless for us.

Why?

all ruain building have the same minimal set of tags.

Why it is more important than not adding tags that provide no additional information?

comment:18 in reply to:  17 Changed 8 months ago by Mkyral

Replying to mkoniecz:

Having this tag only on some buildings is useless for us.

Why?

Because I don't like exceptions. Have this tag only on some ruian building is a mess and complicating things. From my point of view it is either all or none. Nothing between.

all ruain building have the same minimal set of tags.

Why it is more important than not adding tags that provide no additional information?

Is there some rule, that forbids this? What looks to you as a duplicity could be something different for someone else.

comment:19 Changed 8 months ago by anonymous

Is there some rule, that forbids this?

Common sense? If somebody would tag river with waterway=river waterway:cs=řeka waterway:pl=rzeka I would remove two latter tags as useless duplicates, and for example import of villages adding both place=village and OBJECT_CLASS:PREFIX=Populated place is undesirable, adding just place=village would be better.

I see no reason to make exception for this specific tag - and note that JOSM routinely removes completely pointless tags, see https://josm.openstreetmap.de/browser/josm/trunk/data/validator/unnecessary.mapcss

Last edited 8 months ago by mkoniecz (previous) (diff)

comment:20 Changed 8 months ago by mkoniecz

Sorry I made the comment above.

comment:21 Changed 8 months ago by anonymous

This tag is useless for you. Not for me. If this tag should be removed, then completely. From plugin and database. But I'm still not sure, if I want to remove it.

comment:22 Changed 8 months ago by Mkyral

Sorry, did not noticed that I'm not logged on second computer.

comment:23 Changed 8 months ago by tom.k

Hello,

RUIAN id is not 1:1 mappable to OSM tags, so please leave it as it is. Removing just some special values creates only a big mess, making OSM data unusable for those wishing to use *:ruian: tags.

comment:24 Changed 8 months ago by anonymous

RUIAN id is not 1:1 mappable to OSM tags

Only ones mappable 1:1 are removed.

comment:25 in reply to:  19 Changed 8 months ago by anonymous

Replying to anonymní:

I see no reason to make exception for this specific tag - and note that JOSM routinely removes completely pointless tags, see https://josm.openstreetmap.de/browser/josm/trunk/data/validator/unnecessary.mapcss

Well, it might be doing so, but it isn't exactly what I would expect. This might be a solution for very old, pointless tags, but it is completely counterproductive for data quality. If somebody is putting pointless tags in recent changesets, others should be addressing the person, not fixing it silently.

Only ones mappable 1:1 are removed.

The tag are directional. You are removing only part of it.

BTW, why is automated edit by a software acceptable and automated edit by a person not?

Sorry, just removing the "anonymous".

Last edited 8 months ago by majkaz (previous) (diff)

comment:26 in reply to:  24 Changed 8 months ago by tom.k

Replying to anonymní:

RUIAN id is not 1:1 mappable to OSM tags

Only ones mappable 1:1 are removed.

And that's the main point why it is wrong. Removing just some values of a tag is a road to hell. I can randomly remove nodes from OSM as well with the same logic, just because I do not need them.

Are you trying to force CZ users not to use JOSM at all or have us to fork this project?

comment:27 Changed 7 months ago by Klumbumbus

Milestone: 19.0319.04

This validator test should be reconsidered after the mentioned discussion on talk-cz (comment:15).
IMHO if the czech community wants to use the building:ruian:type tagging schema on their buildings then josm should respect this and not raise a warning.

comment:28 Changed 7 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 14980/josm:

fix #17482 - remove building:ruian:type check

comment:29 Changed 7 months ago by Mkyral

Thanks.

comment:30 Changed 7 months ago by mkoniecz

I added note at https://wiki.openstreetmap.org/wiki/Key:building:ruian:type with link to this issue to make people aware that local community currently prefers to keep this tags.

Including "Please consult talk-cz mailing list before removing them".

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.