Modify

Opened 3 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#16145 closed defect (fixed)

Validator URL checker issues a false positive for archive.org URLs

Reported by: aseerel4c26 Owned by: aseerel4c26
Priority: minor Milestone: 18.04
Component: Core validator Version:
Keywords: template_report false_positive URL Cc:

Description

What steps will reproduce the problem?

  1. add a new object with this tag: website=https://web.archive.org/web/20180330151005/http://example.com/foo/bar
  2. try to upload

What is the expected result?

upload dialog opens

What happens instead?

validator complains about wrong URL format. Note that the URL format is fine and is automatically generated by archive.org.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-29 19:25:33 +0200 (Thu, 29 Mar 2018)
Revision:13584
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Build-Date:2018-03-30 01:34:25
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13584 de) Linux
Memory Usage: 344 MB / 2048 MB (145 MB allocated, but free)
Java version: 9.0.4+11, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on, -Dswing.aatext=true]

Plugins:
+ OpeningHoursEditor (34095)
+ buildings_tools (34109)
+ measurement (34109)
+ reverter (34109)
+ terracer (34109)
+ todo (30303)
+ turnrestrictions (34129)
+ undelete (34109)
+ utilsplugin2 (34109)

Tagging presets:
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (2)

validator.osm (272 bytes) - added by aseerel4c26 3 weeks ago.
test case
Screenshot_20180403_195523.png (23.0 KB) - added by aseerel4c26 3 weeks ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 3 weeks ago by Don-vip

Milestone: 18.04

comment:2 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13590/josm:

fix #16145 - allow several slashes in URL validator

comment:3 Changed 3 weeks ago by aseerel4c26

Resolution: fixed
Status: closedreopened

Thanks, but, now with my example steps above the validator complains about "ungültiges Protokoll: https". Whyever... E.g. website=https://www.example.com/foo/bar does not lead to complaining.

Version 0, edited 3 weeks ago by aseerel4c26 (next)

comment:4 Changed 3 weeks ago by Don-vip

I don't have any warning with the example provided. Can you please attach your .osm file?

comment:5 in reply to:  4 Changed 3 weeks ago by Klumbumbus

Owner: changed from team to aseerel4c26
Status: reopenedneedinfo

Replying to Don-vip:

I don't have any warning with the example provided.

Me neither.

comment:6 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: needinfoclosed

comment:7 Changed 3 weeks ago by aseerel4c26

Resolution: fixed
Status: closedreopened

Attached file. Tested with version 13595 with fresh config.

Changed 3 weeks ago by aseerel4c26

Attachment: validator.osm added

test case

Changed 3 weeks ago by aseerel4c26

comment:8 Changed 3 weeks ago by Klumbumbus

There is an invisible character in front of the URL in your file. By opening the edit tag window (Alt+S) and closing with OK, without changing anything yourself automatically removes the character and the warning.

Not sure if it is worth to add a Validator warning for invisible characters?

comment:9 in reply to:  8 ; Changed 3 weeks ago by aseerel4c26

Replying to Klumbumbus:

By opening the edit tag window (Alt+S) and closing with OK, without changing anything yourself automatically removes the character and the warning.

Oh, indeed, thank you (and sorry). This is likely because I added the tag by copying from https://josm.openstreetmap.de/ticket/16145#Whatstepswillreproducetheproblem and then just pasting and let JOSM automatically separate the key and value. Maybe JOSM should do the same cleaning/stripping as if you would do Alt+S and OK.

Not sure if it is worth to add a Validator warning for invisible characters?

Well, at least the current warning (see my screenshot) is quite confusing because it says that "https" is invalid (yes, likely it also shows the invisible chars).

Should we have invisible characters in URLs? Is that valid a URL anyway? I do not know.

Last edited 3 weeks ago by aseerel4c26 (previous) (diff)

comment:10 in reply to:  9 Changed 2 weeks ago by Don-vip

Replying to aseerel4c26:

JOSM should do the same cleaning/stripping as if you would do Alt+S and OK.

Yep.

comment:11 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 13597/josm:

fix #16145 - remove white spaces from key/values when pasting tags

comment:12 in reply to:  11 Changed 2 weeks ago by aseerel4c26

Replying to Don-vip:

In 13597/josm:

fix #16145 - remove white spaces from key/values when pasting tags

Perfect, thank you! Also pasting from here works with version 13600.
Have a nice weekend, you guys!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain aseerel4c26.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.