Modify

Opened 2 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#16133 closed defect (fixed)

Imagery layer offset not saved

Reported by: pinkduck Owned by: team
Priority: major Milestone: 18.04
Component: Core imagery Version: latest
Keywords: offset drag regression Cc:

Description

What steps will reproduce the problem?

  1. Add imagery layer
  2. menu Imagery > New Offset
  3. Drag to move layer offset
  4. Click OK button in offset dialog
  5. Drag again on imagery layer

What is the expected result?

Layer remains in place once dialog accepted

What happens instead?

The layer continues to be moved until Enter key is pressed

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-26 22:16:39 +0200 (Mon, 26 Mar 2018)
Revision:13576
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Build-Date:2018-03-26 20:45:23
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13576 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1709 (16299)
Memory Usage: 256 MB / 2048 MB (101 MB allocated, but free)
Java version: 9.0.4+11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024, \Display1 1280x1024
Maximum Screen Size: 1280x1024
VM arguments: [-XX:HeapDumpPath=JOSM.hprof, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ measurement (34109)
+ reverter (34109)
+ terracer (34109)
+ utilsplugin2 (34109)

Tagging presets:
+ C:\Users\Pink Duck\Downloads\JOSM Custom Presets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/EnglandWalesRightsOfWay&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&style&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- E: java.util.concurrent.ExecutionException: [powershell, -Command, [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12;[System.Net.WebRequest]::Create('https://www.certigna.fr').GetResponse()]
- E: Failed to locate image 'styles/standard/vehicle/restriction/speed.png'
- W:  NSL: Could not get presets icon styles/standard/vehicle/restriction/speed.png
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (15)

comment:1 Changed 2 months ago by Adam Schneider

This is happening for me too, using version 13576 on Mac OS X... except that pressing the Enter key does NOT clear it up; I have to restart JOSM to regain normal mouse control.

Reverting to JOSM 13500 doesn't seem to help, so maybe the problem is in an updated plugin?

comment:2 Changed 2 months ago by Don-vip

Milestone: 18.04

Follow-up of #15716, #15849, #16053... I can't get this feature to work properly in all use cases...

comment:3 Changed 2 months ago by Don-vip

Keywords: regression added; imagery dialog removed

comment:4 Changed 8 weeks ago by Klumbumbus

Ticket #16151 has been marked as a duplicate of this ticket.

comment:5 Changed 8 weeks ago by Klumbumbus

from #16151:

Last version that DOES NOT have this bug is 13533. Stable 13576 is buggy as well.

comment:6 Changed 7 weeks ago by Don-vip

Ticket #16153 has been marked as a duplicate of this ticket.

comment:7 Changed 7 weeks ago by Don-vip

Priority: normalmajor
Summary: Imagery align cessationImagery layer offset not saved

comment:8 Changed 6 weeks ago by Don-vip

Ticket #16179 has been marked as a duplicate of this ticket.

comment:9 Changed 6 weeks ago by Klumbumbus

The video in #16179 show a bit different behavior. The align window disappears so clicking on OK is not possible at the beginning.

comment:10 Changed 4 weeks ago by Klumbumbus

Ticket #16218 has been marked as a duplicate of this ticket.

comment:11 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13686/josm:

fix #16133, see #16053 - fix imagery layer offset bug (regression of r13546)

comment:12 Changed 4 weeks ago by Klumbumbus

Resolution: fixed
Status: closedreopened

I just tested it in v13690 and it is still not fully fixed.

  1. open dialog
  2. press ESC
  3. dialog closes
  4. drag with left mouse button hold moves the background
Version 1, edited 4 weeks ago by Klumbumbus (previous) (next) (diff)

comment:13 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 13694/josm:

fix #16133, see #16053 - fix imagery layer offset bug (regression of r13546)

comment:14 Changed 3 weeks ago by ralph.a.aytoun@…

I am also experiencing this problem on my Acer laptop on Windows 10 and JOSM version 13576. Pressing the "Enter" key does not free the imagery layer so cannot do any mapping.

I have found a work-around.

In the layers panel on the right I manually move the green "active layer" icon to the imagery layer that I want to move, then moving the imagery and pressing "OK", then manually moving the "active layer" icon back to the Data layer. This process allows JOSM to accept the moved imagery and revert back to mapping mode.

comment:15 Changed 3 weeks ago by Klumbumbus

It should be fixed now since v13694. You can try the latest version or wait for the next stable version, which will be released soon.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.