Modify

Opened 4 years ago

Closed 4 years ago

#14554 closed defect (fixed)

The "Misspelled property value - Value 'Bing' for key 'source' looks like 'bing'" validator warning should be reversed and demoted, or removed

Reported by: moltonel Owned by: team
Priority: normal Milestone:
Component: External preset Version:
Keywords: bing Cc:

Description

As mentioned https://lists.openstreetmap.org/pipermail/talk/2017-March/077645.html :

While we do have a "standard values should be lowercase" best-practice in OSM, I don't think this should apply to source tags except maybe "survey" and "local_knowledge" :

  • Most source values, like Bing, are proper names and capitalization matters.
  • Exact capitalization could be expected/demanded by sources which allow importing into OSM.
  • "Bing" is twice as frequent as "bing" on taginfo, so suggesting the later goes against the general trend.
  • Clicking the "obtain from current layers" link in the changeset upload form yields "Bing", which is inconsistent with the validator warning.
  • There's no reason to treat Bing specially, yet the validator doesn't warn about "Mapbox" or "Mapillay".

The simple way to fix this is to remove the warning altogether, but alternatively:

  • The warning should suggest "Bing" rather than "bing"
  • The warning should be demoted to a notice
  • Other values like "Mapbox" etc should be handled similarly (maybe extract the correct values from the imagery definitions ?)

Attachments (0)

Change History (10)

comment:1 Changed 4 years ago by Klumbumbus

Owner: changed from team to moltonel
Status: newneedinfo

I can't reproduce.

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


additionally required: the content of the box named "data sources (*.cfg)" in the validator settings (Help/Preferences/Validator)

comment:2 Changed 4 years ago by moltonel

What steps will reproduce the problem?

  1. Download and edit data, adding a "source=Bing" tag to some object
  2. Start uploading the data to trigger the validator

What is the expected result?

No "Misspelled property value" warning from the validator.
Or (as explained in the initial report) a notice to replace "bing" with "Bing" (change the steps to reproduce accordingly).

What happens instead?

Misspelled property value - Value 'Bing' for key 'source' looks like 'bing'

Please provide any additional information below. Attach a screenshot if possible.

Build info provided since you asked for it, but this validator check has been there and enabled by default for as long as I remember.

Build-Date:2017-03-21 16:46:18
Revision:11763
Is-Local-Build:true

Identification: JOSM/1.5 (11763 SVN en) Linux Gentoo
Memory Usage: 1045 MB / 1765 MB (519 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.library.path=/lib:/usr/lib]
Dataset consistency test: No problems found

Plugins:
+ HouseNumberTaggingTool (33160)
+ ImproveOsm (97)
+ Mapillary (v1.4.2)
+ OpeningHoursEditor (33185)
+ PicLayer (33148)
+ SimplifyArea (33004)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ cadastre-fr (33088)
+ continuosDownload (53)
+ contourmerge (1030)
+ ejml (32680)
+ geochat (33088)
+ geotools (33042)
+ imagery_offset_db (33004)
+ jna (32699)
+ jts (32699)
+ measurement (33088)
+ merge-overlap (33154)
+ reltoolbox (33088)
+ reverter (33088)
+ scripting (30764)
+ splinex (33160)
+ terracer (33088)
+ todo (30000)
+ turnrestrictions (33088)
+ utilsplugin2 (33182)

Tagging presets:
+ http://somewhere.dk/email/josm/source.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&preset&zip=1
+ http://maps.openstreetmap.ie/josm/irishboundaries.xml
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/current/roofspresets.xml
+ http://maps.openstreetmap.ie/josm/irishboundaries-dev.xml

Map paint styles:
- <josm.pref>/hidenodes.mapcss
- <josm.pref>/width.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- http://maps.openstreetmap.ie/josm/townland.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.SocketTimeoutException: Read timed out
- W: java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org

comment:3 Changed 4 years ago by Klumbumbus

whats the content of the box named "data sources (*.cfg)" in the validator settings (Help/Preferences/Validator)?

comment:4 Changed 4 years ago by Klumbumbus

Owner: changed from moltonel to team
Status: needinfonew

OK, this is caused by the external preset http://somewhere.dk/email/josm/source.xml you added to your list.

comment:5 Changed 4 years ago by Klumbumbus

comment:6 Changed 4 years ago by moltonel

Ah sorry for missing the request for specific info (I've got the standard ignoretags.cfg and words.cfg). I've seen that warning for so long that I assumed it was core josm behavior.

I can confirm that after moving my ~/.josm aside, I need to readd the sources preset to get the faulty behavior. And that unchecking the "check property values" validator setting makes the warning go away.

Strangely, if I edit cache/mirror_http___somewhere.dk_email_josm_source.xml to /s/bing/Bing/, the warning disappears completely, so getting that preset fixed would help but now I'm wondering why with that change it doesn't suggest "Bing" when I enter "bing".

comment:7 Changed 4 years ago by Don-vip

I'd rather ask to fix the preset. There's no problem on our side.

comment:8 Changed 4 years ago by Don-vip

Component: Core validatorExternal preset
Keywords: bing added

comment:9 Changed 4 years ago by Klumbumbus

The preset is in our list since the beginng (https://josm.openstreetmap.de/wiki/Presets?version=4)

It seems the problem is that the preset contains 6 times "Bing" and once "bing" as source values. This should be fixed in the preset.

Also I see a xml parse error today at http://somewhere.dk/email/josm/source.xml in the browser, which was not there yesterday.

Version 1, edited 4 years ago by Klumbumbus (previous) (next) (diff)

comment:10 in reply to:  9 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Replying to Klumbumbus:

Also I see a xml parse error today at http://somewhere.dk/email/josm/source.xml in the browser, which was not there yesterday.

Great, presets removed, ticket closed, next!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.