Modify

Opened 4 years ago

Closed 4 years ago

#13267 closed defect (fixed)

JOSM does not show recently added tags (when openign a new session) - ver: latest-10710

Reported by: OSM-user:smaprs Owned by: team
Priority: normal Milestone: 16.07
Component: Core Version: latest
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. I've uninstalled the hole previous version of JOSM in my Windows7 (also removed its branches at C:\Users\XX\AppData\Roaming\JOSM and C:\Users\XX\AppData\Local\JOSM), and reinstalled from latest josm-setup.exe, and used josm-latest.jar ver.10710; it opens OK as ver.10710;
  2. I've added a tag like "building=yes" from the tag list; in the same session, for a new object, JOSM correctly shows again recently-added-tags;
  3. But after closing JOSM and reopening it, it doesn't shows again the recently-added-tags in the list.

What is the expected result?

JOSM should show the same previous list of recently-added-tags every new session

What happens instead?

JOSM "doesn't show" the same previous list of recently-added-tags in a new session

Please provide any additional information below. Attach a screenshot if possible.

http://i.imgur.com/2qas5vV.jpg

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-02 22:18:08 +0200 (Tue, 02 Aug 2016)
Build-Date:2016-08-03 01:55:14
Revision:10710
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10710 en_GB) Windows 7 32-Bit
Memory Usage: 92 MB / 247 MB (38 MB allocated, but free)
Java version: 1.8.0_73-b02, Oracle Corporation, Java HotSpot(TM) Client VM

Plugins:
+ turnrestrictions (32629)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by simon04

Keywords: regression added
Milestone: 16.07

Bug not present in r10526.

Version 0, edited 4 years ago by simon04 (next)

comment:2 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 10722/josm:

fix #13267 - JOSM does not remember last used tags after restart

Due to typo in r10332.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.