Ignore:
Timestamp:
2012-09-08T16:51:51+02:00 (8 years ago)
Author:
Don-vip
Message:

Robustness in "plugin.requires" parsing

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/org/openstreetmap/josm/plugins/PluginHandler.java

    r5436 r5508  
    7070public class PluginHandler {
    7171
    72     /* deprecated plugins that are removed on start */
     72    /**
     73     * deprecated plugins that are removed on start
     74     */
    7375    public final static Collection<DeprecatedPlugin> DEPRECATED_PLUGINS;
    7476    static {
     
    445447            Set<String> missingPlugins = new HashSet<String>();
    446448            for (String requiredPlugin : plugin.requires.split(";")) {
     449                requiredPlugin = requiredPlugin.trim();
    447450                if (!pluginNames.contains(requiredPlugin)) {
    448451                    missingPlugins.add(requiredPlugin);
Note: See TracChangeset for help on using the changeset viewer.