Ignore:
Timestamp:
2016-09-10T01:45:13+02:00 (3 years ago)
Author:
Don-vip
Message:

fix #13609 - --version and --help are too verbose

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/org/openstreetmap/josm/tools/I18n.java

    r10748 r10983  
    403403        // FIXME: This can be removed after we switch to a minimal version of Java that enables CLDR by default
    404404        // or includes all languages we need in the JRE. See http://openjdk.java.net/jeps/252 for Java 9
    405         Utils.updateSystemProperty("java.locale.providers", "JRE,CLDR");
     405        System.setProperty("java.locale.providers", "JRE,CLDR"); // Don't call Utils.updateSystemProperty to avoid spurious log at startup
    406406
    407407        //languages.put("ar", PluralMode.MODE_AR);
Note: See TracChangeset for help on using the changeset viewer.