Ticket #18916: 18916.3.patch

File 18916.3.patch, 9.2 KB (added by taylor.smock, 3 months ago)

Update Eclipse to use IvyDE

  • .classpath

     
    1313                        <attribute name="javadoc_location" value="jar:platform:/resource/JOSM-apache-commons/lib/dec-0.1.2-javadoc.jar!/"/>
    1414                </attributes>
    1515        </classpathentry>
    16         <classpathentry kind="lib" path="lib/zstd-jni-1.3.2-2.jar" sourcepath="lib/zstd-jni-1.3.2-2-sources.jar">
    17                 <attributes>
    18                         <attribute name="javadoc_location" value="jar:platform:/resource/JOSM-apache-commons/lib/zstd-jni-1.3.2-2-javadoc.jar!/"/>
    19                 </attributes>
    20         </classpathentry>
     16        <classpathentry exported="true" kind="con" path="org.apache.ivyde.eclipse.cpcontainer.IVYDE_CONTAINER/?project=JOSM-apache-commons&amp;ivyXmlPath=ivy.xml&amp;confs=*"/>
    2117        <classpathentry kind="output" path="bin"/>
    2218</classpath>
  • .project

     
    33        <name>JOSM-apache-commons</name>
    44        <comment></comment>
    55        <projects>
     6                <project>JOSM</project>
    67        </projects>
    78        <buildSpec>
    89                <buildCommand>
     
    2425        <natures>
    2526                <nature>org.eclipse.jdt.core.javanature</nature>
    2627                <nature>net.sf.eclipsecs.core.CheckstyleNature</nature>
     28                <nature>org.apache.ivyde.eclipse.ivynature</nature>
    2729        </natures>
    2830</projectDescription>
  • build.xml

     
    11<?xml version="1.0" encoding="utf-8"?>
    2 <project name="apache-commons" default="dist" basedir=".">
     2<project name="apache-commons" default="dist" basedir="." xmlns:ivy="antlib:org.apache.ivy.ant">
    33
    44    <!-- enter the *lowest* JOSM version this plugin is currently compatible with -->
    55    <property name="plugin.main.version" value="10580"/>
     
    1010    <property name="plugin.author" value="nokutu; Don-vip"/>
    1111    <property name="plugin.class" value="org.openstreetmap.josm.plugins.commons.CommonsPlugin"/>
    1212    <property name="plugin.description" value="Provides Apache Commons library components. Not meant to be installed directly by users, but rather as a dependency for other plugins."/>
    13    
     13
    1414        <property name="josm" location="../../core/dist/josm-custom.jar"/>
    1515        <property name="plugin.dist.dir" value="../../dist"/>
    1616    <!--<property name="plugin.requires" value=""/>-->
     
    2121    <!-- ** include targets that all plugins have in common ** -->
    2222    <import file="../build-common.xml"/>
    2323
     24    <target name="resolve" description="--> retrieve dependencies with Ivy">
     25        <ivy:retrieve/>
     26    </target>
     27
     28    <target name="dist" depends="resolve,plugin_common.dist"/>
     29
    2430    <!--
    2531    ***************************************************************
    2632    ** compile_lang3 - compiles Apache Commons Lang 3 (not UTF-8 !)
  • ivy.xml

     
     1<?xml version="1.0" encoding="utf-8"?>
     2<!-- License: GPL. For details, see LICENSE file. -->
     3<ivy-module version="2.0">
     4    <info organisation="org.openstreetmap" module="josm"/>
     5    <configurations>
     6        <conf name="ivy" description="Apache Ivy configuration for self-update"/>
     7        <!--  configuration that should be used when specifying dependencies -->
     8        <conf name="implementation" description="All libs JOSM uses that plugins should not use"/>
     9        <conf name="api" description="All libs that JOSM uses and are available for plugins"/>
     10        <conf name="runtimeOnly" description="The libs shipped with JOSM that we do not need during compilation"/>
     11        <conf name="provided" description="The libs we need during compilation but not on application start"/>
     12        <conf name="epsg" description="Everything epsg needs- which is currently all of JOSM."/>
     13        <!--  Meta configuration used in build scripts -->
     14        <conf name="runtime" description="Libraries only needed at runtime" extends="implementation,api,runtimeOnly"/>
     15        <conf name="compile" description="Libraries needed only for compilation" extends="implementation,api,provided"/>
     16        <conf name="test" description="Libraries only needed for testing" extends="compile,runtime"/>
     17    </configurations>
     18    <dependencies>
     19        <dependency org="com.github.luben" name="zstd-jni" rev="1.4.4-7" conf="api->default"/>
     20    </dependencies>
     21</ivy-module>
  • src/org/apache/commons

    Cannot display: file marked as a binary type.
    svn:mime-type = application/octet-stream
    
    Property changes on: lib/zstd-jni-1.3.2-2-javadoc.jar
    ___________________________________________________________________
    Deleted: svn:mime-type
    ## -1 +0,0 ##
    -application/octet-stream
    \ No newline at end of property
    Cannot display: file marked as a binary type.
    svn:mime-type = application/octet-stream
    
    Property changes on: lib/zstd-jni-1.3.2-2-sources.jar
    ___________________________________________________________________
    Deleted: svn:mime-type
    ## -1 +0,0 ##
    -application/octet-stream
    \ No newline at end of property
    Cannot display: file marked as a binary type.
    svn:mime-type = application/octet-stream
    
    Property changes on: lib/zstd-jni-1.3.2-2.jar
    ___________________________________________________________________
    Deleted: svn:mime-type
    ## -1 +0,0 ##
    -application/octet-stream
    \ No newline at end of property