wiki:Ru:HowTo

Эта страница даст вам представления об основных действиях, которые можно выполнять в JOSM.

Выделение линий, имеющих общие точки

Довольно часто встречаются случаи, когда две или более source:trunk/images/data/way.pngлиний имеют несколько общих source:trunk/images/data/node.pngточек. Используя инструмент выделения можно выделить только одну линию.

При нажатии средней клавиши мыши, когда курсор находится над линиями - вы увидите всплывающее окно с перечнем этих линий. Нажмите Ctrl, удерживая среднюю кнопку мыши, после чего вы можете отпустить среднюю клавишу и воспользоваться левой кнопкой для выбора одной из линий из списка.

Или вы можете воспользоваться клавишей AltGr для пошагового переключения между линиями с помощью левой клавиши мыши.

для пользователей Mac

В Mac OSX, нет клавиши, работающей как средняя клавиша в unix. Вы можете использовать среднюю клавишу Mighty Mouse. Подключите Mighty Mouse, откройте System Preferences, щелкните на "Keyboard and Mouse" и настройте использование клавиши Пули как "button 3". после чего ее можно использовать как среднюю клавишу. Заметьте, что вы не можете установить другую кнопку как "button 3" с помощью Apple Driver. Возможно, вам больше подойдет драйвер мыши для этого.

Как продлить линию

Воспользуйтесь инструментом «Выделение» (S) и выделите конец существующей линии. После этого используйте инструмент чертить точки (A) для нанесения на карту новых точек, которые автоматически продлят существующую линию.

Полученная линия будет включать исходную линию и новые добавленные точки и, если вы добавили название или любые другие атрибуты, они будут применены ко всей удлиненной линии.

Как добавить точки к линии

Используя инструмент «чертить точки», наведите курсор (в виде перекрестия) на линию в которую вы хотите добавить точку. Линия должна стать подсвеченной.

Щелкните на линию в том месте, где вы хотите добавить точку. Будет добавлена ​​точка, и программа будет ждать от вас создания новых точек для новой линии, которую вы только что начали.

Нажмите клавишу Esc, чтобы прекратить рисование новой линии. Теперь вы можете добавить еще одну точку к существующей линии.

Как изменить тип перекрестка на круговое движение

Скажем, кто-то нарисовал перекресток, но вы хорошо знаете, что в этом месте организовано круговое движение, и хотите показать это. Если это мини-круг, добавьте тег highway=mini_roundabout к точке на пересечении дорог и все - готово. В противном случае ...

  • Начертите линию, длиной равной диаметру круга.

  • Выделите ее и воспользуйтесь инструментом Инструменты -> Создать окружность.

  • Если вы считаете, что получилось недостаточно кругло, добавьте в него несколько точек и воспользуйтесь инструментом Инструменты -> Выстроить точки по окружности.
  • Переместите окружность на перекресток.

  • Вы можете вращать круг удерживая CTRL+SHIFT в режиме Выделение

Теперь мы разъединим перекресток :)

  • Выделите точку в центре перекрестка и разъедините линии нажав G (Инструменты -> Разъединить линии)
  • Щелкните в любом пустом месте для снятия выделения. Нажмите на центральную точку вновь (теперь она состоит из двух точек одна над другой) и сдвиньте ее немного в сторону. Две линии разъединены.

  • Выделите одну из двух точек и нажмите P (Инструменты -> Разделить линию). Выделите ту же точку снова и разъедините линию (G), сбросьте выделение и выделите ее снова и переместите ее немного в сторону.

  • Повторите тоже самое для другой линии; вы получите четыре конца линий.
  • Переместите эти концы к тому месту, где они должны быть присоединены к окружности.

  • Щёлкните по одному из концов и нажмите A.
  • Щелкните на круге для соединения линии с окружностью. (Либо по одной из существующих точек, либо щелкните на один из отрезков окружности для создания новой точки.)

  • Выделите ту же точку снова и нажмите клавишу Delete для ее удаления.
  • Повторите для других трёх концов.
  • Готово!

Внимание:

  • Убедитесь, что окружность имеет соответствующее направление движения. (Инструменты -> Изменить направление линии чтобы исправить.)
  • Проверьте, не входят ли линии в некие отношения (relation) между собой или с другими объектами. Если вы не заботитесь о связях объектов, пожалуйста, все равно не разрушайте существующие. Приятно иметь аккуратный перекресток с круговым движением, но отношения (relation) - это действительно полезно :).

Как использовать голосовые метки и продолжительные звукозаписи

Смотри Audio Mapping.

Использование JOSM в Linux

Запуск: java -jar ./josm-tested.jar

HowTo/JOSM-under-Linux

Как использовать проверку данных

Смотри Примеры проверки данных? , где сообщается как исправлять ошибки, выявленные в ходе проверки данных.


Назад к Основной странице

Last modified 5 years ago Last modified on 2012-02-06T17:44:10+01:00