wiki:Hu:VersionHistory

Korábbi JOSM újdonságok

  • 2017. 10. 03. (stabil kiadás 12921)
    • Hivatkozások a külső módosításcsomag nézegetőkre az Előzmények és Módosításcsomag kezelő ablakban
    • Visszajelzés kérése jelölőnégyzet a feltöltés ablakban
    • A kör létrehozás eszköz már az átmérő függvényében hoz létre pontokat
    • Új parancssori paraméterek, egyes feladatok grafikus felület nélküli futtatásához:
      • OSM adatok kirajzolása MapCSS stílusozással
      • Koordináták átváltása egyik vetületből a másikba
  • 2017. 09. 02. (stabil kiadás 12712)
  • 2017. 07. 30. (stabil kiadás 12542)
    • Keresés címkekészlet alapján a Kereső ablakban.
    • Új „otthon” helyszín könyvjelző (ha az OSM fiókban be van állítva) és a legutóbbi 15 módosításcsomag könyvjelzője.
  • 2017. 07. 02. (stabil kiadás 12450)
  • 2017. 05. 29. (stabil kiadás 12275)
  • 2017. 05. 02. (stabil kiadás 12039)
    • Légifelvétel rétegek transzformációja (átvetítés): lehetővé teszi a különböző vetületekből származó források kombinálását.
  • 2017. 04. 02. (stabil kiadás 11826)
    • "upload=never" tartalmú osm fájlok feltöltésének megakadályozása
    • Új beállítási lehetőség, hogy ne zoomoljon az újonnan letöltött adatokra. (csak szakértő módban)
  • 2017. 02. 27. (stabil kiadás 11639)
    • A GPS hőtérkép mód pár új beállítással bővült, hogy szabályozni lehessen a megjelenítését.
    • A légifelvételek tükörszerverei kiválaszthatóak a Légifelvétel beállítások menüben.
  • 2017. 02. 02. (stabil kiadás 11526)
    • A GPS nyomvonalak hőtérkép stílusban is megjeleníthetőek.

2016

  • 2016. 12. 31. (stabil kiadás 11427)
    • Belső adatbázis az összes ország határvonaláról. A hibakereső szabályok, térképrajz stílusok már akár egy-egy országra is korlátozhatók.
    • Adatokat letölteni egy URL-t a JOSM ablakára húzva, vagy beillesztve is lehet. Támogatja a Hely megnyitása ablak által ismert URL típusokat.
    • A címke hozzáadása ablak kulcs és érték mezői kitöltődnek az alatta lévő lista következő elemével, ha a lista első kulcsa már használatban van.
  • 2016. 11. 06. (stabil kiadás 11223)
  • 2016. 09. 05. (stabil kiadás 10966)
  • 2016. 08. 12. (stabil kiadás 10786)
    • Váltás Java 8-ra, a JOSM központi kódjának jelentős átdolgozásával
    • Új lehetőséga Szerkesztés menüben: „Beillesztés az eredeti helyre” (Ctrl+Alt+V, csak szakértő módban)
    • geo: URL-ek felismerése
  • 2016. 07. 12. (stabil kiadás 10526)
    • A JOSM központi kódjának jelentős átdolgozása
  • 2016. 04. 28. (stabil kiadás 10161)
    • Új rétegszűrők (átlátszóság, színtelítettség, gamma, élesség)
  • 2016. 03. 13. (stabil kiadás 9979)
    • Az OAuth lett az alapértelezett bejelentkezési mód.
    • Drag & Drop támogatás a kapcsolatszerkesztőben (bővebben)
    • Kapcsolat frissítése gomb a kapcsolatszerkesztőben (pl. egy vonal elvágása után)
    • Az Előzmények ablak térképen jeleníti meg az elmozgatott pontok régi és új koordinátáit
    • Zoomszint automatikus rögzítése a háttérkép felbontásához
    • Kibővített térképvetület támogatás

2015

  • 2015. 12. 31. (stabil kiadás 9229)
    • A felületek csak a határvonaluk belső fele mentén vannak kitöltve. Ez, és más beállítások módosíthatóak a JOSM alapértelmezett térképstílus Stílusbeállítások menüjében. További információ a stílusbeállításról
  • 2015. 11. 23. (stabil kiadás 9060)
    • Norvég Bokmål nyelvváltozat támogatása
  • 2015. 10. 30. (stabil kiadás 8969)
    • Vonal vágás: a leghosszabb szakasz örökli az eredeti vonal azonosítóját és előzményeit (a haladó felhasználók másik szakaszt is választhatnak)
    • A pontok térképen használt ikonjai megjelennek a listákban is (pl. kiválasztás ablak, kapcsolat szerkesztő, feltöltés dialógus)
  • 2015. 09. 28. (stabil kiadás 8800)
    • Overpass letöltés és Overpass Turbo Wizard (Csak szakértő módban)
    • Minimap ablak
    • Taginfo link a címkék jobb klikkes menüjében
    • Háttérkép rétegen beállítható a gamma érték
  • 2015. 08. 22. (stabil kiadás 8677)
  • 2015. 06. 17. (stabil kiadás 8491)
    • Belarusz nyelv támogatása
    • Vietnami nyelv támogatása
  • 2015-04-18 (8227)
    • Valenciai nyelv támogatása
  • 2015-03-31 (8160)
    • Litván nyelv támogatása
  • 2015-03-02 (8109)
    • Újabb nyelvek támogatásához több betűtípus Windowson
    • Néhány bővítmény már telepíthető és használható a JOSM újraindítása nélkül.
    • Új keresőmező a menüelemekhez (jobb felső sarok)
    • A beépített Jegyzetek kezelés alapértelmezetten engedélyezetté vált (a Jegyzetek bővítmény ki lett kapcsolva).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Két új nyelv: Asztúriai és Khmer.
    • Beállítások, felhasználói adatok és cache fájlok könyvtára módosult OS X-en és Windowson.
  • 2014-12-10 (7777)
    • Új logó, tervezte: Diamond00744.
    • OSM Jegyzetek letöltése/feltöltése → Notes Dialog.
    • Előzmények oldalsáv dialógusablak eltávolítva, helyette a Kiválasztás ablak kapott egy előzmények gombot.
  • 2014-10-21 (7643)
    • A billentyűkombinációkat, és a Vonalak egyesítése eszköz konfliktuskezelését érintő nagyobb hibák javítása.
  • 2014-09-30 (7588)
    • Jobb OS X integráció (részletekért lásd #10455).
    • OSM címkék megjelenítése a Címkekészlet ablakban.
  • 2014-09-20 (7569)
    • A JOSM már figyelmeztet a régi fajta multipolignokra, amik a releváns címkék külső vonalról kapcsolatba mozgatásával szüntethetők meg.
  • 2014-08-31 (7480)
    • Az alap térképstílus fejlesztései:
      • Alacsony zoomszinten a pontok szimbólumai és ikonjai eltűnnek (ez konfigurálható a stílusbeállításokban).
      • Jobb felirat pozicionálás a területeken belül
      • Az utak neve a vonal mentén jelenik meg
    • Offline mód új parancssori argumentummal --offline=[josm_website|osm_api|all]
  • 2014-07-20
    • Grafikai versenyt hirdetünk egy új logó elkészítésére szeptember 30-i határidővel! Részletekért lásd a wikit.
  • 2014-07-04 (7287)
    • Új dupla igazítás mód a Kihúzó eszközben
    • Helyi térképrajz stílusok és hibakeresési szabályok automatikus újratöltése
    • A légifelvétel lista automatikus frissítése
  • 2014-05-18 (7139)
    • A JOSM alapértelmezett térképstílusa XML-ből át lett konvertálva MapCSS-be
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Váltás Java 7-re; kódtisztítás
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • OSM API elérése HTTPS kapcsolaton
  • 2014-01-29 (6767)
    • Új MapCSS-alapú címkeellenőrző, ami kibővíthető saját szabályokkal
    • "Objektumok keresése Címkekészlet alapján" művelet Shift-F3
    • Címkekészlet/MapCSS/Ellenőrző fejlesztések

2013

  • 2013-12-20 (6502)
    • A feltöltés dialógusablak megkérdezi a módosítások forrását
    • Előzmények: módosításcsomag megjegyzés letöltése és megjelenítése
    • source:trunk/images/mapmode/improvewayaccuracy.png Vonalpontosság növelése engedélyezve a nem haladó felhasználóknak is
    • Sok egyéb fejlesztés (pl. magyar EOV (EPSG:23700) vetület) és hibajavítás (changelog)
  • 2013-11-17 (6388)
    • Frissített nyelvi fájlok
  • 2013-11-12 (6383)
    • Új "Pont leválasztása vonalról" eszköz
    • Értesítés olvasatlan OSM üzenetekről
    • Sok apró fejlesztés a címkekészleteken, stílusokon és a hibakeresőn
  • 2013-09-20 (6238)
    • Új, nem zavaró értesítések
    • Új "munkamenet" menüpont található a Fájl menüben szakértő módban
    • GPX route-ok teljes támogatása
    • Sok apró fejlesztés a címkekészletek, újraindítás, stílusok, és a hibakereső teljesítménye terén
  • 2013-08-07 (6115)
    • OAuth azonosítás szükséges az új Jegyzetek bővítmény teljes támogatásához.
    • Átdolgozott bővítménymenük a jobb csoportosítás és integráció érdekében
    • Az (utoljára) kiválasztott objektumok gyerekpontjainak preferálása duplikációval rendelkező pontok kiválasztásakor
    • Sok egyéb fejlesztés és hibajavítás (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • beállítható billentyűkombinációk a címkekészletekhez és eszköztár gombokhoz és új "Billentyűkombináció szerkesztése" környezeti menü a módosításukhoz
    • automatikus zoom a WMS rétegeken
    • új "Panelek ki/be kapcsolása" művelet a tabulátor gombbal, amivel eltüntethetőek az oldalsó panelek
  • 2013-05-08 (5939)
    • újraindítás bővítmény beépítve a főprogramba
    • jobb klikkes "visszavonás, kivágás, másolás, beillesztés, törlés, kijelölés" menü a szövegdobozokhoz
    • javított Elfelejtés művelet teljesítmény
  • 2013-04-08 (5836)
    • jelentősen átdolgozott környezeti menük
    • "puffer törlése" gomb a helytelen puffertartalom eltávolítására a "címke beillesztése szövegből" műveletnél (Ctrl+Shift+V)
    • az (elavult) légifelvétel eltolás szerver eltávolítva
  • 2013-03-07 (5759)
    • Ctrl+Shift+V már tud címkéket beilleszteni vágólapról, pl. a=2,c=3 és a 2 c 3
    • többrétű MapCSS renderelési fejlesztés
    • A Kihúzó mód már elhúzza a pontokat is
    • helyi menük a Tulajdonságok ablak Hozzáadás/Szerkesztés dialógusában és opció a billentyűzetkiosztás javításához
    • alap dátumszűrés a GPS nyomvonalakhoz
    • távirányító: címkék törlése és objektumok létrehozása címkékkel
    • sok apró fejlesztés és hibajavítás
  • 2013-02-06 (5697)
    • javasolt szerepek a kapcsolatszerkesztőben és kapcsolat létrehozásakor
    • a kapcsolatlista ablak szűrhető lett
    • számos fejlesztés az Érték hozzáadása ablakban: súgó gomb, pozíció megjegyzése, több érték megadásának lehetősége egyszerre, az ablak bezárása nélkül (Shift+klikk)
    • légifelvételeknél új wms_endpoint beállítás és átdolgozott WMS/TMS dialógusok
    • új hibakereső tesztek lakcímekhez és wikipédia címkékhez, teljesítményjavítás a rétegrajzolásban és pár hibajavítás
    • sok apró fejlesztés

2012

  • 2012-12-08 (5608)
    • keresésnél új nth: és nth% operátorokkal lehet keresni pozícióra a vonalban
    • néhány kisebb fejlesztés a távirányítónál és a beépített címkekészletekben
  • 2012-11-10 (5576)
    • a "tengeri mérföld" (NM) támogatott mérési rendszer lett
  • 2012-10-08 (5531)
    • hibakereső épülettesztje átdolgozva
    • feltöltésnél néhány címke automatikusan kidobva (TIGER, odbl, yh)
    • a licencváltással kapcsolatos kódok eltávolítva
  • 2012-08-29 (5482, 5485)
    • javaslat légifelvétel választáshoz a letöltött terület alapján
    • címkék hozzáadásánál az öt utoljára használt címke megjelenik a gyorsabb használatért
    • a szűrő jobban kezeli a multipoligonokat
    • a 'Fájl > Megnyitás...' ablakban többé nem lehet könyvtárat kiválasztani és betölteni az összes benne lévő fotót automatikusan. Helyette válaszd ki a képfájlokat közvetlenül (Ctrl-A vagy Shift-kattintás használatával). A GPX réteg jobb klikkes 'Képek importálása' menüje továbbra is a régi módon működik.
  • 2012-07-23 (5353, 5356)
    • fontosabb hibajavítások a Licencváltás bot által módosított adatok kezeléséhez
    • apróbb fejlesztések a térképstílusokon, a hibakereső tesztjein, beleértve az inaktív rétegek renderelését és a nevek megjelenítését hibakereső ablakában
  • 2012-07-03 (5315)
    • nagyobb hibajavítások az adatellenőrzőben, ütközéskezelőben és a rétegek egyesítésében
    • fejlesztések az ütközéskezelésben, beleértve a kiválasztást (dupla kattintás) és az elemre közelítést (helyi menü)
    • számos fejlesztés az adatellenőrző tesztjein
  • 2012-06-04 (5267)
    • új nyelvek: Portugál (európai) (pt), Katalán (ca)
    • egyéni vetületek támogatása
    • multipoligon készítésekor a címkék áthelyezése a kapcsolatba
  • 2012-05-02 (5210)
    • Néhány apró fejlesztés
      • alternatív keresési dialógus alapértelmezetté tétele
      • parancssori --load-preferences= argumentum beállítások indításkori alkalmazásához
      • MapCSS fejlesztése a bal és jobb oldali burkolat különböző megjelenítéséhez
  • 2012-04-14 (5181)
    • A josm.openstreetmap.de kezdőlapjának átrendezése és egyszerűsítése
    • Tesztelt verzió (5181) jelent meg rengeteg módosítással/fejlesztéssel, mint
      • source:trunk/images/mapmode/rope.png lasszó kijelölés mód (szakértő mód)
      • információs párbeszédablak kezdőknek: figyelmeztetés igazítatlan légifelvételre, és vonalak egyesítésekor az ütköző címkékre és vonalakra, amik kapcsolat tagjai
      • új lehetőség kapcsolatok szerkesztésére: "Kiválasztott elemek kapcsolathoz adása" (jobb kattintás egy kapcsolatra), "Előző/következő rés kijelölése" (kapcsolatszerkesztőben)
      • felhasználói felület fejlesztése a Nézet menüben: "Térképrajzolási stílusok", szerkesztősor elrejtésének lehetősége
      • számos javítás az indulási időn
  • 2012-02-07 (4905)
    • Új gyorsbillentyűk a Kapcsolatszerkesztőhöz: Alt-Fel, Alt-Le (kijelölt elemek mozgatása fel/le), Alt-Del (tag törlése) és Alt-Home (félkész tagok letöltése)
    • Elérhető egy összesített változáslista is, mi az előző főverzió óta történt lényeges változtatásokat tartalmazza.
  • 2012-02-02 (4897 ...)
    • A JOSM és a bővítények ütköző billentyűparancsai javítva. Sok gyorsbillentyű funkciója megváltozott!
  • 2012-01-22 (4846)
    • Az ImproveWayAccuracy bővítmény a főprogram része lett. Válassz ki egy vonalat, kattints a source:trunk/images/mapmode/improvewayaccuracy.png gombra és javíts a pontosságán. A részletes leíráshoz lásd a súgólapját.
  • 2012-01-21 (4791, 4796, 4833)
    • Különböző bővítések a RemoteControlhoz: új '/load_object' parancs id szerinti letöltésnél; '/add_way' parancs új vonal létrehozásához a megadott koordinátákkal; adatok új rétegben betöltéséhez 'new_layer' paraméter a '/load_and_zoom' parancshoz.
  • 2012-01-12 (4789)
    • Új parancssori kapcsoló tetszőleges beállításérték megadásához indításnál. (pl. --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • Egér alatti pontok és vonalak felvillantása kikapcsolható: 'Beállítások' > 'Megjelenítési Beállítások' > 'OSM Adatok' (Csak Szakértő módban)
    • A rajzolás művelet source:trunk/images/mapmode/node/autonode.png lehetővé teszi vonalszakaszok meghatározott szögben rajzolását (pl. 30/45°). A tabulátor gombbal tudod a rögzítést átkapcsolni.
  • 2012-01-04 (4765)
    • The automatic hiding of buttons for the right hand side dialogs can be disabled for each window individually. (Eye-symbol in the upper right corner)

2011

  • 2011-12-29 (4745)
    • New command to load and cache WMS background images along a gpx track in advance. (In right click menu of GPX-Layer)
  • 2011-12-20 (4673)
    • Lambert 93 projection (EPSG:2154) is available for France.
  • 2011-12-20 (4670)
    • Languages Arabic, Icelandic and Hebrew have been removed due to missing translation efforts.
  • 2011-12-05 (4621-4636)
    • Performance with large multipolygons improved.
  • 2011-11-26 (4609, 4611)
    • The buttons of the edit toolbar (upper left area) can be hidden.
    • When drawing ways, the backspace key takes back the last action.
  • 2011-11-20 (4601)
    • The version history display now shows the license status for each contributing user.
  • 2011-11-15 (4595)
    • Support for multipart shortcuts. For example Ctrl+Alt+S, 1 toggles the visibility of the first layer.
  • 2011-11-14 (4593)
    • On small screens, long menus are no longer clipped, but can be scrolled up and down.
  • 2011-11-07 (4587)
    • New option in the search dialog to add a toolbar button for the search. The button can be removed later from the right click menu of the button. (Only in expert mode.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • The internal format for saving user preference data has been changed to XML.
  • 2011-10-29 (4546)
    • The text display of nodes, ways and relations can be customized with name templates.
  • 2011-10-20 (4530)
    • The OsmChange format (*.osc) is now officially supported.
  • 2011-10-10 (4512)
    • Expert mode introduced to reduce complexity for new users. For compatibility existing installations are experts by default.
  • 2011-10-07 (4497, 4498, 4500)
    • More options in 'File > Download Object...' dialog.
    • History dialog: Better display of inserted / deleted way nodes (and relation members).
    • New shortcuts in properties dialog: Alt+A, Alt+S, Alt+D for Add, Edit, Delete.
  • 2011-09-23 (4454)
    • Copy key and value to clipboard by right click in the properties dialog.
  • 2011-09-12 (4416, 4423)
    • Bounds of imagery services are displayed on a preview map in 'Preferences > Imagery'.
  • 2011-09-08 (4408)
    • Menu item 'Inspect' in context menu of the selection dialog has moved to 'View > Advanced Info'.
  • 2011-09-07 (4405)
    • List in 'Preferences > Imagery' is sorted by country code.
  • 2011-08-29 (4380)
    • New feature 'Edit > Copy Coordinates'.
  • 2011-08-28 (4371)
    • The list of recently opened files shows not just opened, but also saved files.
  • 2011-08-27 (4355)
    • Dynamic visibility of button row in toggle dialogs to the right (optional, advanced preferences 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Shortcuts to toggle layer visibility (Alt-1 to Alt-9)
  • 2011-08-21 (4332)
    • Selection of visible tracks, for each gpx layer (from the right click menu of the layer)
  • 2011-08-21 (4327)
    • Select and delete mode now have better visual indication what the next action will do (highlighting, cursor changes).
  • 2011-07-18 (4256)
    • Support for the SVG image format.
  • 2011-07-14 (4241)
    • Takes Orientation in EXIF header of JPEG images into account.
  • 2011-07-07 (4207)
    • GPS traces can be coloured with respect to the direction.
  • 2011-06-18 (4142)
    • Extrude Mode: A double click at a line segment inserts a new point.
  • 2011-06-11 (4126, 4129, 4134)
    • Memory optimizations and faster drawing of GPX tracks
    • New drawing mode: Add a parallel way next to an existing one. (Shift + P)
  • 2011-05-16 (4081, 4085, 4086)
    • New Follow Line feature to ease drawing of adjacent areas. (similar to Potlatch 2's "F" shortcut)
    • Search (and Filter) can query closed ways now, and those enclosing a certain minimum and maximum area. (Keywords: closed; areasize:MIN-MAX or areasize:MAX, in m²)
    • The download Object... feature now accepts a list of ids.
  • 2011-04-18 (4032)
    • Add multiple customized search strings or background layers with its own icon to the toolbar.
    • Update of re-licensing status display in the user list (green check - agreed, gray check - agreed automatically, red cross - disagreed)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • New Viewport Following function - moves the viewport so that the last placed node is in the center. (Main Menu > View; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Plugins imagery,wmsplugin,slippymap and remotecontrol are integrated into JOSM core.
  • 2010-12-07 (3705)
    • Layers can be displayed transparently. (new button in layer list dialog)
  • 2010-12-07 (3702)
    • Scaling of objects is supported. (Ctrl+Alt in select mode)
    • info To rotate an object click Ctrl+Shift.
  • 2010-11-25 (3669)
    • The Validator plugin has been integrated into the main program.
  • 2010-09-23 (3557, #5427)
    • Change in “Extrude” mode (X): When moving in one direction multiple times, no superfluous nodes remain. (Shift key forces the old behaviour.)
  • 2010-09-14 (3529)
    • For the tags in the properties dialogue, you can directly open the corresponding wiki-page in a browser.
  • 2010-09-03 (o22964)
    • The WMS plugin supports GetCapabilities requests.
  • 2010-08-13 (3431)
    • The new Purge command can clean up data layers.
  • 2010-07-27 (3388)
    • New tagging preset search dialog.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • Search supports searching for role in relation membership.
    • The properties dialog shows position of relation membership.
  • 2010-06-01 (3291)
    • Roles defined in presets are now used. This may result in unexpected validator warnings for relations not yet know to JOSM.
    • Members of selected relations are displayed in a different color than directly selected elements.
  • 2010-04-16 (3189)
    • With the new Filter feature you can temporarily hide certain kinds of objects.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • New dialog to download an object by id and optionally all ways and relations that use this object.
  • 2010-01-28 (2901)
    • New: Create a duplicate of the selected data layer without a file association.
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note to former AgPifoJ users: Now you can open images from the main menu (File > Open...) or from the right click menu of the corresponding GPX-layer.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
    • New Changeset List Dialog displays information about changesets. Changesets can be downloaded, closed and displayed.
  • 2009-12-05 (2575)
    • The plugins utilsplugin and AgPifoJ have been integrated in JOSM core.
  • 2009-11-24 (2513)
    • Projections support parameters and display projection code and world bounds to user.
  • 2009-10-25 (2313)
    • Display of linked state in relation editor now graphical and better understandable.
    • Area names are now also displayed (in light grey) when they fit into the area.
  • 2009-09-16 (2147)
    • The plugin panel in preferences now has a search function. You can search through plugin names, descriptions and versions by providing space-separated search terms in any order.
  • 2009-09-14 (2133)
    • Numerous shortcuts to the preset menu have been added to the default toolbar.
  • 2009-09-13 (2124)
    • JOSM now supports keeping multiple changesets open simultaneously on the server. If you want to change something you notice while making an unrelated change you can now tag that change correctly.
  • 2009-09-13 (2118)
    • The preset menu now has a few top-level categories instead of the previous huge list. That should help with using JOSM on smaller screens and finding more easily.
  • 2009-09-12 (2109)
    • New middle click handling allows to toggle selection between elements below cursor. This allows much easier selection of overlapping elements.
  • 2009-09-02 (2026)
    • When in delete mode the mouse pointer will change depending on the type of object about to be deleted.
  • 2009-07-15 (1790)
    • Complete rework of relation editor.
  • 2009-07-11 (1767)
    • JOSM plugins now support different versions (at least the SVN managed plugins). Plugin updates no longer cause plugin malfunction.
  • 2009-07-07 (1743)
    • JOSM now has easy usable support for external presets and drawing styles. Have a look at Presets and Styles pages.
  • 2009-06-28 (1709)
    • Support for element history display inside of JOSM.
  • 2009-06-07 (1652)
    • New dialog to resolve conflicts (when changed objects have been modified elsewhere).
  • 2009-05-30 (1628)
    • Settings are now stored in UTF-8. Users with non-latin GUI may need to fix own texts or reset configuration.
  • 2009-05-19 (1605)
    • JOSM's default projection is now Mercator instead of EPSG:4326 which was previously the default.
  • 2009-05-19 (1603)
    • New parent and child search operators make it possible to search for parent and child objects of those objects that match a given search query.
  • 2009-02-14 (1405)
    • Lots of improvements in draw mode (double clicking ends drawing). Also switching to All-In-One-Potlatch style is possible in preferences.
  • 2009-01-31 (1358)
    • Turn restrictions are displayed in the map, an asterisk next to the relation indicates a problem
    • First step of presets for relations is implemented
  • 2009-01-10 (1231)
    • Files can now also be opened by dropping them onto the JOSM window (Drag-n-Drop).
  • 2009-01-08 (1213)
    • The search function now supports search using regular expressions.
  • 2009-01-03 (1208)
    • The display of node names on the map was enhanced. If no name for a node is given, one of ref, operator or brand is shown instead. Names for unknown features (with no icon) are also displayed now.
  • 2009-01-02 (1203)
    • Rendering of multipolygon relations is now supported. The option "mappaint.multipolygon=true" must be set to do so (will be default later). When there is a * before the relation name, then JOSM found an error. Use current validator plugin to display that error.

2008

  • 2008-12-25 (1180)
    • This release removes lots of obsolete stuff in JOSM. Old plugins very likely wont work anymore. Update everything.
  • 2008-11-28 (1078)
    • If you have the "display boundaries of downloaded data" option enabled (and were until now seeing yellow rectangles for every download), you will now find the non-downloaded area hatched, and the downloaded area clear. This should make for a better editing experience because the actual edit area is not criss-crossed with yellow lines.
  • 2008-11-14 (1076)
    • The "align nodes in rectangle" function has been replaced by a more general function that allows you to orthogonalize any shape or line that already is "almost" rectangular.
  • 2008-10-29 (1058)
    • Translations of JOSM have been restructured. Language plugins are now obsolete and translations have been bundled with JOSM. Language is determined by the default system locale or the --language parameter.
  • 2008-10-05 (1023)
    • WARNING: JOSM now supports keyboard configuration. However, some of the defaults have changed. Please check (and configure) the keyboard shortcuts carefully to avoid losing your work accidentially.
  • 2008-08-24 (858)
    • The unglue action has been integrated. The UnGlue plugin is no longer required.
  • 2008-08-19 (805)
    • This version has a new drawing mode. Little crosses are shown in the middle of way when using the select tool. When these crosses are clicked, they become real nodes. This reduces mode changes a lot. If unwanted, disable the virtual nodes in preferences.
  • 2008-05-20 (643)
    • This version has a minor change to Draw Nodes mode: SHIFT+CLICK now always selects a node when over one (previously it only selected the node when nothing was already selected). This is more consistent, and reduces the number of times you have to switch into Select mode.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • Rubber-band helper line connects last point to prospective next point. To turn this off set the "draw.helper-line" preference to "false".
  • 2008-05-08 (608)
    • Status bar gives information about position, angle and length of line segment that will be added.
  • 2008-05-08 (547)
    • Now includes built-in support for Audio Mapping with continuously recorded sound tracks

Last modified 5 years ago Last modified on 2013-06-25T23:18:39+02:00