wiki:Fr:VersionHistory

Nouvelles sur JOSM plus anciennes

  • 03/10/2017 (version stable 12921)
    • Ajout de liens vers des visualiseurs de changesets dans les fenêtres d' Historique et de Gestion des changesets
    • Ajout d’une case à cocher de demande d’évaluation des données dans la fenêtre d’envoi des données
    • La fonction de création de cercles utilise automatiquement un nombre approprié de nœuds en fonction du diamètre du cercle
    • Nouveaux paramètres de console pour exécuter certaines tâches sans interface graphique d’utilisateur :
      • Rendu des données osm avec un style MapCSS
      • Conversion de coordonnées d'une système de coordonnées de référence à un autre
  • 02/09/2017 (version stable 12712)
  • 30/07/2017 (version stable 12542)
    • Search by preset in the Search window.
    • New "home location" bookmark (if set in the OSM user settings) and bookmarks of the last 15 changesets.
  • 02/07/2017 (version stable 12450)
  • 29/05/2017 (version stable 12275)
  • 02/05/2017 (version stable 12039)
    • Reprojection (warping) des couches d'image : cela permet de combiner des sources avec différentes projections.
  • 02/04/2017 (version stable 11826)
    • Dissuasion de l'envoi de couches de données par l'ajour d'un tag "upload=never" dans le fichier osm
    • Une option a été ajoutée pour ne pas dezoomer après le chargement d'un jeu de données. (seulement en mode expert)
  • 27/02/2017 (version stable 11639)
    • Le mode « GPS Heat Map » possède maintenant des paramètres pour influer sur son rendu
    • On peut maintenant sélectionner des serveurs miroirs dans les « Préférences d'imagerie »
  • 02/02/2017 (version stable 11526)
    • Les traces GPS s'affichent dans le nouveau mode « Heat Map »

2016

  • 31.12.2016 (version stable 11427)
    • Internal database with boundaries of all countries. Single validator rules and mappaint styles can now e.g. be limited to a specific country.
    • Simply dropping or pasting URLs to download data supports now all URL types from the Open Location window.
    • The key and value text boxes in the add value window are prefilled with the next tag of the list below if the first key is already used.
  • 06.11.2016 (version stable 11223)
  • 05.09.2016 (version stable 10966)
  • 12.08.2016 (version stable 10786)
    • Bascule vers Java 8 avec une grosse refonte du noyau de JOSM
    • Nouvelle fonction "Coller à la position originale" dans le menu Editer (Ctrl+Alt+V, seulement en mode expert)
    • Support des URLs geo:
  • 12.07.2016 (version stable 10526)
    • Importante modification du cœur de JOSM
  • 28.04.2016 (version stable 10161)
    • Nouveaux filtres de calque (opacité/saturation/gamma/précision)
  • 13.03.2016 (version stable 9979)
    • OAuth est désormais la méthode d’identification par défaut.
    • Prise en charge du glisser-déposer pour l’éditeur de relation (plus d’information)
    • Nouveau bouton pour rafraîchir la relation dans l’éditeur de relation (par exemple après avoir séparé un chemin)
    • La fenêtre d’historique affiche sur une carte les anciennes et les nouvelles coordonnées d’un noeud ayant été déplacé
    • Zoom automatique à la résolution par défaut des arrière-plans
    • Prise en charge étendue de différentes projections

2015

  • 31 dec. 2015 (version stable 9229)
  • 23 nov. 2015 (version stable 9060)
    • Prise en charge du bokmål norvégien
  • 30 oct. 2015 (version stable 8969)
    • Couper le chemin [P] : l’id et l’historique sont appliqués au plus long des deux segments (les utilisateurs avancés peuvent choisir l’autre segment)
    • Affichage des icônes de nœuds de la carte dans les différentes listes (comme le dialogue de sélection, l’éditeur de relation ou le dialogue d’envoi des données)
  • 28 sept. 2015 (version stable 8800)
    • Intégration du téléchargement Overpass et de l'Overpass Turbo Wizard (Mode avancé uniquement)
    • Ajout d'une minicarte
    • Ajout de liens vers taginfo
    • Sélection de la valeur gamma pour l'imagerie
  • 22.08.2015 (version stable 8677)
  • 17.06.2015 (version stable 8491)
    • Support du biélorusse
    • Support du vietnamien
  • 2015-04-18 (8227)
    • Support du valencien
  • 2015-03-31 (8160)
    • Support du lituanien
  • 2015-03-02 (8109)
    • Plus de polices disponibles pour supporter plus de langues dans Windows ;
    • Certains greffons peuvent être installés et utilisés sans nécessiter le redémarrage de JOSM ;
    • Nouvelle boîte de recherche pour le menu principal (en haut à droite) ;
    • Le support des Notes est maintenant activé par défaut dans le noyau (le greffon est obsolète).
  • 2015-02-18

2014

  • 2014-12-29 (7906)
    • Deux nouvelles langues supportées : l’asturien et le khmer.
    • Les dossiers de stockage des préférences, des données utilisateurs et du cache ont été déplacés sous OS X (Apple) et Windows (Microsoft).
  • 2014-12-10 (7777)
    • Nouveau logo conçu par Diamond00744.
    • Possibilité d’envoyer et de télécharger des notes OSM.
    • Remplacement dans le menu latéral de l’icône de consultaton de l’historique au profit d’un bouton historique dans le panneau de sélection.
  • 2014-10-21 (7643)
    • Correction des principales anomalies rencontrées dans les raccourcis clavier et la gestion des conflits de la commande Fusionner les chemins C.
  • 2014-09-30 (7588)
    • Meilleure intégration de OS X (voir #10455 pour plus de détails).
    • Affichage des balises OSM dans l’interface utilisateur des attributs.
  • 2014-09-20 (7569)
    • JOSM émet maintenant des avertissements pour les anciens styles de multipolygones, qui peuvent être résolus par le transfert des balises pertinentes des chemins extérieurs (outer) à la relation correspondante.
  • 2014-08-31 (7480)
    • Amélioration du style de carte par défaut :
      • Les symboles des Nœuds et les icônes sont masqués aux faibles zooms (c’est configurable dans le réglage des styles) ;
      • Meilleur placement des libellés à l'intérieur des surfaces ;
      • Les noms des routes (highway) sont affichés sur le long.
    • Le mode déconnecté (Offline) est disponible avec le nouveau paramètre de ligne de commande --offline=[josm_website|osm_api|all].
  • 2014-07-20
    • Nous lançons un concours de graphisme qui durera jusqu'au 30 septembre pour renouveller le logo de JOSM ! Voir les détails sur le wiki.
  • 2014-07-04 (7287)
    • Nouveau mode d'extension d'une surface (double alignement) dans l'action Extrude X
    • Rechargement automatique des styles du rendu local et des règles du validateur
    • Mise à jour automatique du catalogue d'imageries
  • 2014-05-18 (7139)
    • Le style de carte par défaut de JOSM a été modifié de XML à MapCSS
  • 2014-05-15 (7131)
  • 2014-04-25 (7001)
    • Bascule sur la version 7 de Java, beaucoup de nettoyage du code
  • 2014-03-30 (6950)
  • 2014-02-28 (6891)
    • Permet l'accès à l'API OSM en HTTPS
  • 2014-01-29 (6767)
    • Nouveau vérificateur de Tag basé sur MapCSS, extensible avec des règles personnalisées
    • Ajout d'une action "Search for objects by preset" Maj-F3
    • Améliorations des préréglages, des MapCSS et de Validateur

2013

  • 2013-12-20 (6502)
    • Ajout d'un champ de saisie de la source dans la boîte de dialogue d'envoi des données
    • Boîte de dialogue de l'historique des éléments Ctrl-H : Affichage des commentaires de chaque groupe de changements
    • Nouveau mode source:trunk/images/mapmode/improvewayaccuracy.png Amélioration du tracé des chemins W disponible pour les non-experts
    • Plein d'autres améliorations et corrections de bugs (changelog)
  • 2013-11-17 (6388)
    • Mise à jour des fichiers de traduction
  • 2013-11-12 (6383)
    • Une nouvelle commande pour séparer un nœud d'un chemin
    • Signalement de l'arrivée de nouveaux messages OSM
    • Et toujours plein de petites améliorations des réglages, des styles et du validateur et de bien d'autres parties encore
  • 2013-09-20 (6238)
    • Nouveaux messages de notification non-intrusifs
    • Nouvel élément "Fichier/Session" disponible en mode expert
    • Support complet des routes GPX
    • et toujours plein d'améliorations des réglages, des styles et amélioration des performances du validateur
  • 2013-08-07 (6115)
    • Demande d'authentification OAuth pour supporter pleinement le nouveau greffon notes
    • Refonte des menus greffons pour permettre de meilleurs regroupements et intégrations
    • Choix du nœud fils du (dernier) objet sélectionné lors d'une sélection de nœuds superposés
    • Plein d'autres améliorations et corrections de bugs (changelog)
  • 2013-07-09 (6060)
  • 2013-06-05 (5990)
    • Possibilité de définir des raccourcis clavier ou d'autres boutons de barre d'outils et ajout de l'élément de menu "Edition des raccourcis" pour les modifier
    • Zoom automatique pour les couches WMS
    • Nouvelle fonction de masquage des panneaux avec TAB
  • 2013-05-08 (5939)
    • Intégration du greffon "Restart" dans le code de JOSM
    • Menu clic-droit "Annuler, Couper, Copier, Coller, Supprimer, Tout sélectionner" pour chaque champ texte
    • Amélioration des performance de la commande Purger
  • 2013-04-08 (5836)
    • Modification importante des menus contextuels
    • Ajout d'un bouton "clear buffer" pour supprimer les buffers incorrects lors d'une action "Coller les attributs (Ctrl-Maj-V)"
    • Suppression du support (déjà déprécié) du serveur de décalage d'image
  • 2013-03-07 (5759)
    • Ctrl-Maj-V permet maintenant de coller des attributs depuis le presse-papier, par ex. a=2,c=3 et a 2 c 3
    • Nombreuses améliorations du rendu MapCSS
    • Permet le déplacement de nœuds dans Extrude mode
    • Menu contextuel dans les propriétés du dialogue Ajouter/Editer, option pour corriger le plan de clavier
    • Simplification du filtrage des dates dans les traces GPS
    • Contrôle à distance : permet la suppression des tags et la création d'objets avec des tags
    • Plein d'autres améliorations mineures et de corrections de bugs
  • 2013-02-06 (5697)
    • Suggestion des rôles dans l'éditeur et lors de la création de relations
    • Ajout d'un filtre dans la liste des relations
    • Plusieurs améliorations du dialogue "Ajouter un attribut" comme l'ajout d'un bouton d'aide, la mémorisation de la position précédente, la possibilité d'ajouter plusieurs attributs sans refermer ce dialogue
    • Nouveau type d'imagerie wms_endpoint et retouche du dialogue WMS/TMS
    • Nouveaux tests du validateur pour les adresses et les liens Wikipédia, amélioration des performances du rendu des couches et correction d'erreurs
    • et plein d'améliorations mineures

2012

  • 2012-12-08 (5608)
    • Les nouveaux opérateurs nth: et nth% permettent la recherche du node d'un rang particulier dans un way
    • De petites améliorations du contrôle à distance et de réglages internes
  • 2012-11-10 (5576)
    • Ajout du support de l'unité de mesure "Mille Nautique" [NM] (cf. Nq / Nautique)
  • 2012-10-08 (5531)
    • Réécriture du test des bâtiments du Validate
    • Des tags supplémentaires sont automatiquement supprimés lors des uploads (TIGER, odbl, yh)
    • Le code concernant le changement de licence a été supprimé
  • 2012-08-29 (5482, 5485)
    • Les fournisseurs d'imagerie sont suggérés, en fonction de la zone téléchargée.
    • Lors de l'ajout d'attributs à des nœuds, chemins ou relations, les cinq derniers tags sont affichés pour une sélection plus rapide.
    • Meilleur support des multipolygones dans l'outil Filtre
    • Vous ne pouvez plus ouvrir un dossier dans la boîte de dialogue "Fichier > Ouvrir..." et charger automatiquement toutes ses photos automatiquement. A la place, sélectionnez directement les images (en utilisant Ctrl-A ou Maj-Clic). L'outil "Importer des images" du menu contextuel d'un calque GPX fonctionne encore à l'ancienne, de sorte que vous pouvez charger des photos récursivement en ouvrant un répertoire de plus haut niveau.
  • 2012-07-23 (5353, 5356)
    • correction de problèmes majeurs dans la gestion des données modifiées par le bot de révision pour la nouvelle licence OSM
    • légères améliorations du rendu de carte et des tests de validation, qui incluent le rendu des calques inactifs et l'affichage des noms dans la fenêtre de validation
  • 2012-07-03 (5315)
    • grosses corrections de bug dans le Validateur de données, le Dialogue des conflits et lors de la fusion de calques
    • plusieurs améliorations dans le Dialogue des conflits, comme l'option Sélectionner (double-clic) et le zoom sur les éléments (menu contextuel)
    • plusieurs améliorations dans les tests du Validateur de données
  • 2012-06-04 (5267)
    • nouvelles langues : portugais (européen) (pt) et catalan (ca)
    • support de projections spécifiques
    • déplacement des tags vers la relation à la création d'un multi-polygone
  • 2012-05-02 (5210)
    • Cette version ne comporte que des modifications mineures
      • Le menu de recherche alternatif est présenté par défaut (en test) ;
      • La ligne de commande accepte un nouveau paramètre --load-preferences= pour charger vos préférences ;
      • MapCSS gère différemment le style des éléments latéraux (comme les voies cyclables).
  • 2012-04-14 (5181)
    • La page d'accueil de josm.openstreetmap.de a été simplifiée et ré-organisée
    • Une nouvelle version stable (5181) est disponible et contient de nombreuses modifications/améliorations, qui incluent
      • source:trunk/images/mapmode/rope.png le mode de sélection Lasso (mode avancé)
      • des fenêtres d'information pour les débutants: avertissement contre les sources d'imagerie mal alignées, lorsque sont combinés des chemins avec des tags en conflit ou des chemins faisant partie de relations
      • de nouvelles fonctions pour l'édition de relations: "Ajouter la sélection à la relation" (dans le menu contextuel d'une relation), "Sélectionner la séparation précédente/suivante" (dans l'éditeur de relations)
      • des améliorations de l'interface utilisateur dans le menu Affichage: Styles de coloriage, possibilité de masquer la barre d'édition
      • plusieurs améliorations du temps de démarrage
  • 2012-02-07 (4905)
    • Des raccourcis ont été ajoutés pour l'éditeur de relations : Alt-Up, Alt-Down (déplacer des membres sélectionnés vers le haut, le bas), Alt-Del (supprimer un membre) and Alt-Home (télécharger des membres incomplets) ;
    • Un résumé des modifications est disponible et décrit les modifications réalisées depuis la dernière version stable.
  • 2012-02-02 (4897 ...)
    • Correction des conflits entre JOSM et ses greffons. De nombreux raccourcis vont changer de fonction, attention !
  • 2012-01-22 (4846)
    • Le greffon ImproveWayAccuracy a été intégré au module principal. Sélectionner un chemin, cliquer sur source:trunk/images/mapmode/improvewayaccuracy.png, et améliorer sa précision. Vérifier la page d'aide pour des détails sur son utilisation.
  • 2012-01-21 (4791, 4796, 4833)
    • Diverses extensions pour la fonction de Contrôle à distance: commande '/load_object' pour télécharger des objets par leur ID; commande '/add_way' pour créer un chemin avec certaines coordonnées; paramètre 'new_layer' pour la commande '/load_and_zoom' pour charger les données dans un nouveau calque.
  • 2012-01-12 (4789)
    • Nouvelle option de la ligne de commande pour positionner une valeur de préférence au démarrage. (ex: --set=expert=true)
  • 2012-01-07 (4767, 4768)
    • La mise en surbrillance des nœuds et chemins sous le curseur de la souris peut être désactivée : 'Préférences' > 'Paramètre d'affichage' > 'Données OSM' (Uniquement en mode avancé)
    • L'outil Dessiner des nœuds source:trunk/images/mapmode/node/autonode.png permet de dessiner des segments avec des angles distincts (par exemple, 30/45°). Appuyez sur la touche de tabulation pour faire défiler les différents modes.
  • 2012-01-04 (4765)
    • Le masquage automatique des boutons dynamiques dans les fenêtres latérales de droite peut être désactivé individuellement pour chaque fenêtre. (Symbole en forme d’œil dans le coin supérieur droit)

2011

  • 2011-12-29 (4745)
    • Nouvelle commande pour charger et mettre en cache les images de fond WMS le long d'une trace GPX. (Dans le menu contextuel du calque GPX)
  • 2011-12-20 (4673)
    • La projection Lambert 93 (EPSG:2154) est disponible pour la France.
  • 2011-12-20 (4670)
    • Les langues arabe, islandaise et hébraïque ont été retirées en raison d'efforts de traduction insuffisants.
  • 2011-12-05 (4621-4636)
    • Les performances avec de gros multipolygones sont améliorées.
  • 2011-11-26 (4609, 4611)
    • Les boutons de la barre d'outils d'édition (zone de gauche) peuvent être masqués individuellement.
    • En mode création de chemins, la touche retour arrière annule la dernière action.
  • 2011-11-20 (4601)
    • L'historique des versions affiche désormais le statut d'acceptation de la licence de chaque contributeur.
  • 2011-11-15 (4595)
    • Support des raccourcis clavier en plusieurs parties. Par exemple, Ctrl+Alt+S, 1 modifie la visibilité du premier calque.
  • 2011-11-14 (4593)
    • Sur les écrans de faible résolution, les longs menus ne sont plus tronqués, mais peuvent être défilés verticalement.
  • 2011-11-07 (4587)
    • Nouvelle option dans la fenêtre de recherche pour ajouter un bouton de recherche dans la barre d'outils. Ce bouton peut-être retiré plus tard par son menu contextuel (clic droit). (Seulement en mode expert.)
  • 2011-11-02 (4558)
  • 2011-10-31 (4553)
    • Le format interne d'enregistrement des préférences utilisateur a été modifié en XML.
  • 2011-10-29 (4546)
    • L'affichage textuel des nœuds, chemins et relations peut-être personnalisé avec des modèles de noms.
  • 2011-10-20 (4530)
    • Le format OsmChange (*.osc) est officiellement supporté.
  • 2011-10-10 (4512)
    • Mode Expert introduit pour réduire la complexité pour les nouveaux utilisateurs. Pour la compatibilité, les installation existantes sont en mode expert par défaut.
  • 2011-10-07 (4497, 4498, 4500)
    • Nouvelles options dans la boîte de dialogue 'Fichier > Télécharger un objet...'.
    • Historique: Meilleur affichage des nœuds insérés / supprimés dans un chemin (et des membres de relation).
    • Nouveaux raccourcis dans la fenêtre d'attributs: Alt+A, Alt+S, Alt+D pour ajouter, éditer, supprimer.
  • 2011-09-23 (4454)
    • Copie d'une clé et de sa valeur vers le presse-papiers par clic droit dans la fenêtre d'attributs.
  • 2011-09-12 (4416, 4423)
    • Les limites des services d'imagerie sont affichées sur une carte de prévisualisation dans 'Préférences > Imagerie'.
  • 2011-09-08 (4408)
    • L'item 'Inspecter' du menu contextuel de la fenêtre de sélection a été déplacé vers 'Affichage > Infos avancées'.
  • 2011-09-07 (4405)
    • La liste dans 'Préférences > Imagerie' est triée par code de pays.
  • 2011-08-29 (4380)
    • Nouvelle fonctionnalité 'Modifier > Copier les coordonnées'.
  • 2011-08-28 (4371)
    • La liste des fichiers ouverts récemment affiche également les fichiers enregistrés récemment.
  • 2011-08-27 (4355)
    • Affichage dynamique de la barre de boutons des fenêtres de droite (optionnel, préférence avancée 'dialog.dynamic.buttons=true').
  • 2011-08-22 (4333)
    • Raccourcis pour basculer la visibilité des calques (Alt-1 à Alt-9)
  • 2011-08-21 (4332)
    • Sélection des traces visibles, pour chaque calque GPX (depuis le menu contextuel du calque)
  • 2011-08-21 (4327)
    • Les modes de sélection et de suppression ont maintenant une meilleure indication visuelle de ce que la prochaine action va être (surbrillance, apparence du pointeur).
  • 2011-07-18 (4256)
    • Support du format image SVG.
  • 2011-07-14 (4241)
    • Prise en compte de l'orientation dans l'en-tête EXIF des images JPEG.
  • 2011-07-07 (4207)
    • Les traces GPS peuvent être colorées en fonction de leur direction.
  • 2011-06-18 (4142)
    • Mode Extrusion : Un double-clic sur un segment de ligne insert un nouveau point.
  • 2011-06-11 (4126, 4129, 4134)
    • Optimisation de la mémoire et dessin plus rapide des traces GPX.
    • Nouveau mode de dessin : ajout d'un chemin parallèle (Maj + P).
  • 2011-05-16 (4081, 4085, 4086)
    • Nouvelle fonction suivi de ligne pour dessiner facilement des objets adjacents (similaire au raccourci "F" de Potlatch 2).
    • La recherche et le filtrage peuvent maintenant se limiter aux chemins fermés ou à une superficie minimale ou maximale (mots-clés : closed; areasize:MIN-MAX ou areasize:MAX, en m²).
    • L'outil Télécharger un objet accepte maintenant une liste d'identifiants.
  • 2011-04-18 (4032)
    • Ajout de recherches personnalisées multiples ou de couches de fond à l'aide d'icônes personnalisables dans la barre d'outils.
    • Le statut du changement de licence apparaît dans la liste des contributeurs (coche verte : accord, coche grise : accord automatique, croix rouge : désaccord)
  • 2011-02-15 (3906)
  • 2011-02-02 (3848-3904)
  • 2011-02-01 (3837)
    • Nouvelle fonction "Viewport Following" - déplace la vue pour que le dernier nœud placé soit au centre. (Menu principal > Affichage; Ctrl+Shift+F)

2010

  • 2010-12-12 (3715)
    • Les greffons imagery,wmsplugin,slippymap et remotecontrol sont intégrés au noyau de JOSM.
  • 2010-12-07 (3705)
    • Les calques peuvent être affichés avec transparence. (nouveau bouton dans le dialogue de liste des calques)
  • 2010-12-07 (3702)
    • Le redimensionnement d'objets est possible. (Ctrl+Alt dans le mode sélection)
    • info Pour pivoter un objet faire clic Ctrl+Maj.
  • 2010-11-25 (3669)
    • Le greffon Validator a été intégré dans le programme principal.
  • 2010-09-23 (3557, #5427)
    • Changement dans le mode « Créer des surfaces » (X) : en bougeant dans la même direction plusieurs fois, il n'y a plus de nœud superflu qui reste. (la touche Maj permet de forcer l'ancien comportement.)
  • 2010-09-14 (3529)
    • Pour chaque balise dans le dialogue des propriétés, il est possible d'ouvrir directement la page wiki correspondante dans un navigateur.
  • 2010-09-03 (o22964)
    • Le greffon WMS supporte les requêtes GetCapabilities.
  • 2010-08-13 (3431)
    • La nouvelle commande Purger permet de nettoyer des calques de données OSM.
  • 2010-07-27 (3388)
    • Nouveau dialogue de recherche de balises prédéfinies.
  • 2010-07-20 (3378)
  • 2010-06-03 (3306)
    • La recherche permet de rechercher un rôle parmi les membres d'une relation.
    • Le dialogue des propriétés indique la position des membres d'une relation.
  • 2010-06-01 (3291)
    • Les rôles définis dans les pré-réglages sont maintenant utilisés. Cela peut conduire à des avertissements inattendus du validateur, si les relations ne sont pas encore connues de JOSM.
    • Les membres des relations sélectionnées sont affichés dans une couleur différente des éléments directement sélectionnés.
  • 2010-04-16 (3189)
    • Avec la nouvelle fonction de filtrage, il est possible de masquer temporairement certains types d'objets.
  • 2010-03-15 (3136)
  • 2010-02-02 (2923)
    • Nouveau dialogue pour télécharger un objet par son id et éventuellement tous les chemins et relations qui utilisent cet objet.
  • 2010-01-28 (2901)
    • Nouveau : Vous pouvez créer une copie de la couche de données sélectionnée sans l'associer à un fichier
  • 2010-01-06 (2748)

2009

  • 2009-12-31 (2717)
    • Note aux anciens utilisateurs de AgPifoJ : Vous pouvez désormais ouvrir les images depuis le menu principal (Fichier > Ouvrir...) ou en faisant un clic droit sur le calque GPX correspondant.
  • 2009-12-27 (2689)
  • 2009-12-12 (2616)
  • 2009-12-05 (2575)
    • Les greffons utilsplugin et AgPifoJ ont été intégrés directement à JOSM.
  • 2009-11-24 (2513)
    • Les projections acceptent des paramètres et affichent à l'utilisateur le code et l'emprise de la projection.
  • 2009-10-25 (2313)
    • L'état des liens dans l'éditeur de relation s'affiche maintenant graphiquement et est de ce fait plus lisible.
    • Les noms de surfaces sont désormais inscrits (en gris clair) quand ils peuvent s'insérer dans la surface.
  • 2009-09-16 (2147)
    • La page des greffons dans les préférences a désormais une fonction de recherche. Vous pouvez rechercher par nom de greffon, description ou version en saisissant des mots séparés par un espace.
  • 2009-09-14 (2133)
    • De nombreux raccourcis du menu Balises ont été ajoutés à la barre d'outils standard.
  • 2009-09-13 (2124)
    • JOSM accepte désormais de garder ouverts sur le serveur plusieurs ensembles de changements simultanément. Si vous souhaitez modifier quelque chose que vous remarquez durant une autre série de changements, vous pouvez désormais l'étiqueter correctement.
  • 2009-09-13 (2118)
    • Le menu des balises n'a plus désormais que quelques catégories principales au lieu de l'immense liste précédente. Cela devrait permettre d'utiliser JOSM plus facilement sur de petits écrans et de trouver plus facilement les balises.
  • 2009-09-12 (2109)
    • La nouvelle gestion du bouton milieu de la souris permet de choisir entre les différents éléments présents sous le curseur. Ceci facilite la sélection des éléments superposés.
  • 2009-09-02 (2026)
    • Lorsque le mode suppression est activé, le curseur de la souris changera en fonction du type d'objet à supprimer.
  • 2009-07-15 (1790)
    • Réécriture complète de l'éditeur de relations.
  • 2009-07-11 (1767)
    • Les greffons de JOSM supportent désormais plusieurs versions (tout du moins les greffons gérés par SVN). La mise à jour des greffons ne provoque plus de disfonctionnement de ceux-ci.
  • 2009-07-07 (1743)
    • JOSM a désormais un support fonctionnel des balises et des styles d'affichage externes. Veuillez consulter les pages Presets et Styles.
  • 2009-06-28 (1709)
    • Support de l'affichage de l'historique des éléments au sein de JOSM.
  • 2009-06-07 (1652)
    • Nouvelle page de dialogue de résolution de conflits (lorsqu'un objet a été modifié par ailleurs).
  • 2009-05-30 (1628)
    • Les paramètres sont désormais stockés en UTF-8. Les utilisateurs avec une interface non-latine devront peut-être retoucher les textes ou réinitialiser leur configuration.
  • 2009-05-19 (1605)
    • La projection par défaut de JOSM est maintenant Mercator à la place de EPSG:4326 qui était l'ancien choix par défaut.
  • 2009-05-19 (1603)
    • De nouveaux opérandes parent et child permettent de rechercher les objets parents et enfants des objets répondant a un critère de recherche.
  • 2009-02-14 (1405)
    • Beaucoup d'améliorations en mode tracé (double cliquer termine un chemin). Le passage au style Potlatch-tout-en-un est désormais possible dans les préférences.
  • 2009-01-31 (1358)
    • Les interdictions de tourner sont affichées sur la carte et utilisent les mêmes vérifications que les multipolygones (une étoile indique une erreur)
    • Première étape pour l'intégration des relations dans le menu "Prédéfinis"
  • 2009-01-10 (1231)
    • Les fichiers peuvent maintenant être ouverts en les glissant sur la fenêtre de JOSM (glisser-déposer).
  • 2009-01-08 (1213)
    • La fonction de recherche supporte maintenant les expressions régulières.
  • 2009-01-03 (1208)
    • L'affichage du nom des noeuds sur la carte a été amélioré. Si aucun nom n'est donné à un noeud, la référence, l'opérateur ou la marque est affiché à la place. Les noms des fonctions inconnues (sans icône) sont également affichés désormais.
  • 2009-01-02 (1203)
    • Le rendu des relations multipolygonales est maintenant supporté. L'option "mappaint.multipolygon=true" doit être définie pour cela (sera activée par défaut plus tard). Lorsqu'il y a une * au début du nom de la relation, c'est que JOSM a trouvé une erreur. Utilisez le greffon Validator pour afficher cette erreur.

2008

  • 2008-12-25 (1180)
    • Cette version supprime un grand nombre de choses obsolètes de JOSM. Les anciennes versions des greffons ont peu de chance de fonctionner. Mettez tout à jour.
  • 2008-11-28 (1078)
    • Si vous avez activé l'option "Afficher les limites des donnés téléchargées" (et voyiez des rectangles jaunes pour chaque téléchargement), vous devriez désormais trouver les zones non téléchargées barrées et les zones téléchargées vides. Cela devrait améliorer l'expérience d'édition car la zone d'édition en cours ne sera plus couverte de lignes jaunes.
  • 2008-11-14 (1076)
    • La fonction "aligner les nœuds en rectangle" a été remplacée par une fonction plus générale qui vous permet d'orthogonaliser n'importe quelle forme ou ligne qui est déjà "presque" rectangulaire.
  • 2008-10-29 (1058)
    • Les traductions de JOSM ont été restructurées. Les plugins Langue sont maintenant obsolètes et les traductions ont été intégrées à JOSM. La langue est déterminée par la variable système locale ou le paramètre --language.
  • 2008-10-05 (1023)
    • ATTENTION: JOSM supporte maintenant la configuration du clavier. En conséquence, certaines combinaisons par défaut ont changé. Vérifier (et configurer) les raccourcis clavier avec soin pour éviter de perdre votre travail accidentellement.
  • 2008-08-24 (858)
    • La séparation des chemins est intégrée. Le greffon UnGlue n'est plus nécessaire.
  • 2008-08-19 (805)
    • Cette version a un nouveau mode de dessin. De petites croix sont représentées en cours de chemin quand on utilise loutil de sélection. En cliquant sur ces croix, on les transforme en nœuds réels. Cela réduit beaucoup les changements de modes. Dé-sélectionner les nœuds virtuels dans préférences, si vous ne désirez pas cette fonction.
  • 2008-05-20 (643)
    • Cette version inclue un changement mineur au mode "Dessiner des nœuds": maintenant SHIFT+CLICK sélectionne toujours un nœud lorsque le curseur en survole un (auparavant le nœud n'était sélectionné qui si rien n'était déjà sélectionné). C'est plus consistent, et cela réduit le nombre de fois où il est nécessaire de passer en mode de sélection.
  • 2008-05-08 (608)
  • 2008-05-08 (608)
    • La ligne élastique connecte le dernier point au point prospectif suivant. Pour désactiver ce comportement, positionnez la préférence "draw.helper-line" à "false".
  • 2008-05-08 (608)
    • La barre de statut donne les informations de position, angle et longueur du segment à ajouter.
  • 2008-05-08 (547)
    • Contient maintenant le support intégré de Audio Mapping avec pistes audio enregistrées en continu

Last modified 5 years ago Last modified on 2013-06-25T23:18:19+02:00