Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9996 closed defect (invalid)

cadastre-fr

Reported by: Muselaar Owned by: team
Priority: normal Milestone:
Component: Plugin cadastre-fr Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. launch JOSM
  2. select Cadastre>télécharger le cadastre (F10)
  3. select département, and commune
  4. error

What is the expected result?
« Une exception inattendue pouvant provenir du greffon 'cadastre-fr' est survenue. D’après les informations du greffon, l’auteur est Pieren. Essayez de mettre à jour le greffon vers une version plus récente avant de rapporter l’erreur. »

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-08 01:38:32
Last Changed Author: Don-vip
Revision: 7076
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-08 02:54:38 +0200 (Thu, 08 May 2014)
Last Changed Rev: 7076

Identification: JOSM/1.5 (7076 fr) Linux Debian GNU/Linux 7.4 (wheezy)
Memory Usage: 162 MB / 821 MB (42 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u25-2.3.10-1~deb7u1

Plugin: DirectDownload (30416)
Plugin: ImageWayPoint (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: cadastre-fr (28912)
Plugin: colorscheme (28912)
Plugin: conflation (0.1.6)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1010)
Plugin: dataimport (30416)
Plugin: editgpx (28912)
Plugin: geochat (30416)
Plugin: geotools (30416)
Plugin: jts (30416)
Plugin: measurement (28912)
Plugin: print (30416)
Plugin: routes (30416)
Plugin: utilsplugin2 (30419)
Plugin: wikipedia (30416)

java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/projection/LambertCC9Zones
	at cadastre_fr.MenuActionNewLocation.addNewLayer(MenuActionNewLocation.java:118)
	at cadastre_fr.MenuActionNewLocation.actionPerformed(MenuActionNewLocation.java:58)
	at cadastre_fr.MenuActionGrab.actionPerformed(MenuActionGrab.java:44)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.projection.LambertCC9Zones
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 42 more

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin cadastre-fr
Resolution: invalid
Status: newclosed

You're not using the last (and correct) version of the plugin but a very old one. Please update your plugins. Correct and current version is 30416, you're using 28912.

comment:2 Changed 4 years ago by skyper

Be careful with the debian package josm-plugins as JOSM will always use these plugins and no newer ones even though it does download them. See #7483.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.